B6.7 CM2670 B153B

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 01-Feb-2020
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Engine power derate.
Engine Control Module

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1117 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Condition Exists

FAULT CODE 11267

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 11267 PID: SPN: 3610 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after one trip where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading

High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

  • Bulk fuel supply may be contaminated.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 11267 .

Last Modified: 07-Feb-2021


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Special Instructions

FAULT CODE 11268

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 11268 PID: SPN: 3610 FMI: 14/14 LAMP: Red SRT: | The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • An engine speed derate will occur when the fault is registered.

Conditions for Clearing the Fault Code

  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading

High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

  • Bulk fuel supply may be contaminated.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 11268 .

Last Modified: 07-Feb-2021


Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1139

Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S1 SPN: 651 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1139 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1141

Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S2 SPN: 652 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1141 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1142

Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S3 SPN: 653 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1142 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1143

Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S4 SPN: 654 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1143 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1144

Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S5 SPN: 655 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1144 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1145

Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S6 SPN: 656 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1145 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 122 .

Last Modified: 17-Feb-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 123 .

Last Modified: 17-Feb-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1239 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake manifold pressure is above the maximum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was higher than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • High exhaust restriction.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 124 .

Last Modified: 17-Feb-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor

Damaged accelerator pedal position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1241 .

Last Modified: 01-Feb-2020


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2

Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1242 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions.

Possible causes of this fault code include:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • A damaged barometric pressure sensor
  • Restriction in the charge-air cooler
  • Fuel inlet restriction too high (normally caused by a restricted fuel filter).
Refer to Troubleshooting Fault Code 125 .

Last Modified: 17-Feb-2020


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 131 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

FAULT CODE 13138

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 13138 PID: SPN: 3251 FMI: 10/10 LAMP: Amber SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had reached the first stage of plugging.

Action Taken When the Fault Code is Active

The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.

The ECM will flash the aftertreatment dash lamp as the severity of the soot load increases.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter

Possible engine damage that causes excessive black smoke to be generated.

  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 13138 .

Last Modified: 20-Jun-2021


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 132 .

Last Modified: 01-Feb-2020


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 133 .

Last Modified: 07-Feb-2021


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged remote accelerator pedal or lever position sensor
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 134 .

Last Modified: 07-Feb-2021


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144 .

Last Modified: 01-Feb-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145 .

Last Modified: 01-Feb-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | Engine torque output will be reduced.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

  • Restricted air flow through the radiator.
  • Low coolant level
  • Malfunctioning or damaged coolant temperature sensor.

A malfunctioning fan clutch solenoid

  • Malfunctioning engine coolant thermostat.
  • A malfunctioning water pump.
Refer to Troubleshooting Fault Code 146 .

Last Modified: 20-Jun-2021


Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 14671

Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 14671 PID: SPN: 5246 FMI: 0/0 LAMP: None SRT: | Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Vehicle speed will be limited to 20 km [12 miles] per hour.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

  • Engine torque will be reduced.
  • Vehicle Speed will be limited to 20 km [12 mi] per hour.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, and indicates that an engine power derate and vehicle speed limit have been implemented in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 14671 .

Last Modified: 30-Jan-2022


Engine Protection Torque Derate - Condition Exists

FAULT CODE 14672

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 14672 PID: SPN: 1569 FMI: 11/31 LAMP: None SRT: | Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 14672 .

Last Modified: 30-Jan-2022


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 113°C [ 235°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151 .

Last Modified: 01-Feb-2020


Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 01-Apr-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located in the air intake horn.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 95°C [203°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1668 .

Last Modified: 06-Sep-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the catalyst tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

  • Vehicle Speed will be limited to 20 km [12 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1669 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1671

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1671 PID: SPN: 1761 FMI: 1/18 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The diesel exhaust fluid tank level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Low aftertreatment diesel exhaust fluid level has been detected in the diesel exhaust fluid tank.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Fault code 1671 is triggered when low diesel exhaust fluid level has been detected in the diesel exhaust fluid tank. Add diesel exhaust fluid to the tank. This fault code is only a warning for low diesel exhaust fluid tank solution level.

Refer to Troubleshooting Fault Code 1671 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

  • The diesel exhaust fluid lamp will be flashing.
  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be severely reduced.

  • Vehicle speed will be limited to 20 km [12 mi] per hour after the engine has been shutdown, 1 hour of engine idle time, or the fuel tank has been refilled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically.This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code 1673 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1677 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1678 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

In-range failure of the diesel exhaust fluid tank temperature sensor

Damaged wiring harness

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1679 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | Engine power derate.
Engine Control Module

Circuit Description

For an air-assisted SCR aftertreatment system, the aftertreatment diesel exhaust fluid dosing unit requires air pressure from the OEM air tanks in order to prime and help carry the diesel exhuast fluid from the dosing unit to the aftertreatment nozzle. The diesel exhaust fluid dosing unit precisely measures the amount of diesel exhaust fluid to be injected into the aftertreatment system. The diesel exhaust fluid dosing unit has three primary cycles: priming, dosing, and purging. The priming cycle occurs at initial engine start makes sure that diesel exhaust fluid is available at the diesel exhaust fluid dosing unit. During the dosing cycle, the diesel exhaust fluid is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle confirms that all the diesel exhaust fluid is removed from the diesel exhaust fluid lines and aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank

Blocked or restricted diesel exhaust fluid tank filter

Blocked, restricted, kinked, broken, disconnected or frozen diesel exhaust fluid supply lines

Refer to Troubleshooting Fault Code 1682 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1685

Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1685 PID: SPN: 3364 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage below normal, or shorted to low source | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
  • Short to ground in the wiring harness
Refer to Troubleshooting Fault Code 1685 .

Last Modified: 01-Sep-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1686

Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1686 PID: SPN: 3364 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage above normal, or shorted to high source | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid quality sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Short circuit to voltage source in the OEM harness

Refer to Troubleshooting Fault Code 1686 .

Last Modified: 01-Sep-2021


Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 5298 FMI: 1/18 LAMP: Amber SRT: | The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning diesel oxidation catalyst

Malfunctioning fuel injectors

Refer to Troubleshooting Fault Code 1691 .

Last Modified: 01-Feb-2020


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1695 .

Last Modified: 01-Feb-2020


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the aftertreatment diesel exhaust fluid tank level/tank temperature sensor, remote accelerator, engine coolant level sensor, fan speed sensor, and the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1696 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

FAULT CODE 1714

Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1714 PID: SPN: 3364 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaut Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1714 .

Last Modified: 01-Sep-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

FAULT CODE 1715

Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1715 PID: SPN: 3364 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1715 .

Last Modified: 01-Sep-2021


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843 .

Last Modified: 01-Feb-2020


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 1848

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1848 PID: P105 SPN: 105 FMI: 10/10 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature reading was higher or lower than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor
  • High resistance in the engine intake manifold temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 1848 .

Last Modified: 01-Feb-2020


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1852 .

Last Modified: 01-Feb-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 187 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1879 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1881

Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1881 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure was greater than 1.5 kpa [0.44 in HG] at initial key ON, or is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.
  • Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1883 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1885

Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: SPN: 3216 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment intake NOx sensor has malfunctioned or is damaged

The aftertreatment intake NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Open NOx sensor power supply circuit.

Refer to Troubleshooting Fault Code 1885 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

The ECM will illuminate the Malfunction Indicator Lamp (MIL) after an extended period of time with the fault code active.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment outlet NOx sensor has malfunctioned or is damaged

The aftertreatment outlet NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1887 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | Engine speed and torque derate.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter was moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will flash the aftertreatment lamp immediately after the diagnostic fails.

  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • Excessive ash in the DPF

If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not permitted. Confirm that OEM settings for the aftertreatment permit switch are configured correctly. A stationary regeneration of the aftertreatment diesel particulate filter can be performed. Use the recommended Cummins® electronic service tool or equivalent.

Refer to Troubleshooting Fault Code 1921 .

Last Modified: 01-Sep-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1922

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0/0 LAMP: Red SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. Engine protection derate is enabled. | Progressive power derate increasing in severity from time of alert.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had exceeded the maximum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The aftertreatment wiring harness or the aftertreatment temperature sensor connector pin installation may be incorrect.
  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • A possible base engine malfunction that causes excessive black soot to be generated.
  • Excessive ash in the DPF

If both Fault Code 1921 and 2777 are inactive with an active Fault Code 1922, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not allowed. Use the OEM manuals to confirm that the OEM settings for the aftertreatment permit switch are configured correctly.

Refer to Troubleshooting Fault Code 1922 .

Last Modified: 13-Oct-2021


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Engine Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs when the engine is running and the second part runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure sensor was reading an erratic value at key OFF or the crankcase pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

  • Loose or missing lubricating oil fill cap.
  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor
  • Crankcase pressure sensor is not installed correctly in the housing.

Missing or damaged breather filter element

Refer to Troubleshooting Fault Code 1942 .

Last Modified: 01-Feb-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent "Data Monitor/Logger" feature to monitor Crankcase Pressure with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather system may need to be inspected.

Refer to Troubleshooting Fault Code 1974 .

Last Modified: 01-Feb-2020


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine braking on cylinders 1 through 6 by sending a signal to engine brake solenoid 1.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was detected to be greater than 0 volts when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2182 .

Last Modified: 17-Feb-2020


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Solenoid Number 1 Signal Circuit

Circuit Description

The engine control module (ECM) controls engine braking on cylinders 1 through 6 by sending a signal to engine brake solenoid 1.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2183 .

Last Modified: 17-Feb-2020


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2185 .

Last Modified: 17-Feb-2020


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2186 .

Last Modified: 01-Feb-2020


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is internal to the ECM and cannot be service separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
  • A malfunctioning barometric air pressure sensor
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 222 .

Last Modified: 01-Feb-2020


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 227 .

Last Modified: 01-Feb-2020


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Crankshaft engine speed sensor intermittent synchronization. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent "misfire" if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent "low power" if a "glitch" in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.

Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the primary engine speed sensor circuit.

Look for loose connections at the ECM connector where the pins can not be locked into the socket.

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.

Look for pin wear at the speed sensor.

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2321 .

Last Modified: 17-Feb-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2/2 LAMP: None SRT: | Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor is located in the top of the gear housing on the exhaust side. .

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems

Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the secondary engine speed sensor circuit

Look for loose connections at the ECM connector where the pins can not be locked into the socket

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit

Look for pin wear at the speed sensor

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2322 .

Last Modified: 17-Feb-2020


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage

Reverse powering (motoring) of the engine

  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

If Fault Code 234 becomes active only during engine braking, and the engine brakes fail to engage, check for a short circuit to ground in the engine brake wiring harness. The rocker lever cover must be removed to perform this inspection. Repair or replace the engine brake wiring harness as necessary.

Refer to Troubleshooting Fault Code 234 .

Last Modified: 17-Feb-2020


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal wire shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 2373 .

Last Modified: 17-Feb-2020


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 2374 .

Last Modified: 17-Feb-2020


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

  • An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

  • Malfunctioning or damaged ECM.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2377 .

Last Modified: 17-Feb-2020


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238 .

Last Modified: 01-Feb-2020


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.
Refer to Troubleshooting Fault Code 239 .

Last Modified: 01-Feb-2020


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: P171 SPN: 171 FMI: 2/2 LAMP: Amber SRT: | The ambient air temperature sensor is reading an erratic value. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • A default value for the ambient air temperature reading is used.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High resistance in the ambient air temperature sensor signal or return lines

Malfunctioning ambient air temperature sensor

ECM malfunction.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2398 .

Last Modified: 01-Feb-2020


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect Cummins® electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

NOTE: If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 241 .

Last Modified: 01-Feb-2020


Fan Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2412

Fan Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2412 PID: P26 SPN: 1639 FMI: 2/2 LAMP: Amber SRT: | The fan speed signal has been lost. | The fan can stay on continuously or not run at all.
Fan Speed Sensor Circuit

Circuit Description

The fan speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the fan hub shaft is a ground flat in the center of the shaft. The electronic control module (ECM) interprets this signal and converts it to a fan speed reading.

Component Location

The fan speed sensor is located in the fan hub assembly. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan speed signal has been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The fan will only be in the ON or OFF position.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServeâ„¢ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

The fan speed sensor is installed by the original equipment manufacturer (OEM). This fault code is triggered when the fan speed signal is reading 0 when the engine is running. This indicates a failed fan speed sensor or a failure in the OEM wiring harness.

Refer to Troubleshooting Fault Code 2412 .

Last Modified: 01-Feb-2020


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins® electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins® electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 245 .

Last Modified: 17-Feb-2020


Engine Starter Mode Before Ready Status - Condition Exists

FAULT CODE 2482

Engine Starter Mode Before Ready Status - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2482 PID: SPN: 1675 FMI: 11/31 LAMP: Red SRT: | The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Control Module (ECM)

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 2482 .

Last Modified: 20-Jun-2021


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at ambient air temperature circuit. | Engine power derate.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 249 .

Last Modified: 17-Feb-2020


Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | The exhaust gas pressure sensor is reading an erratic value. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust pressure reading was higher or lower than the other absolute pressure sensors when the keyswitch is OFF and the engine is not running.

The Engine Control Module (ECM) detected the exhaust pressure was higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and run it at high idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range exhaust gas pressure sensor reading

High resistance in the exhaust gas pressure sensor signal or return lines

  • Plugging or restriction in the exhaust gas pressure sensor tube

Leaks in the exhaust system

Refer to Troubleshooting Fault Code 2554 .

Last Modified: 17-Feb-2020


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at ambient air temperature circuit. | Engine power derate.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 256 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had reached the first stage of plugging.

Action Taken When the Fault Code is Active

The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.

The ECM will flash the aftertreatment dash lamp as the severity of the soot load increases.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter

Possible engine damage that causes excessive black smoke to be generated.

  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 2639 .

Last Modified: 13-Oct-2021


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage is detected at the fuel pump actuator circuit. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the fuel pump actuator signal or return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Refer to Troubleshooting Fault Code 271 .

Last Modified: 05-Apr-2020


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272 .

Last Modified: 17-Feb-2020


Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2764

Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2764 PID: P131 SPN: 1209 FMI: 0/16 LAMP: Amber SRT: | High exhaust gas pressure has been detected by the exhaust gas pressure sensor. | Engine speed and torque derate.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Exhaust gas pressure sensor reading was greater than the engine protection limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

An engine derate will be activated to bring exhaust gas pressure below the maximum operating limits.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning variable geometry turbocharger

A damaged in-range exhaust gas pressure sensor

A plugged or restricted aftertreatment diesel particulate filter

Refer to Troubleshooting Fault Code 2764 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The Aftertreatment Outlet NOx Sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.

Open return circuit on the aftertreatment outlet NOx sensor battery return.

Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.

Intermittent communications between the aftertreatment outlet NOx sensor and the ECM on the J1939 data link.

Internal malfunction of the outlet NOx sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2771 .

Last Modified: 01-Feb-2020


Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 2777

Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: S390 SPN: 3703 FMI: 11/31 LAMP: Maintenance SRT: | Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | May cause frequent aftertreatment regeneration.
Aftertreatment Regeneration Inhibit Switch Circuit

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter regeneration permit switch was disabling regeneration while the ECM was requesting active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2777 .

Last Modified: 05-Apr-2020


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 285 .

Last Modified: 07-Feb-2021


J1939 Network #1 - Out of Calibration

FAULT CODE 286

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 286 .

Last Modified: 01-Jun-2021


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | An error in the barometric pressure sensor signal was detected by the ECM. | Possible reduced engine performance.
Barometric Air Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure reading was higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor was detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Aftertreatment DEF dosing system will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 295 .

Last Modified: 01-Feb-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Plugged charge-air cooler fins

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 2964 .

Last Modified: 17-Feb-2020


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic consists of two parts. At key OFF, the sensor readings for intake manifold pressure, compressor intake pressure, oil pressure (if available), and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned OFF. This fault can also be set active when the intake manifold pressure is too high or low for the current engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault code include:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A damaged intake manifold pressure sensor

A damaged turbocharger compressor intake temperature sensor.

Malfunctioning compressor intake pressure sensor

A malfunctioning exhaust gas pressure sensor

Refer to Troubleshooting Fault Code 2973 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3133

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3133 PID: SPN: 3610 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out range high.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3133 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3134

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3134 PID: SPN: 3610 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3134 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3135

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3135 PID: SPN: 3610 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading

High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

  • Bulk fuel supply may be contaminated.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3135 .

Last Modified: 21-Feb-2021


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.

Signal shorted to return or ground in the sensor

  • Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3142 .

Last Modified: 16-May-2021


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3143

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3143 PID: SPN: 4360 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SCR intake temperature sensor signal voltage was less than 0.13-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3143 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3144

Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3144 PID: SPN: 4360 FMI: 2/2 LAMP: Amber SRT: | The SCR intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intake temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by performing a road test.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A malfunctioning aftertreatment SCR intake temperature sensor

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 3144 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3146 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3147 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2/2 LAMP: Amber SRT: | The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the SCR catalyst outlet temperature is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by performing a road test.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • To validate the repair, start and operate the engine to raise exhaust temperatures.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3148 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment SCR catalyst in the exhaust system is not present. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • This fault code can be set as a result of multiple failure modes. All steps of the troubleshooting tree must be completed.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Tampering with SCR catalyst system, removal of SCR catalyst from vehicle, or malfunctioning SCR catalyst

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Degraded, diluted, or incorrect diesel exhaust fluid

Diesel exhaust fluid deposits in the decomposition tube.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

  • Deposits or plugging on the inlet face of the Aftertreatment Selective Catalytic Reduction (SCR).
Refer to Troubleshooting Fault Code 3151 .

Last Modified: 17-May-2020


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0/0 LAMP: Red SRT: | The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 800Â°C [1472Â°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR outlet temperature sensor.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3165 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3168

Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3168 PID: SPN: 3936 FMI: 0/16 LAMP: Amber SRT: | The system has detected a malfunction in the filtering capability of the aftertreatment diesel particulate filter. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The ECM calculates an aftertreatment diesel particulate filter flow resistance, using the aftertreatment diesel particulate filter differential pressure and calculated exhaust flow rate.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the aftertreatment diesel particulate filter flow resistance was too low after successful regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged aftertreatment diesel particulate filter differential pressure sensor

Missing or malfunctioning aftertreatment diesel particulate filter differential pressure sensor tubes

Malfunction aftertreatment diesel particulate filter.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3168 .

Last Modified: 01-Feb-2020


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance.
Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the real-time clock data was lost due to power loss

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 15 minutes.
  • For hard-wired real time clock with battery pack, reset the time in the recommended Cummins® electronic service tool or equivalent to make the fault go inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319 .

Last Modified: 16-May-2021


Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 322 .

Last Modified: 01-Jul-2021


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3229

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3229 PID: SPN: 4360 FMI: 0/0 LAMP: Red SRT: | The selective catalytic reduction (SCR) intake temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake temperature sensor was greater than 700°C [1292°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR intake temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR intake temperature sensor

Upstream exhaust system malfunction.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3229 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 323 .

Last Modified: 01-Jul-2021


Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3231

Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3231 PID: SPN: 4360 FMI: 0/16 LAMP: Red SRT: | The SCR intake temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst intake temperature sensor was greater than 650°C [1202°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR intake temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR intake temperature sensor

Upstream exhaust system malfunction.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3231 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the ECM loses J1939 data link communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment intake NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned NOx sensor fuse, or low voltage supplied by the battery.

Open return circuit on the aftertreatment intake NOx sensor circuit between the battery circuit aftertreatment intake NOx sensor.

Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment intake NOx sensor.

Intermittent communications between the aftertreatment intake NOx sensor and the ECM on the J1939 data link

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3232 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 0/16 LAMP: Red SRT: | The SCR outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 650Â°C [1202Â°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR outlet temperature sensor.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3235 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 324 .

Last Modified: 01-Jul-2021


Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3243

Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3243 PID: SPN: 3060 FMI: 1/18 LAMP: Amber SRT: | The engine is not warming up as expected. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs when the engine speed is above 1500 RPM, coolant Temperature is above 72 degree Celsius and boost pressure is above a calibratable threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature did not reach 72Â°C [162Â°F] in a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low coolant level, or air in the cooling system

Malfunctioning coolant temperature sensor

  • A malfunctioning water pump.

Malfunctioning engine coolant thermostat.

Refer to Troubleshooting Fault Code 3243 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 325 .

Last Modified: 01-Jul-2021


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3251

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3251 PID: S326 SPN: 4765 FMI: 0/16 LAMP: Red SRT: | The diesel oxidation catalyst intake temperature sensor reading has exceeded the maximum temperature limit. | If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the diesel oxidation catalyst intake was greater than 745°C [1373°F] for 65 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

  • Malfunctioning or damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 3251 .

Last Modified: 30-May-2021


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3253

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3253 PID: SPN: 3242 FMI: 0/16 LAMP: Red SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 735Â°C [1355Â°F] for 100 seconds, or the difference between the diesel oxidation catalyst intake temperature and the diesel particulate filter intake temperature was greater than 400Â°C [752Â°F] for 55 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter. This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damaged and reuse. Refer to the OEM service manual.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3253 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3254

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3254 PID: SPN: 3242 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | None on performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 675°C [1247°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3254 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3255

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3255 PID: SPN: 3246 FMI: 0/16 LAMP: Red SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 735C [1355F] for 145 seconds, or the difference between the diesel particulate filter intake temperature and the diesel particulate filter outlet temperature was greater than 400C [752F] for 140 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3255 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3256

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3256 PID: SPN: 3246 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | None on performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor was greater than 675Â°C [1247Â°F] for 10 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3256 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 331 .

Last Modified: 01-Jul-2021


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3311

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3311 PID: SPN: 3242 FMI: 0/0 LAMP: Red SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter intake temperature reading was greater than 800Â°C [1472Â°F] for more than 30 seconds, or the temperature differential across the diesel oxidation catalyst was greater than 540Â°C [1004Â°F] for more than 90 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

A malfunctioning fuel injector causing unburned fuel to enter the exhaust system

Excessive engine oil being introduced into the exhaust system from the engine.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3311 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3312

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3312 PID: SPN: 3246 FMI: 0/0 LAMP: Red SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature reading was greater than 810°C [1490°F] for 35 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive after the aftertreatment temperatures drop below the warning limit and a key cycle has occurred, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

A malfunctioning fuel injector causing unburned fuel to enter the exhaust system

Excessive engine oil being introduced into the exhaust system from the engine.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3312 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3313

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3313 PID: SPN: 4765 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3313 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3314

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3314 PID: SPN: 4765 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3314 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3315

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3315 PID: SPN: 4765 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel oxidation catalyst intake temperature sensor is not changing with engine operating conditions. | None on performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

"The aftertreatment diesel oxidation catalyst temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel oxidation catalyst temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, and aftertreatment diesel oxidation catalyst outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel oxidation catalyst temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and diesel particulate filter intake temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3315 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3316

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3316 PID: SPN: 3242 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment particulate filter intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3316 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3317

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3317 PID: SPN: 3242 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3317 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3318

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3318 PID: SPN: 3242 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter intake temperature is not changing with engine operating conditions. | None on performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel particulate filter intake temperature sensor data and diesel particulate filter outlet temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3318 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3319

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3319 PID: SPN: 3246 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range high

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3319 .

Last Modified: 01-Feb-2020


Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 332 .

Last Modified: 01-Jul-2021


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3321

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3321 PID: SPN: 3246 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range low

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3321 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3322

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3322 PID: SPN: 3246 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet temperature is not changing with engine operating conditions. | None on performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment system is monitored by three temperature sensors that are located in the exhaust system. The aftertreatment diesel oxidation catalyst intake temperature sensor is located after the turbocharger outlet, at the intake of the aftertreatment system. The aftertreatment diesel particulate filter intake temperature sensor is located between the aftertreatment diesel oxidation catalyst and the aftertreatment diesel particulate filter. The aftertreatment diesel particulate filter outlet temperature sensor is located after the aftertreatment diesel particulate filter. The temperature sensors around the aftertreatment diesel oxidation catalyst (DOC) are used to monitor the temperature differential across the catalyst during active regeneration of the aftertreatment system.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature sensor reading did not change with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

The ether injection operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Build up or plugging on the inlet face of the Diesel Particulate Filter.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3322 .

Last Modified: 01-Feb-2020


Engine Fuel Pump Pressurizing Assembly 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3332

Engine Fuel Pump Pressurizing Assembly 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3332 PID: SPN: 1347 FMI: 2/2 LAMP: Amber SRT: | The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit had an intermittent circuit concern, or the fuel pump actuator resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Sensed fuel rail pressure will not follow the commanded rail pressure.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

Fuel pump actuator high resistance

Engine harness high resistance

Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors

Fuel pump actuator with low internal resistance

Fuel pump actuator or engine harness that has shorted to ground

Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 3332 .

Last Modified: 17-Feb-2020


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2/2 LAMP: Amber SRT: | The engine coolant temperature sensor is reading an erratic value. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Monitor Engine Coolant Temperature Using the recommended Cummins® electronic service tool or equivalent during the Diagnostic Road Test or Dynamometer run. Coolant temperature should remain in the normal operating range.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning engine coolant thermostat.

In-range malfunction of the engine coolant temperature sensor

High resistance in the engine coolant temperature sensor signal or return lines.

Refer to Troubleshooting Fault Code 334 .

Last Modified: 01-Feb-2020


Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3343

Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3343 PID: SPN: 5285 FMI: 1/18 LAMP: Amber SRT: | The engine charge air cooler is not cooling the intake air flow sufficiently. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 105C [221F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning intake manifold temperature sensor

A malfunctioning charge-air cooler.

Refer to Troubleshooting Fault Code 3343 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

FAULT CODE 3375

Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3375 PID: SPN: 5397 FMI: 11/31 LAMP: Amber SRT: | The system has detected the need for an active regeneration has occurred too soon following the last active regeneration. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM records the time from the completion of an active regeneration of the aftertreatment diesel particulate filter until the ECM request another active regeneration of the diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The time between the completion of a successful active regeneration and the requests for another active regeneration was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This diagnostic can not be run in the shop environment.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

  • A face plugged aftertreatment diesel oxidation catalyst

A malfunctioning aftertreatment diesel particulate filter differential pressure sensor

  • An engine malfunction resulting in high engine out soot.
  • Excessive ash in the DPF
  • Bulk fuel supply may be contaminated.
Refer to Troubleshooting Fault Code 3375 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

FAULT CODE 3376

Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3376 PID: SPN: 5319 FMI: 11/31 LAMP: Amber SRT: | The system has detected that the aftertreatment diesel particulate filter differential pressure is too high following an active regeneration. | May cause frequent aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The estimated soot load in the aftertreatment diesel particulate filter was higher than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment temperature sensors

A malfunctioning aftertreatment diesel oxidation catalyst

  • A malfunctioning or stuck in-range aftertreatment diesel particulate filter differential pressure sensor

An engine malfunction resulting in high engine out smoke

  • Excessive ash in the DPF

A damaged or malfunctioning OEM wiring harness to the differential pressure sensor.

Refer to Troubleshooting Fault Code 3376 .

Last Modified: 01-Sep-2021


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | ECM power supply errors have been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343 .

Last Modified: 01-Feb-2020


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10/10 LAMP: Amber SRT: | The ECM has diagnosed that the real time clock (RTC) information is increasing abnormally or that power was lost while the RTC is running. The real time clock indicates a stuck engine off timer. | None on performance.
Real Time Clock Power Circuit

Circuit Description

The real-time clock consists of a timing chip internal to the engine control module (ECM) which monitors engine off time, i.e. how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The engine off timer was not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Monitoring the engine off time is necessary in to make sure that all other engine sensors and actuators are performing correctly. If the ECM is recalibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

Malfunctioning real time clock chip internal to the ECM

Engine calibration issue.

Refer to Troubleshooting Fault Code 3492 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

  • The diesel exhaust fluid lamp will be flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3498 .

Last Modified: 01-Feb-2020


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351 .

Last Modified: 17-Feb-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 1, Fault Code 352 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 352 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 352 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 352 .

Last Modified: 17-Feb-2020


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

  • A short circuit to battery in the engine harness.
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3539 .

Last Modified: 17-Feb-2020


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3541 .

Last Modified: 17-Feb-2020


Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3542

Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3542 PID: SPN: 51 FMI: 2/2 LAMP: Amber SRT: | The engine intake air throttle posistion feedback is erratic or incorrect. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

Refer to Troubleshooting Fault Code 3542 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: SPN: 3226 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1887, 2771, or 3682 before troubleshooting this fault code.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3545 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: SPN: 4096 FMI: 11/31 LAMP: Amber SRT: | The diesel exhaust fluid tank is empty. | Vehicle speed will be limited to 20 km [12 miles] per hour.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was empty and the dosing unit was unable to prime.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Driver Warning System lamp will be flashing.
  • Vehicle Speed will be limited to 20 km [12 mi] per hour.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the Driver Warning System lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the aftertreatment diesel exhaust fluid tank is empty and needs refilled immediately.

Refer to Troubleshooting Fault Code 3547 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibratible value or the diesel exhaust fluid dosing unit supply was shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the OEM harness

A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Refer to Troubleshooting Fault Code 3558 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground

A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Refer to Troubleshooting Fault Code 3559 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5/5 LAMP: Amber SRT: | A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open circuit in the diesel exhaust fluid dosing valve

  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

After the repair, It is Important to idle the engine for a minimum of 5 minutes to clear the derate.

Refer to Troubleshooting Fault Code 3567 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3568

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7/7 LAMP: Amber SRT: | A mechanical malfunction has been detected in the DEF dosing valve. | Engine power derate.
Aftertreatment Diesal Exhaust Fluid Dosing Valve Circuit.

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine ECM commands DEF dosing, a pulse width modulated (PWM) signal is sent to the dosing dosing valve, which opens the dosing valve and allows DEF to be pumped into the mixing chamber and sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is internal to the aftertreatment DEF dosing unit and can not be serviced separately.

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Dosing valve stuck closed.

Refer to Troubleshooting Fault Code 3568 .

Last Modified: 06-Sep-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Engine power derate.
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the OEM wiring harness.

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Refer to Troubleshooting Fault Code 3571 .

Last Modified: 23-Aug-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Engine power derate.
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM wiring harness.

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Refer to Troubleshooting Fault Code 3572 .

Last Modified: 23-Aug-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 1/18 LAMP: Amber SRT: | Low diesel exhaust fluid pressure has been detected in the dosing valve. | Engine power derate.
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when diesel exhaust fluid dosing unit is fully primed, and is actively maintaining diesel exhaust fluid pressure in the dosing system.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.
  • Vehicle Speed will be limited to 20 km [12 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter/screen
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Refer to Troubleshooting Fault Code 3574 .

Last Modified: 23-Aug-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | The diesel exhaust fluid dosing valve has detected a blockage in the diesel exhaust fluid return flow. | Engine power derate.
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when diesel exhaust fluid dosing unit is fully primed, and is actively maintaining diesel exhaust fluid pressure in the dosing system.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than 1100 kpa [159 psi] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be reduced.
  • Vehicle Speed will be limited to 20 km [12 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • Use the recommended Cummins® electronic service tool or equivalent to verify the fault code is inactive.
  • The inactive fault code will be cleared from the memory after 9600 hours of engine operation without a reoccurrence.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Refer to Troubleshooting Fault Code 3575 .

Last Modified: 23-Aug-2020


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | Progressive power derate increasing in severity from time of alert.
Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

A damaged aftertreatment outlet NOx sensor

Intermittent power connection to the aftertreatment outlet NOx sensor.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3583 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing valve and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the system is fully primed at key OFF.

This diagnostic runs at key OFF. The fault will be active at the next key-ON event.

Conditions for Setting the Fault Codes

The diesel exhaust fluid pressure reading was a calibratable amount higher or lower than the other pressure sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • Start the engine and allow diesel exhaust fluid system to fully prime.
  • Turn the keyswitch OFF. Allow the ECM to completely power down and turn the keyswitch ON.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Blocked or restricted diesel exhaust fluid dosing unit supply line fitting

Malfunctioning diesel exhaust fluid pressure sensor

  • High resistance in the diesel exhaust fluid pressure sensor wiring.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3596 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | Progressive power derate increasing in severity from time of alert.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 200°C [392°F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 200°C [392°F] for 2 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

Damaged aftertreatment intake NOx sensor

Intermittent power connection to the aftertreatment intake NOx sensor.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3649 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins® electronic service tool or equivalent.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3681 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: SPN: 3218 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins® electronic service tool or equivalent.

Internal malfunction of the intake NOx sensor

The NOx sensor part number is incorrect.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3682 .

Last Modified: 01-Feb-2020


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM will flash the Malfunction Indicator Lamp (MIL) at key on

  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunction of the ECM software.
Refer to Troubleshooting Fault Code 3697 .

Last Modified: 16-May-2021


Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3712

Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3712 PID: SPN: 5246 FMI: 0/0 LAMP: Red SRT: | Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Vehicle speed will be limited to 20 km [12 miles] per hour.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced.

  • Vehicle Speed will be limited to 20 km [12 mi] per hour.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate and vehicle speed limit have been implemented in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3712 .

Last Modified: 01-Feb-2020


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3714 PID: SPN: 1569 FMI: 11/31 LAMP: Amber SRT: | Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3714 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

FAULT CODE 3717

Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3717 PID: SPN: 3226 FMI: 13/13 LAMP: Amber SRT: | A nominal system voltage mismatch has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Calibration incompatibility between aftertreatment outlet NOx sensor and ECM calibration

System voltage incorrect for installed aftertreatment outlet NOx sensor part number.

Incorrect aftertreatment outlet NOx sensor is installed in exhaust system.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3717 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Intake NOx - Out of Calibration

FAULT CODE 3718

Aftertreatment 1 Intake NOx - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3718 PID: SPN: 3216 FMI: 13/13 LAMP: Amber SRT: | A nominal system voltage mismatch has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Calibration incompatibility between aftertreatment intake NOx sensor and ECM calibration.

System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.

Incorrect aftertreatment intake NOx sensor is installed in exhaust system.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3718 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: SPN: 3216 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 200°C [392°F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 200°C [392°F] for 2 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1885, 3232, or 3681 before troubleshooting this fault code.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3725 .

Last Modified: 01-Feb-2020


High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3727

High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3727 PID: SPN: 5571 FMI: 7/7 LAMP: None SRT: | The fuel rail high-pressure relief valve has opened at a lower than expected pressure. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure relief valve had opened at a pressure lower than expected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become inactive at each key OFF event, and will not become active again until the fault condition reoccurs. Troubleshoot inactive or active occurences of this fault code the same.

An occurence of this fault indicates that the high-pressure relief valve is being tripped at a pressure lower than what is expected. If this has happened multiple times, there will be many occurences of this fault. Troubleshoot Fault Code 3727 before Fault Code 1911, if both fault codes are present in the ECM.

This fault code may also be triggered by a sudden and significant loss of fuel pressure in the fuel system.

Refer to Troubleshooting Fault Code 3727 .

Last Modified: 01-Feb-2020


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: SPN: 1675 FMI: 11/31 LAMP: None SRT: | The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Control Module (ECM)

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737 .

Last Modified: 01-Feb-2020


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3741

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3741 PID: SPN: 5571 FMI: 0/0 LAMP: Amber SRT: | The fuel rail pressure relief valve has opened due to high fuel rail pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure had exceeded the fuel pressure relief valve opening pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • High fuel drain line restriction
  • A leaking or sticky fuel pump actuator
  • Air in the fuel
  • A plugged fuel pump actuator mounting adapter

This fault indicates that the fuel rail pressure was high enough to open the fuel rail pressure relief valve.

Refer to Troubleshooting Fault Code 3741 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 2/20 LAMP: Amber SRT: | An offset in the intake NOx sensor reading has been detected. | Progressive power derate increasing in severity from time of alert.
Electronic Control Module

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 200°C [392°F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor reading was not changing with engine conditions or is stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • Start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 200°C [392°F] for 2 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • To validate the repair, it is necessary to drive the vehicle and operate it in a motoring condition for 10 seconds continuously.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment Intake NOx sensor

Improperly installed aftertreatment intake NOx sensor.

Refer to Troubleshooting Fault Code 3748 .

Last Modified: 01-Feb-2020


Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

FAULT CODE 3753

Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3753 PID: SPN: 3713 FMI: 11/31 LAMP: None SRT: | The system was unable to perform an active regeneration of the aftertreatment diesel particulate filter. | None on performance.
Electronic Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and the ECM is requesting active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the system is requesting an active regeneration of the aftertreatment diesel particulate filter for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is an information only fault code indicating that the system was requesting an active regeneration of the aftertreatment system, but was unable to perform an active regeneration.

Refer to Troubleshooting Fault Code 3753 .

Last Modified: 01-Feb-2020


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 386 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9/9 LAMP: Amber SRT: | The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link.
Refer to Troubleshooting Fault Code 3868 .

Last Modified: 01-Sep-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid quality sensor has reported a reading too high or low for the operating conditions. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Quality Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 3878 .

Last Modified: 01-Sep-2021


Wheel-Based Vehicle Speed - Condition Exists

FAULT CODE 3916

Wheel-Based Vehicle Speed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3916 PID: SPN: 84 FMI: 11/31 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. A vehicle speed signal has been detected after the keyswitch is turned off. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will flash the Malfunction Indicator Lamp (MIL) at key on

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3916 .

Last Modified: 01-Feb-2020


Wheel-Based Vehicle Speed - Data Not Rational - Drifted High

FAULT CODE 4132

Wheel-Based Vehicle Speed - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4132 PID: SPN: 84 FMI: 2/20 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. A vehicle speed signal has been detected after the keyswitch is turned off. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will flash the Malfunction Indicator Lamp (MIL) at key on

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 4132 .

Last Modified: 01-Feb-2020


Wheel-Based Vehicle Speed - Data Not Rational - Drifted Low

FAULT CODE 4133

Wheel-Based Vehicle Speed - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4133 PID: SPN: 84 FMI: 2/21 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. A vehicle speed signal has been detected after the keyswitch is turned off. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will flash the Malfunction Indicator Lamp (MIL) at key on

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 4133 .

Last Modified: 01-Feb-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low oil pressure

  • Incorrect oil level
  • Damaged oil pressure sensor

Engine harness shorted to ground.

Refer to Troubleshooting Fault Code 415 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4151

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4151 PID: SPN: 5742 FMI: 9/9 LAMP: Amber SRT: | No communications on the J1939 data link between the ECM and the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment exhaust gas temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply

Incorrect terminating resistance of the SAE J1939 datalink circuit

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Refer to Troubleshooting Fault Code 4151 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4152

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4152 PID: SPN: 5743 FMI: 9/9 LAMP: Amber SRT: | No communication on the J1939 data link between the ECM and the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply

Incorrect terminating resistance of the SAE J1939 datalink circuit

Incorrect sensor for the application (12 VDC versus 24 VDC)

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.
Refer to Troubleshooting Fault Code 4152 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4158

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4158 PID: SPN: 5742 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported an internal error

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter temperature sensor module

Refer to Troubleshooting Fault Code 4158 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4159

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4159 PID: SPN: 5743 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR temperature sensor module

Refer to Troubleshooting Fault Code 4159 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4161

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4161 PID: SPN: 5742 FMI: 3/3 LAMP: Amber SRT: | High battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

High battery voltage supply

Refer to Troubleshooting Fault Code 4161 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4162

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4162 PID: SPN: 5742 FMI: 4/4 LAMP: Amber SRT: | Low battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Low battery voltage supply

Refer to Troubleshooting Fault Code 4162 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4163

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4163 PID: SPN: 5742 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment exhaust gas temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel particulate filter temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to over heating of the aftertreatment diesel particulate filter temperature sensor module.

Refer to Troubleshooting Fault Code 4163 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4164

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4164 PID: SPN: 5743 FMI: 3/3 LAMP: Amber SRT: | High battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

High battery voltage supply

Refer to Troubleshooting Fault Code 4164 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4165

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4165 PID: SPN: 5743 FMI: 4/4 LAMP: Amber SRT: | Low battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins® electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Low battery voltage supply

Refer to Troubleshooting Fault Code 4165 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4166

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4166 PID: SPN: 5743 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Single Module aftertreatment system
Flex Module aftertreatment system

Circuit Description

Single Module aftertreatment system:

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Flex Module aftertreatment system:

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 4166 .

Last Modified: 16-May-2021


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water-fuel separator into a container and dispose of in accordance with local environmental regulations.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 418 .

Last Modified: 01-Feb-2020


Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4213

Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4213 PID: SPN: 3695 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position. | May cause frequent aftertreatment regeneration.
Aftertreatment Regeneration Inhibit Switch Circuit

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position and the ECM is requesting active regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment regeneration permit switch circuit.

  • Incorrect feature and parameter settings
Refer to Troubleshooting Fault Code 4213 .

Last Modified: 05-Apr-2020


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4233

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4233 PID: SPN: 3515 FMI: /3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 4233 .

Last Modified: 06-Sep-2020


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4234

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4234 PID: SPN: 3515 FMI: /4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage or short circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 4234 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

FAULT CODE 4243

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4243 PID: SPN: 3515 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 4243 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4259

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4259 PID: SPN: 5742 FMI: 11/11 LAMP: Amber SRT: | Intermittent battery voltage supply detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment exhaust gas temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment exhaust gas temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, aftertreatment diesel particulate filter outlet temperature, and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment exhaust gas temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment exhaust gas temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4259 .

Last Modified: 01-Feb-2020


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4261

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4261 PID: SPN: 5743 FMI: 11/11 LAMP: Amber SRT: | Intermittent battery voltage supply detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4261 .

Last Modified: 01-Feb-2020


J1939 Network #1 - Abnormal Update Rate

FAULT CODE 427

J1939 Network #1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 427 .

Last Modified: 30-Jan-2022


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

  • Signal wire shorted to sensor supply or battery voltage.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 428 .

Last Modified: 01-Feb-2020


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the water-in-fuel circuit. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 429 .

Last Modified: 01-Feb-2020


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | An error in the engine oil pressure switch signal was detected by the ECM. | None on performance.
Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure switch is used by the engine control module (ECM) to monitor the lubricating oil pressure.The oil pressure switch is normally closed when the engine is not running and open when the engine is running and oil pressure is present.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure switch was indicating that oil pressure was present (switch is open) at intial key ON for two consecutive key cycles, when the ECM expected to see no oil pressure (switch closed) at key ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Damaged engine oil pressure switch

Damaged wiring harness

Malfunctioning ECM

Refer to Troubleshooting Fault Code 435 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: P105 SPN: 105 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts.The first part runs when the keyswitch is turned ON and before engine speed is detected.The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor
  • High resistance in the engine intake manifold temperature sensor signal or return lines.
Refer to Troubleshooting Fault Code 436 .

Last Modified: 17-Feb-2020


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 441 .

Last Modified: 17-Feb-2020


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 442 .

Last Modified: 17-Feb-2020


Diesel Exhaust Fluid Consumption Malfunction - Condition Exists

FAULT CODE 4486

Diesel Exhaust Fluid Consumption Malfunction - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4486 PID: SPN: 5839 FMI: 11/31 LAMP: Amber SRT: | Critical DEF delivery fault codes have been active for an extended period of time and require immediate attention | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when other faults related to DEF delivery have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the Driver Warning System lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for 10 hours with this fault active.
  • Vehicle speed will be limited to 20 km [12 mi] per hour after 20 hours engine operation with this fault active, after the engine has been shutdown, or vehicle becomes stationary after 8 hours of operation.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the Driver Warning System lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is information ONLY, make sure that critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4486 .

Last Modified: 01-Feb-2020


Diesel Exhaust Fluid Dosing Malfunction - Condition Exists

FAULT CODE 4487

Diesel Exhaust Fluid Dosing Malfunction - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4487 PID: SPN: 5840 FMI: 11/31 LAMP: Amber SRT: | Critical DEF dosing related fault codes have been active for an extended period of time and require immediate attention. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when other faults related to DEF Dosing have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the Driver Warning System lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for 10 hours with this fault active.
  • Vehicle speed will be limited to 20 km [12 mi] per hour after 20 hours engine operation with this fault active, after the engine has been shutdown, or vehicle becomes stationary after 8 hours of operation.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the Driver Warning System lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Make sure that the critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4487 .

Last Modified: 01-Feb-2020


Diesel Exhaust Fluid Quality Malfunction - Condition Exists

FAULT CODE 4488

Diesel Exhaust Fluid Quality Malfunction - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4488 PID: SPN: 5841 FMI: 11/31 LAMP: Amber SRT: | Critical DEF quality related fault codes have been active for an extended period of time and require immediate attention. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when faults Related to DEF quality have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the Driver Warning System lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for 10 hours with this fault active.
  • Vehicle speed will be limited to 20 km [12 mi] per hour after 20 hours engine operation with this fault active, after the engine has been shutdown, or vehicle becomes stationary after 8 hours of operation.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the Driver Warning System lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only, make sure that the critical DEF quality related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4488 .

Last Modified: 01-Feb-2020


SCR Monitoring System Malfunction - Condition Exists

FAULT CODE 4489

SCR Monitoring System Malfunction - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4489 PID: SPN: 5842 FMI: 11/31 LAMP: Amber SRT: | Critical SCR related fault codes have been active and require immediate attention. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when faults related to SCR have logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM illuminates the Driver Warning System lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for 36 hours with this fault active.
  • Vehicle speed will be limited to 20 km [12 mi] per hour after 100 hours engine operation with this fault active, after the engine has been shutdown, or vehicle becomes stationary after 8 hours of operation.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the Driver Warning System lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Make sure that the critical dosing related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 4489 .

Last Modified: 01-Feb-2020


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor responds to pressure changes in the fuel rail. The fuel rail pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at low rail pressures. The ECM will detect a high signal voltage during high rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 451 .

Last Modified: 15-Mar-2021


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel rail pressure sensor responds to pressure changes in the fuel rail. The fuel rail pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at low rail pressures. The ECM will detect a high signal voltage during high rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor.
  • Damaged ECM.
Refer to Troubleshooting Fault Code 452 .

Last Modified: 15-Mar-2021


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9/9 LAMP: Amber SRT: | The ECM lost communication with the aftertreatment diesel exhaust fluid tank temperature sensor. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • A default value for the aftertreatment diesel exhaust fluid tank temperature reading is used.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect terminating resistance of the SAE J1939 datalink circuit

Intermittent communication from the aftertreatment diesel exhaust fluid tank temperature sensor

  • An open or short circuit in the SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 4572 .

Last Modified: 01-Feb-2020


Aftertreatment Diesel Particulate Filter System - Special Instructions

FAULT CODE 4584

Aftertreatment Diesel Particulate Filter System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4584 PID: SPN: 3936 FMI: 14/14 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter System - Special Instructions. the incorrect aftertreatment diesel particulate filter system has been installed with the engine | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been manufactured with the incorrect Diesel Particulate Filter System

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. If this fault code is active, the aftertreatment part numbers should be verified.

For intermittent power supply and datalink communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 4584 .

Last Modified: 21-Feb-2021


Aftertreatment 1 SCR Catalyst System - Special Instructions

FAULT CODE 4585

Aftertreatment 1 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4585 PID: SPN: 4792 FMI: 14/14 LAMP: Red SRT: | An incorrect SCR system has been installed. | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been manufactured with the incorrect SCR

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

  • A malfunctioning aftertreatment SCR temperature sensor module
  • A malfunctioning engine control module (ECM)

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 4585 .

Last Modified: 21-Feb-2021


Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4658

Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4658 PID: SPN: 4331 FMI: 1/18 LAMP: Amber SRT: | Low aftertreatment diesel exhaust fluid flow detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing performance is low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Refer to Troubleshooting Fault Code 4658 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

FAULT CODE 4677

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4677 PID: SPN: 1761 FMI: 9/9 LAMP: Amber SRT: | The ECM lost communication with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level/Temperature/Quality sensor.
  • A malfunctioning SAE J1939 datalink circuit
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 4677 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Refer to Troubleshooting Fault Code 4731 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank level sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4732 .

Last Modified: 11-Apr-2021


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

FAULT CODE 4737

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4737 PID: SPN: 3031 FMI: 11/11 LAMP: Amber SRT: | An unknown error has been detected with the aftertreatment diesel exhaust fluid tank temperature sensor. | Engine power derate.
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Refer to Troubleshooting Fault Code 4737 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

  • The diesel exhaust fluid lamp will be flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4739 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

FAULT CODE 4745

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4745 PID: SPN: 3515 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4745 .

Last Modified: 06-Sep-2020


Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

FAULT CODE 4747

Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4747 PID: SPN: 3217 FMI: 2/20 LAMP: Amber SRT: | An in-range high failure has been detected. | Progressive power derate increasing in severity from time of alert.
Electronic Control Module

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment Intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4747 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

FAULT CODE 4748

Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4748 PID: SPN: 3217 FMI: 2/21 LAMP: Amber SRT: | An in-range low failure has been detected. | Progressive power derate increasing in severity from time of alert.
Electronic Control Module

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment Intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4748 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

FAULT CODE 4749

Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4749 PID: SPN: 3227 FMI: 2/20 LAMP: Amber SRT: | An in-range high failure has been detected. | Progressive power derate increasing in severity from time of alert.
Electronic Control Module

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.
  • Exhaust system leaks.
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4749 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

FAULT CODE 4751

Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4751 PID: SPN: 3227 FMI: 2/21 LAMP: Amber SRT: | An in-range low failure has been detected. | Progressive power derate increasing in severity from time of alert.
Electronic Control Module

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.
  • Exhaust system leaks.
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4751 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | A valid diesel exhaust fluid tank level reading has NOT been received. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, and leave the key in the ON position for 2 hours.

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Tampering of the aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4769 .

Last Modified: 01-Feb-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4843

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4843 PID: SPN: 105 FMI: 0/15 LAMP: Amber SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 4843 .

Last Modified: 20-Jun-2021


Performance Bias Selection Switch - Voltage Above Normal or Shorted to High Source

FAULT CODE 4948

Performance Bias Selection Switch - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 4948
PID:
SPN: 6874
FMI: 3/3
LAMP: Amber
SRT:

Low voltage detected at performance bias selection circuit.

  • Performance biased switch will be disabled.
  • Engine will run in Calibrated default mode.
Performance Bias Selection Switch Circuit

Circuit Description

The User Adjustable Fuel Economy feature provides three different engine operation modes through a three position switch. The driver can balance fuel economy and vehicle power performance by running on different engine operation modes.

Component Location

The performance bias selection switch is installed in the dashboard or any other place in the cab that the driver can easily get access.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the performance bias selection switch signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Possible causes of this fault code include:

A short circuit to ground

A malfunctioning performance bias selection switch.

Refer to Troubleshooting Fault Code 4948 .

Last Modified: 01-Feb-2020


Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4949

Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 4949
PID:
SPN: 6874
FMI: 4/4
LAMP: Amber
SRT:

Low voltage detected at performance bias selection circuit.

  • Performance biased switch will be disabled.
  • Engine will run in Calibrated default mode.
Performance Bias Selection Switch Circuit

Circuit Description

The User Adjustable Fuel Economy feature provides three different engine operation modes through a three position switch. The driver can balance fuel economy and vehicle power performance by running on different engine operation modes.

Component Location

The performance bias selection switch is installed in the dashboard or any other place in the cab that the driver can easily get access.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the performance bias selection switch signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Possible causes of this fault code include:

A short circuit to ground

A malfunctioning performance bias selection switch.

Refer to Troubleshooting Fault Code 4949 .

Last Modified: 01-Feb-2020


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Fuel Rail Pressure Sensor

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 515 .

Last Modified: 15-Mar-2021


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Fuel Rail Pressure Sensor

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.
Refer to Troubleshooting Fault Code 516 .

Last Modified: 15-Mar-2021


Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5271

Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5271 PID: SPN: 649 FMI: 3/3 LAMP: Amber SRT: | A short circuit to battery or open circuit has been detected in the engine exhaust back pressure regulator signal circuit. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine exhaust back pressure regulator motor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • A malfunctioning engine exhaust back pressure regulator
Refer to Troubleshooting Fault Code 5271 .

Last Modified: 17-May-2020


Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5272

Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5272 PID: SPN: 649 FMI: 4/4 LAMP: Amber SRT: | A short circuit to ground has been detected in the engine exhaust back pressure regulator signal circuit. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs when the engine exhaust air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine exhaust back pressure regulator motor circuit is shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine wiring harness.
  • A malfunctioning engine exhaust back pressure regulator
Refer to Troubleshooting Fault Code 5272 .

Last Modified: 17-May-2020


Engine Exhaust Back Pressure Regulator Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 5273

Engine Exhaust Back Pressure Regulator Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5273 PID: SPN: 649 FMI: 5/5 LAMP: Amber SRT: | Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or engine exhaust back pressure regulator motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Engine exhaust back pressure regulator motor circuit open circuit

Open circuit in the harness

Malfunctioning ECM

Refer to Troubleshooting Fault Code 5273 .

Last Modified: 01-Feb-2020


Engine Exhaust Back Pressure Regulator Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5274

Engine Exhaust Back Pressure Regulator Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5274 PID: SPN: 5625 FMI: 2/2 LAMP: Amber SRT: | The engine exhaust back pressure regulator position feedback is erratic or incorrect. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine exhaust back pressure regulator position sensor signal is incorrect.

Action Taken When the Fault Code is Active

The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.

  • Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine exhaust back pressure regulator position sensor
  • Open circuit in the wiring harness
Refer to Troubleshooting Fault Code 5274 .

Last Modified: 17-May-2020


Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5275

Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5275 PID: SPN: 5625 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine exhaust back pressure regulator position sensor circuit. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine exhaust back pressure regulator position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine exhaust back pressure regulator position sensor
  • A short circuit to battery in the engine harness.
  • An open circuit in the engine wiring harness.
Refer to Troubleshooting Fault Code 5275 .

Last Modified: 17-May-2020


Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5276

Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5276 PID: SPN: 5625 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine exhaust back pressure regulator position sensor circuit. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine exhaust back pressure regulator position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine exhaust back pressure regulator actuation will be disabled. The engine exhaust back pressure regulator will default to the open position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine exhaust back pressure regulator position sensor
  • A short circuit to ground in the engine wiring harness.
  • An open circuit in the engine wiring harness.
Refer to Troubleshooting Fault Code 5276 .

Last Modified: 17-May-2020


Engine Exhaust Back Pressure Regulator - Out of Calibration

FAULT CODE 5277

Engine Exhaust Back Pressure Regulator - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5277 PID: SPN: 5626 FMI: 13/13 LAMP: Amber SRT: | The engine exhaust back pressure regulator failed auto zero span check. | Possible reduced engine performance.
Engine Exhaust Back Pressure Regulator circuit

Circuit Description

The engine control module (ECM) controls the engine exhaust back pressure regulator. The ECM can open and close the engine exhaust back pressure regulator based on the operating conditions in order to regulate exhaust air flow to the engine.

Component Location

The engine exhaust back pressure regulator location can vary depending on engine model and aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs at initial key OFF and occasionally during normal engine operation after the engine exhaust back pressure regulator is commanded closed.

Conditions for Setting the Fault Codes

The engine exhaust back pressure regulator failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, use the recommended Cummins® electronic service tool or equivalent to perform the "Exhaust Throttle Auto Zero Test" found in ECM Diagnostic Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Mechanical misalignment.
  • A malfunctioning engine exhaust back pressure regulator position sensor
Refer to Troubleshooting Fault Code 5277 .

Last Modified: 02-May-2021


Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

FAULT CODE 5278

Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5278 PID: SPN: 6802 FMI: 11/31 LAMP: Amber SRT: | The ECM has detected conditions which indicate the Diesel Exhaust Fluid Dosing System is frozen. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank temperature Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the diesel exhaust fluid dosing system was unable to prime when the ambient air temperature was low (non-heated diesel exhaust fluid dosing systems).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

On non-heated diesel exhaust fluid dosing systems, this fault code indicates that the system was unable to prime when the ambient air temperature was lower than 0 deg C [32 deg F].

Possible causes of this fault code include:

Frozen diesel exhaust fluid in the DEF tank.

A short circuit to battery in the harness.

  • Aftertreatment diesel exhaust fluid tank level and tank temperature sensor wiring harness connectors are reversed.
Refer to Troubleshooting Fault Code 5278 .

Last Modified: 06-Sep-2020


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553 .

Last Modified: 01-Feb-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather oil separator

Plugged or restricted crankcase breather oil drain tube or check valve

Plugged or restricted crankcase breather draft tube

  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555 .

Last Modified: 01-Feb-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | High crankcase pressure detected. | Possible reduced engine performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather oil separator

Plugged or restricted crankcase breather oil drain tube or check valve

Plugged or restricted crankcase breather draft tube

  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 556 .

Last Modified: 01-Feb-2020


Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5576

Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5576 PID: SPN: 107 FMI: 0/15 LAMP: Maintenance SRT: | Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level | None on performance.
Turbocharger Compressor Intake Pressure Sensor Circuit

Circuit Description

The turbocharger compressor intake pressure sensor is a differential pressure sensor and is used to measure the air pressure drop entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake pressure sensor signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air pressure drop into the compressor intake.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously after the engine has been running for 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake air restriction is above a calibratible value.

Action Taken When the Fault Code is Active

The Engine Control Module (ECM) will flash the Amber CHECK ENGINE lamp at key ON

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Plugged or highly restricted air filter can also possibly cause this fault to become active, especially at higher altitudes.

Refer to Troubleshooting Fault Code 5576 .

Last Modified: 07-Feb-2021


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was less than the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure.

Causes of this fault include:

Fuel inlet restrictions

Fuel filter plugging

Fuel gear pump output low

Fuel gear pump pressure actuator sticking or leaking

High pressure pump capacity decay (high leakage to drain from the high-pressure pump)

Fuel rail pressure relief valve leaks to drain

Fuel rail pressure relief valve opens at too low a pressure

Injector fuel circuit leaks to drain

Air in the fuel.

Refer to Troubleshooting Fault Code 559 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

FAULT CODE 5655

Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5655 PID: SPN: 4364 FMI: 11/31 LAMP: Amber SRT: | NOx conversion across the SCR catalyst is too low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • This fault code can be set as a result of multiple failure modes. All steps of the troubleshooting tree must be completed.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

  • Blocked or restricted diesel exhaust fluid tank filter

Blocked or restricted diesel exhaust fluid dosing unit filter/screen

Diesel exhaust fluid deposits in the decomposition tube.

For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel

  • Deposits or plugging on the inlet face of the Aftertreatment Selective Catalytic Reduction (SCR).
Refer to Troubleshooting Fault Code 5655 .

Last Modified: 17-May-2020


Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

FAULT CODE 5689

Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5689 PID: SPN: 3226 FMI: 11/11 LAMP: Amber SRT: | Signal indicates wrong reading or sensor tampering. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor reading was not changing with engine conditions or is stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200°C [392°F] for 5 minutes before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Incorrectly installed aftertreatment outlet NOx sensor

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins® electronic service tool or equivalent.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Leaks in the exhaust system

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5689 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

FAULT CODE 5715

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5715 PID: SPN: 3251 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading

High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires

Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes

Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5715 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

FAULT CODE 5716

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5716 PID: SPN: 3610 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading

High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires

Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes

Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5716 .

Last Modified: 01-Feb-2020


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 584 .

Last Modified: 17-Feb-2020


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Motor Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 585 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5864

Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5864 PID: SPN: 4375 FMI: 3/3 LAMP: Amber SRT: | A short circuit to battery has been detected in the Diesel Exhaust Fluid Pump Command Circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected voltage above a calibrated value on the control circuit when the dosing unit was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Refer to Troubleshooting Fault Code 5864 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5865

Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5865 PID: SPN: 4375 FMI: 4/4 LAMP: Amber SRT: | A short circuit to ground has been detected in the Diesel Exhaust Fluid Pump Command Circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected voltage below a calibrated value on the control circuit when the dosing unit was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
Refer to Troubleshooting Fault Code 5865 .

Last Modified: 17-Feb-2020


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5879

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5879 PID: SPN: 3464 FMI: 3/3 LAMP: Amber SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • A malfunctioning engine intake air throttle actuator.
Refer to Troubleshooting Fault Code 5879 .

Last Modified: 17-Feb-2020


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5881

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5881 PID: SPN: 3464 FMI: 4/4 LAMP: Amber SRT: | A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine intake air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to ground when the actuator is commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning engine intake air throttle actuator.
Refer to Troubleshooting Fault Code 5881 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5935

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5935 PID: SPN: 4334 FMI: 7/7 LAMP: Amber SRT: | The Diesel Exhaust pressure sensor is reading erratic. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the system is fully primed at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It may be necessary to perform both validations to clear this fault:
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Blocked, restricted, or frozen diesel exhaust fluid dosing valve return line or return line connector.

Refer to Troubleshooting Fault Code 5935 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5936

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5936 PID: SPN: 4334 FMI: 0/15 LAMP: Amber SRT: | The Diesel Exhaust Fluid Pressure did not decrease below a threshold after a key off. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the system is fully primed at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • It may be necessary to perform both validations to clear this fault:
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The line heaters are not successfully thawing the frozen diesel exhaust fluid

The diesel exhaust fluid return line between the diesel exhaust fluid tank and the dosing valve is kinked or blocked

Refer to Troubleshooting Fault Code 5936 .

Last Modified: 17-Feb-2020


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | High battery voltage detected by the battery voltage monitor feature. | None on performance.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Overcharged batteries caused by a malfunctioning alternator or regulator.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 596 .

Last Modified: 17-Feb-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 597 .

Last Modified: 17-Feb-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Undercharged batteries caused by a malfunctioning alternator or regulator.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 598 .

Last Modified: 17-Feb-2020


Engine Coolant Temperature - Abnormal Rate of Change

FAULT CODE 5986

Engine Coolant Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5986 PID: SPN: 110 FMI: 10/10 LAMP: Amber SRT: | The engine coolant temperature sensor is reading an erratic value. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Monitor Engine Coolant Temperature Using the recommended Cummins® electronic service tool or equivalent during the Diagnostic Road Test or Dynamometer run. Coolant temperature should remain in the normal operating range.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning engine coolant thermostat.

In-range malfunction of the engine coolant temperature sensor

High resistance in the engine coolant temperature sensor signal or return lines.

Refer to Troubleshooting Fault Code 5986 .

Last Modified: 01-Feb-2020


Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6127

Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6127 PID: SPN: 636 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • The incorrect crankshaft position sensor has been installed.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 6127 .

Last Modified: 01-Feb-2020


Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

FAULT CODE 6266

Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6266 PID: SPN: 5862 FMI: 14/14 LAMP: Amber SRT: | The SCR intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The selective catalytic reduction (SCR) intake temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature entering the SCR catalyst. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intake temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by performing a road test.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A malfunctioning aftertreatment SCR intake temperature sensor

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 6266 .

Last Modified: 11-Oct-2020


J1939 Network #1 - Out of Calibration

FAULT CODE 6338

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6338 PID: SPN: 639 FMI: 13/13 LAMP: None SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 6338 .

Last Modified: 30-Jan-2022


Aftertreatment 1 Diesel Exhaust Fluid Pump Drive Percentage - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6485

Aftertreatment 1 Diesel Exhaust Fluid Pump Drive Percentage - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6485 PID: SPN: 4375 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.
  • Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank

The line heaters are not successfully thawing the frozen diesel exhaust fluid

The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected

The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected

  • Malfunctioning diesel exhaust fluid dosing unit

The diesel exhaust fluid suction and return lines between the dosing unit and diesel exhaust fluid tank are reversed

Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.

Refer to Troubleshooting Fault Code 6485 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6486

Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6486 PID: SPN: 4331 FMI: 0/16 LAMP: Amber SRT: | High aftertreatment diesel exhaust fluid flow detected. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit.

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing performance is high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Refer to Troubleshooting Fault Code 6486 .

Last Modified: 17-Feb-2020


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Change the engine oil and filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins® electronic service tool or equivalent to reset the Maintenance Monitor feature.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in the recommended Cummins® electronic service tool or equivalent. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649 .

Last Modified: 01-Feb-2020


Engine Speed - Root Cause Not Known

FAULT CODE 6595

Engine Speed - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6595 PID: SPN: 190 FMI: 11/11 LAMP: None SRT: | The engine control module has detected the primary and backup speed sensor signals have lost synchronization or are connected backwards. | Engine may be shut down.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of both engine speed/position signals.

Action Taken When the Fault Code is Active

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor have lost synchronization or the wiring harness connectors are reversed.

Refer to Troubleshooting Fault Code 6595 .

Last Modified: 17-Feb-2020


Engine Position Sensor - Abnormal Frequency or Pulse Width or Period

FAULT CODE 6712

Engine Position Sensor - Abnormal Frequency or Pulse Width or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6712 PID: SPN: 636 FMI: 8/8 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • The incorrect crankshaft position sensor has been installed.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 6712 .

Last Modified: 01-Feb-2020


Engine Position Sensor - Condition Exists

FAULT CODE 6713

Engine Position Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6713 PID: SPN: 636 FMI: 11/31 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Crankshaft Position Sensor Circuits

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning sensor
  • The incorrect crankshaft position sensor has been installed.
Refer to Troubleshooting Fault Code 6713 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6765

Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6765 PID: SPN: 3521 FMI: 0/16 LAMP: None SRT: | The aftertreatment diesel exhaust fluid quality sensor has detected on in-range high condition. | Engine speed and torque derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has risen above a critical threshold.

Action Taken When the Fault Code is Active

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 6765 .

Last Modified: 01-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6766

Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6766 PID: SPN: 3521 FMI: 1/18 LAMP: None SRT: | The diesel exhaust fluid (DEF) quality has been detected to be below a critical threshold. | Progressive torque and speed derate increasing in severity from time of alert.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 6766 .

Last Modified: 06-Sep-2020


Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

FAULT CODE 6767

Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6767 PID: SPN: 3521 FMI: 11/31 LAMP: None SRT: | The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | Engine speed and torque derate.
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

The aftertreatment DEF quality sensor is unable to determine the concentration of the urea or DEF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • Shorted or open J1939 data link wiring.
  • Malfunctioning Aftertreatment DEF Quality Sensor.
  • Inactive counts can be caused by elevation changes or tank sloshing while driving.
Refer to Troubleshooting Fault Code 6767 .

Last Modified: 01-Feb-2020


Aftertreatment System Assembly - Special Instructions

FAULT CODE 6771

Aftertreatment System Assembly - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6771 PID: SPN: 521032 FMI: 14/14 LAMP: Red SRT: | Aftertreatment System Assembly - Special Instructions. The incorrect aftertreatment diesel particulate filter system has been installed with the engine | None on performance.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been manufactured with the incorrect aftertreatment System.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 2 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. If this fault code is active, the aftertreatment part numbers should be verified.

For intermittent power supply and datalink communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 6771 .

Last Modified: 21-Feb-2021


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor - Data Not Rational - Drifted High

FAULT CODE 6786

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6786 PID: SPN: 3610 FMI: 2/20 LAMP: None SRT: | An offset in the Diesel Particulate Filter Outlet Pressure Sensor reading has been detected. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

  • Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

Refer to Troubleshooting Fault Code 6786 .

Last Modified: 09-May-2021


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness

Damaged or malfunctioning engine speed sensor

Damaged tone wheel

  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 693

Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 693 PID: P351 SPN: 1172 FMI: 2/2 LAMP: Amber SRT: | A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range compressor intake temperature sensor

High resistance in the compressor intake temperature sensor signal or return lines

ECM malfunction.

Refer to Troubleshooting Fault Code 693 .

Last Modified: 17-Feb-2020


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is between 100 rpm and 1200 rpm.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes of this fault code include:

Engine speed sensor rings that are loose or not aligned correctly

Mechanical misalignment.

Refer to Troubleshooting Fault Code 731 .

Last Modified: 17-Feb-2020


Aftertreatment 1 Diesel Exhaust Fluid Pump Motor Speed - Condition Exists

FAULT CODE 7325

Aftertreatment 1 Diesel Exhaust Fluid Pump Motor Speed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7325 PID: SPN: 4374 FMI: 11/31 LAMP: None SRT: | The aftertreatment diesel exhaust fluid dosing unit is running erratically. | None.
The aftertreatment diesel exhaust fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an erratic value from the aftertreatment diesel exhaust fluid dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage.
  • Open return or signal circuit in the engine wiring harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 7325 .

Last Modified: 01-Sep-2020


Aftertreatment Diesel Exhaust Fluid Pump 1 Motor Speed - Data Not Rational - Drifted High

FAULT CODE 7381

Aftertreatment Diesel Exhaust Fluid Pump 1 Motor Speed - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7381 PID: SPN: 4374 FMI: 2/20 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit is running erratically. | None.
The aftertreatment diesel exhaust fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an erratic value from the aftertreatment diesel exhaust fluid dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage.
  • Open return or signal circuit in the engine wiring harness, connectors, or sensor.
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 7381 .

Last Modified: 01-Sep-2020


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 741

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 741 PID: S314 SPN: 1176 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit.The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open return circuit in the engine harness, connector, sensor

  • Open signal circuit in the engine harness, connectors, or sensor

Damaged sensor

Refer to Troubleshooting Fault Code 741 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 742

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 742 PID: S314 SPN: 1176 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit.The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Signal shorted to return or ground in the sensor.

Damaged sensor

Refer to Troubleshooting Fault Code 742 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 743

Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 743 PID: S314 SPN: 1176 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure - Data erratic, intermittent or incorrect | Possible reduced engine performance.
Turbocharger Compessor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit.The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Stuck in-range ambient air temperature sensor

ECM malfunction.

Refer to Troubleshooting Fault Code 743 .

Last Modified: 17-Feb-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.

  • Damaged or malfunctioning camshaft position sensor.

Damaged speed indicator lobe.

Sensor air gap that is too large or small.

Refer to Troubleshooting Fault Code 778 .

Last Modified: 17-Feb-2020


Turbocharger 1 Compressor Intake Temperature Sensor - Abnormal Rate of Change

FAULT CODE 7861

Turbocharger 1 Compressor Intake Temperature Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7861 PID: SPN: 1172 FMI: 10/10 LAMP: Amber SRT: | A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure / Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

A default value for the compressor intake temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning turbocharger compressor intake pressure/temperature sensor

High resistance in the compressor intake temperature sensor signal or return lines

ECM malfunction.

Refer to Troubleshooting Fault Code 7861 .

Last Modified: 01-Feb-2020


Engine Turbocharger 1 Compressor Intake Pressure - Abnormal Rate of Change

FAULT CODE 7862

Engine Turbocharger 1 Compressor Intake Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7862 PID: SPN: 1176 FMI: 10/10 LAMP: Amber SRT: | A pressure too high or low for the operating conditions has been detected by the turbocharger compressor intake pressure sensor. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure / Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit.The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The turbocharger compressor intake pressure reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • This fault code may cause possible derate related fault code to become active.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning turbocharger compressor intake pressure/temperature sensor

ECM malfunction.

Refer to Troubleshooting Fault Code 7862 .

Last Modified: 01-Feb-2020


Ambient Air Temperature - Abnormal Rate of Change

FAULT CODE 7863

Ambient Air Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7863 PID: SPN: 171 FMI: 10/10 LAMP: Amber SRT: | The ambient air temperature sensor is reading an erratic value. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will illuminate the Malfunction Indicator Lamp (MIL) for a short period of time after start up with this fault code active.

  • A default value for the ambient air temperature reading is used.
  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High resistance in the ambient air temperature sensor signal or return lines

Malfunctioning ambient air temperature sensor

ECM malfunction.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 7863 .

Last Modified: 01-Feb-2020


Exhaust Gas Pressure - Abnormal Rate of Change

FAULT CODE 7864

Exhaust Gas Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7864 PID: SPN: 1209 FMI: 10/10 LAMP: Amber SRT: | A pressure too high or low for the operating conditions has been detected by the exhaust gas pressure sensor. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The exhaust gas pressure reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value is used for the exhaust gas pressure sensor reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range exhaust gas pressure sensor reading

High resistance in the exhaust gas pressure sensor signal or return lines

  • Plugging or restriction in the exhaust gas pressure sensor tube
  • Leaks in the exhaust system
Refer to Troubleshooting Fault Code 7864 .

Last Modified: 23-Aug-2020


Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 8522

Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 8522 PID: SPN: 3720 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment diesel particulate filter (DPF) requires exchange or cleaning. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the aftertreatment DPF restriction. The diagnostic alerts the operator of the requirement to clean or exchange the aftertreatment DPF.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment DPF differential pressure sensor. When the aftertreatment DPF differential pressure is above a maximum value at the end of an aftertreatment regeneration the fault code is set.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • In order to clear the fault code, the aftertreatment DPF must be exchanged or properly cleaned and the recommended Cummins® electronic service tool or equivalent must be used to perform an Aftertreatment Diesel Particulate Filter Installation.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with

The aftertreatment diesel particulate filter intake temperature sensor malfunctioned in-range

The aftertreatment diesel particulate filter requires exchange or cleaning.

Build up or plugging on the inlet face of the Diesel Particulate Filter.

  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 8522 .

Last Modified: 01-Feb-2020


High Sulphur Content In Fuel - Condition Exists

FAULT CODE 8523

High Sulphur Content In Fuel - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 8523 PID: SPN: 521240 FMI: 11/31 LAMP: Amber SRT: | High sulfur content in fuel has been detected. | None.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning aftertreatment diesel exhaust fluid dosing system.
  • Exhaust system leaks.
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.
  • Blocked or restricted diesel exhaust fluid filters
  • Blocked or restricted diesel exhaust fluid dosing unit filter/screen
  • Deposits or plugging on the inlet face of the Aftertreatment Selective Catalytic Reduction (SCR).

For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel

Refer to Troubleshooting Fault Code 8523 .

Last Modified: 11-Apr-2021


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

B6.7 CM2670 B153B

Fault Code: 111 | SPN: 629 | FMI: 12
Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Internal ECM Error

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Internal ECM Error

Solution: S00000446

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 90 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if a fault code from the following list is active or has greater than 3 inactive counts: 111, 335, 342, 343, 1597, 3697, 3724, 5874, 6155, 7155

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 122 | SPN: 102 | FMI: 3
Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00000457

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00000411

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the sensor disconnected: 123

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00000456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 123
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 123

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 123 | SPN: 102 | FMI: 4
Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00000457

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00000352

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the jumper wire in place: 122

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00002392

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 122
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 122

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 124 | SPN: 102 | FMI: 16
Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor has carbon buildup
  5. Intake manifold pressure sensor stuck in-range
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005080

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Turbocharger: 691, 692, 693
  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 351, 451, 452, 483, 484, 553, 559, 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00000457

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 125 | SPN: 102 | FMI: 18
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor has carbon buildup
  4. Intake manifold pressure sensor stuck in-range
  5. High exhaust restriction
  6. Leaks in the intake air system
  7. Turbocharger is malfunctioning
  8. ECM calibration revision history check
  9. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005475

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973, 5989, 5991
  • Barometric pressure: 295
  • Turbocharger: 741, 742, 743, 7862
  • Exhaust gas pressure: 2373, 2374, 2554, 2764
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277
  • Intake throttle: 3539, 3541, 3542, 5879, 5881, 5882

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the intake air system

Solution: S00005731

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the air intake component causing the air leak.

Refer to OEM Service Manual

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger is malfunctioning

Solution: S00008465

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger.

Refer to Procedure 010-033

  • Visually inspect the air filter and air intake system for leaks allowing dirt and dust to enter the turbocharger.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 131 | SPN: 91 | FMI: 3
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the sensor disconnected: 132

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 132 | SPN: 91 | FMI: 4
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to ground short
  7. Accelerator pedal position sensor circuit pin to pin short
  8. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the accelerator pedal position sensor SUPPLY pin and the accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 131

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 133 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008858

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code become active with the remote accelerator pedal position sensor disconnected: 134

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 134 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor open circuit check
  6. Remote accelerator pedal position sensor circuit pin to ground short
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000048

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000370

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the remote accelerator pedal position sensor SUPPLY pin and the remote accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 133

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor circuit pin to ground short

Solution: S00000454

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SUPPLY pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 144 | SPN: 110 | FMI: 3
Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code become active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 145
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 145 | SPN: 110 | FMI: 4
Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000313

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code became active with the sensor disconnected: 144

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000319

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 144
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 144

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 146 | SPN: 110 | FMI: 16
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Water pump is malfunctioning
  11. Combustion gases entering the cooling system
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Water pump is malfunctioning

Solution: S00004446

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the water pump.

Refer to Procedure 008-062

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the water pump.

Refer to Procedure 008-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Combustion gases entering the cooling system

Solution: S00001960

Verification

Conditions

  • None

Action

  • Check for air or combustion gases in the cooling system.
  • Perform the combustion gas leak test.

Refer to Procedure 008-020

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 151 | SPN: 110 | FMI: 0
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Water pump is malfunctioning
  11. Combustion gases entering the cooling system
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Water pump is malfunctioning

Solution: S00004446

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the water pump.

Refer to Procedure 008-062

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the water pump.

Refer to Procedure 008-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Combustion gases entering the cooling system

Solution: S00001960

Verification

Conditions

  • None

Action

  • Check for air or combustion gases in the cooling system.
  • Perform the combustion gas leak test.

Refer to Procedure 008-020

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 153 | SPN: 105 | FMI: 3
Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00000354

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000576

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 154
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 154 | SPN: 105 | FMI: 4
Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00001234

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the sensor disconnected: 153

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000479

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 153
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 153

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 155 | SPN: 105 | FMI: 0
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Cooling fan component inspection
  3. High intake manifold temperature basic checks
  4. Radiator is externally obstructed
  5. Fan clutch operates incorrectly
  6. Intake manifold temperature sensor stuck in-range
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Leaks in the intake air system
  10. Malfunctioning cooling fan drive or cooling fan controls
  11. Turbocharger is malfunctioning
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000050

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Fan control circuit: 245, 2377

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Leaks in the intake air system

Solution: S00005731

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the air intake component causing the air leak.

Refer to OEM Service Manual

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 187 | SPN: 3510 | FMI: 4
Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage below normal

1 - ECM sensor supply 2 voltage below normal

Solution: S00005160

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 222 | SPN: 108 | FMI: 4
Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Barometric pressure sensor is malfunctioning

1 - Barometric pressure sensor is malfunctioning

Solution: S00004535

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 221 , 222

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

The barometric pressure sensor is internal to the ECM and not a separately serviceable part.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 227 | SPN: 3510 | FMI: 3
Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 2 voltage above normal

Solution: S00000992

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 227
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 227

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 234 | SPN: 190 | FMI: 0
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine speed sensor is malfunctioning
  3. Turbocharger oil seal is leaking oil into air intake/exhaust system
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000067

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689
  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger oil seal is leaking oil into air intake/exhaust system

Solution: S00005777

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 238 | SPN: 3511 | FMI: 4
Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage below normal

Solution: S00001086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 239 | SPN: 3511 | FMI: 3
Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage above normal

Solution: S00000819

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 239
  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 239

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 241 | SPN: 84 | FMI: 2
Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Vehicle speed sensor tampering
  2. Incorrect vehicle speed sensor configuration
  3. Vehicle speed sensor open circuit check
  4. Vehicle speed sensor circuit pin to ground short
  5. Vehicle speed sensor circuit pin to pin short
  6. Mechanical gear slippage causing erratic wheel speed data
  7. ECM calibration revision history check

1 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 245 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid circuit pin to ground short
  2. Fan control solenoid circuit pin to pin short

1 - Fan control solenoid circuit pin to ground short

Solution: S00001060

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 249 | SPN: 171 | FMI: 3
Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor open circuit check
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000374

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the sensor connector of the OEM wiring harness
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the jumper wire in place: 256

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 256 | SPN: 171 | FMI: 4
Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor circuit pin to ground short
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000375

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the sensor disconnected: 249

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor circuit pin to ground short

Solution: S00003624

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 271 | SPN: 1347 | FMI: 4
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator circuit pin to ground short
  3. ECM calibration revision history check

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 272 | SPN: 1347 | FMI: 3
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator open circuit check
  3. Fuel pump actuator circuit pin to ground short
  4. ECM calibration revision history check
  5. Fuel pump actuator is malfunctioning

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator open circuit check

Solution: S00000508

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness fuel pump actuator RETURN pin at the ECM connector of the engine wiring harness and the fuel pump actuator RETURN pin at the fuel pump actuator connector.
  • Measure the resistance between the engine wiring harness fuel pump actuator SIGNAL pin at the ECM connector of the engine wiring harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 285 | SPN: 639 | FMI: 9
SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 286 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 295 | SPN: 108 | FMI: 2
Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000070

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Barometric pressure: 221, 222

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 319 | SPN: 251 | FMI: 2
Real Time Clock - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Real-time clock power interrupted or is incorrect
  2. Low real-time clock battery voltage
  3. Real time clock open circuit check
  4. Real time clock circuit pin to ground short
  5. Engine wiring harness has a pin to pin short
  6. ECM calibration revision history check

1 - Real-time clock power interrupted or is incorrect

Solution: S00000525

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Select Advanced ECM Data - Real Time Clock Settings.
  • Check if the address for the Real Time Clock signal is correct per OEM specification.
  • Check to ensure Real Time Clock is enabled and adjust "Auto Set" if required.

Refer to Procedure 019-311

Specification

  • None

Linked Solutions

  • None

Repair

  • Modify the real-time clock battery setting to the correct configuration.

Refer to Procedure 019-311

  • Enable the real time clock.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low real-time clock battery voltage

Solution: S00000526

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.

Action

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Specification

  • Voltage must be within the following specification: 3.3 - 3.6 VDC

Linked Solutions

  • None

Repair

  • Replace the real-time clock battery.

Refer to Procedure 019-311

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Real time clock open circuit check

Solution: S00001966

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the real time clock battery engine wiring harness connector and the real time clock battery SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the real time clock battery RETURN pin at the real time clock battery engine wiring harness connector and the real time clock battery RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Real time clock circuit pin to ground short

Solution: S00001964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the engine wiring harness ECM connect to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine wiring harness has a pin to pin short

Solution: S00001967

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real time clock battery from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the real time clock battery SUPPLY pin at the ECM connector of the engine wiring harness and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 322 | SPN: 651 | FMI: 5
Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 1 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 1 current below normal or open circuit

Solution: S00000513

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 322

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 323 | SPN: 655 | FMI: 5
Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 5 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 5 current below normal or open circuit

Solution: S00000506

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 323

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 324 | SPN: 653 | FMI: 5
Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 3 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 3 current below normal or open circuit

Solution: S00000509

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 324

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 325 | SPN: 656 | FMI: 5
Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 6 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 6 current below normal or open circuit

Solution: S00000510

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 325

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 331 | SPN: 652 | FMI: 5
Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 2 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 2 current below normal or open circuit

Solution: S00000512

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 331

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 332 | SPN: 654 | FMI: 5
Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Injector solenoid driver cylinder 4 current below normal or open circuit
  2. Injector solenoid circuit check at pass through connector
  3. Fuel injector solenoid has an open circuit
  4. Fuel injector driver solenoid circuit pin to ground short
  5. Fuel injector solenoid to engine block ground resistance check
  6. Injector driver solenoid circuit pin to pin short
  7. Fuel injector isolation test
  8. Fuel injector solenoid isolation test
  9. ECM fuel injector solenoid driver is malfunctioning

1 - Injector solenoid driver cylinder 4 current below normal or open circuit

Solution: S00000511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 332

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 334 | SPN: 110 | FMI: 2
Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Thermostat is malfunctioning
  3. Out-of-chassis opening temperature test
  4. ECM calibration revision history check
  5. Coolant temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000074

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant temperature sensor is malfunctioning

Solution: S00001238

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 343 | SPN: 629 | FMI: 12
Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Charging system alternator is malfunctioning
  4. Keyswitch open circuit check
  5. ECM calibration revision history check
  6. Internal ECM Error

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Internal ECM Error

Solution: S00000446

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 90 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if a fault code from the following list is active or has greater than 3 inactive counts: 111, 335, 342, 343, 1597, 3697, 3724, 5874, 6155, 7155

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 351 | SPN: 3597 | FMI: 12
Injector Power Supply - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. Battery or battery cables are malfunctioning
  3. ECM power supply open circuit check
  4. Engine control module power supply circuit pin to ground short
  5. ECM calibration revision history check
  6. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000077

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM power supply open circuit check

Solution: S00001889

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the OEM wiring harness connector and the battery positive (+) pins at the battery positive (+) connection.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 0.5 Ω
  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 0.5 Ω

Linked Solutions

Click on the link below:

  • Engine control module power supply circuit pin to ground short

Refer to S00002882

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • None
Next Solution

3.1 - Engine control module power supply circuit pin to ground short

Solution: S00002882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery negative (-) pins at the OEM wiring harness connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 352 | SPN: 3509 | FMI: 4
Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage below normal

1 - ECM sensor supply 1 voltage below normal

Solution: S00005670

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine wiring harness.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 20-Jun-2021


NO TITLE

B6.7 CM2670 B153B

Fault Code: 386 | SPN: 3509 | FMI: 3
Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 1 voltage above normal

Solution: S00002196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 386
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 386

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 415 | SPN: 100 | FMI: 1
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Basic oil system checks
  2. Contaminated lubricating oil
  3. Lubricating oil pressure switch is malfunctioning
  4. Loose or broken lubricating oil suction tube
  5. Main lubricating oil pressure regulator is malfunctioning
  6. Lubricating oil pump is malfunctioning
  7. ECM calibration revision history check

1 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure switch is malfunctioning

Solution: S00002162

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Install a mechanical gauge on the engine.
  • Start the engine.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Refer to Procedure 007-037

Specification

  • If the measured oil pressure is within specification, then a malfunctioning lubricating oil pressure switch has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure switch.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00001453

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 418 | SPN: 97 | FMI: 15
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Water accumulation in the fuel filter
  3. Water in fuel sensor circuit pin to ground short
  4. OEM wiring harness has a pin to pin short
  5. ECM calibration revision history check
  6. Water in fuel sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000079

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 428, 429

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Water accumulation in the fuel filter

Solution: S00005320

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor circuit pin to ground short

Solution: S00004487

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 427 | SPN: 639 | FMI: 9
J1939 Network #1 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 428 | SPN: 97 | FMI: 3
Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect water-in-fuel sensor installed
  2. Water in fuel sensor open circuit check
  3. OEM wiring harness has a pin to pin short
  4. Water in fuel sensor is malfunctioning

1 - Incorrect water-in-fuel sensor installed

Solution: S00000588

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct water-in-fuel sensor is being used for the engine application.

Specification

  • If the water in fuel sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Install the correct water in fuel sensor for the engine configuration.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor open circuit check

Solution: S00000589

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water in fuel sensor SIGNAL pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the water in fuel sensor RETURN pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 429 | SPN: 97 | FMI: 4
Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Water in fuel sensor circuit pin to ground short
  2. OEM wiring harness has a pin to pin short
  3. Water in fuel sensor is malfunctioning

1 - Water in fuel sensor circuit pin to ground short

Solution: S00004487

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 435 | SPN: 100 | FMI: 2
Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Lubricating oil pressure switch open circuit check
  2. Lubricating oil pressure switch is malfunctioning
  3. Lubricating oil pressure switch circuit pin to pin short
  4. Main lubricating oil pressure regulator is malfunctioning
  5. ECM calibration revision history check

1 - Lubricating oil pressure switch open circuit check

Solution: S00002073

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the lubricating oil pressure sensor SIGNAL pin at the lubricating oil pressure sensor engine wiring harness connector and the lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil pressure switch is malfunctioning

Solution: S00002892

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure switch from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the lubricating oil pressure switch SIGNAL pin at the lubricating oil pressure switch and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure switch.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure switch circuit pin to pin short

Solution: S00002763

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00001453

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-029

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 436 | SPN: 105 | FMI: 2
Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005103

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Real time clock: 3492

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 441 | SPN: 168 | FMI: 18
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. Unswitched battery open circuit check
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 442 | SPN: 168 | FMI: 16
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 451 | SPN: 157 | FMI: 3
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor is malfunctioning
  3. Fuel rail pressure sensor voltage check
  4. Fuel rail pressure sensor voltage check at the ECM
  5. Fuel rail pressure sensor circuit response
  6. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor is malfunctioning

Solution: S00000598

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the fuel rail pressure sensor is the correct fuel rail pressure sensor.

When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized.

Refer to Procedure 006-060

  • Monitor the fuel rail pressure sensor.

Specification

  • If the FUEL RAIL PRESSURE MEASURED does not meet specification, then a malfunctioning fuel rail pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel rail pressure sensor circuit response

Solution: S00000378

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000604

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 452
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 452 | SPN: 157 | FMI: 4
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor is malfunctioning
  3. Fuel rail pressure sensor voltage check
  4. Fuel rail pressure sensor voltage check at the ECM
  5. Fuel rail pressure sensor circuit response
  6. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor is malfunctioning

Solution: S00000598

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the fuel rail pressure sensor is the correct fuel rail pressure sensor.

When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized.

Refer to Procedure 006-060

  • Monitor the fuel rail pressure sensor.

Specification

  • If the FUEL RAIL PRESSURE MEASURED does not meet specification, then a malfunctioning fuel rail pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel rail pressure sensor circuit response

Solution: S00000379

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the sensor disconnected: 451

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000605

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 451
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 451

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 515 | SPN: 3514 | FMI: 3
Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage above normal

Solution: S00000026

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 515
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 515

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 516 | SPN: 3514 | FMI: 4
Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage below normal

Solution: S00000934

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 553 | SPN: 157 | FMI: 16
Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator o-ring is malfunctioning
  6. ECM calibration revision history check
  7. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00005148

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 3332

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator o-ring is malfunctioning

Solution: S00000620

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

  • Visually inspect fuel pump actuator for a cut or damaged o-ring.
  • Visually inspect the wiring or body of the actuator for damage.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the o-ring.

Refer to Procedure 019-117

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 555 | SPN: 101 | FMI: 16
Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil level is incorrect
  3. Plugged external crankcase breather tube
  4. Crankcase pressure sensor stuck in-range
  5. Crankcase Blowby Check
  6. Plugged external crankcase breather tube
  7. Turbocharger leaking air into crankcase
  8. Air compressor leaking air into crankcase
  9. Worn or damaged power cylinder components
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001079

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844, 3733, 3734

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankcase Blowby Check

Solution: S00005142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00006462

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Worn or damaged power cylinder components

Solution: S00006462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the cylinder block bore.

Refer to Procedure 001-026

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 556 | SPN: 101 | FMI: 0
Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil level is incorrect
  3. Plugged external crankcase breather tube
  4. Crankcase pressure sensor stuck in-range
  5. Crankcase Blowby Check
  6. Plugged external crankcase breather tube
  7. Turbocharger leaking air into crankcase
  8. Air compressor leaking air into crankcase
  9. Worn or damaged power cylinder components
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001080

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844, 3733, 3734

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankcase Blowby Check

Solution: S00005142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00006462

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Worn or damaged power cylinder components

Solution: S00006462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the cylinder block bore.

Refer to Procedure 001-026

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 559 | SPN: 157 | FMI: 18
Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine will not start
  3. Low pressure fuel system component is malfunctioning
  4. Air in fuel check
  5. Fuel Inlet Restriction check
  6. Fuel filter restriction
  7. Fuel pump gear pump check
  8. Fuel injector return flow check
  9. Fuel injector isolation test
  10. High-Pressure Fuel Pump Supply Flow Test
  11. Air in fuel check
  12. Fuel pressure relief valve return flow excessive
  13. Fuel pump actuator is malfunctioning
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001575

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 324, 331, 332, 449, 451, 452, 553, 2311, 3727, 3741

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure fuel system component is malfunctioning

Solution: S00007273

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.
  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • Air in fuel check

Refer to S00001205

  • Fuel Inlet Restriction check

Refer to S00006667

  • Fuel filter restriction

Refer to S00004905

  • Fuel pump gear pump check

Refer to S00006666

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Fuel Inlet Restriction check

Solution: S00006667

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the fuel tank stand pipe.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Fuel filter restriction

Solution: S00004905

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the differential pressure does not meet specification, then a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel filter.

Refer to Procedure 006-015

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Fuel pump gear pump check

Solution: S00006666

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the fuel pump gear pump pressure check.

Refer to Procedure 005-236

Specification

  • If the fuel pump gear pump pressure is not within specification, then a malfunctioning fuel pump gear pump has been detected.

Linked Solutions

  • None

Repair

  • Replace high pressure fuel pump.

Refer to Procedure 005-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - High-Pressure Fuel Pump Supply Flow Test

Solution: S00002889

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the High-Pressure Fuel Pump Supply Flow Test.

Refer to Procedure 005-236

Specification

  • If the high-pressure fuel pump flow is not within specification, then a malfunctioning high-pressure fuel pump has been detected.

Refer to Procedure 005-016

Linked Solutions

  • None

Repair

  • Replace high pressure fuel pump.

Refer to Procedure 005-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel pressure relief valve return flow excessive

Solution: S00004613

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Engine running at idle.

Action

  • Perform the Fuel System Leakage Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Fuel pump actuator is malfunctioning

Solution: S00001170

Verification

Conditions

  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor Commanded Fuel Rail Pressure.
  • Monitor Measured Fuel Rail Pressure.

Specification

  • Proceed to the Repair section if the Measured Fuel Rail Pressure deviates from the Commanded Fuel Rail Pressure by more than following: 100 bar [1450 psi]
  • Proceed to the next solution if the Measured Fuel Rail Pressure does not deviate from the Commanded Fuel Rail Pressure by more than the following: 100 bar [1450 psi]

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 584 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay open circuit check
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 585 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay circuit pin to ground short
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 596 | SPN: 167 | FMI: 16
Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 597 | SPN: 167 | FMI: 18
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Loose alternator belt
  3. Charging system alternator is malfunctioning
  4. Unswitched battery open circuit check
  5. Unswitched battery circuit pin to pin short
  6. Loose charging system alternator pulley
  7. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose alternator belt

Solution: S00005691

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 008-002

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 008-087

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 008-002

  • Replace the alternator belt.

Refer to Procedure 008-002

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose charging system alternator pulley

Solution: S00005287

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the alternator pulley for damage.

Refer to OEM Service Manual

  • Check the charging system alternator pulley nut torque.

Refer to OEM Service Manual

Specification

  • If damage has been observed or if alternator pulley nut torque is out of specification, the proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace or adjust the charging system alternator pulley so that it is tight on the shaft.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 598 | SPN: 167 | FMI: 1
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Loose alternator belt
  4. Charging system alternator is malfunctioning
  5. Unswitched battery open circuit check
  6. Unswitched battery circuit pin to pin short
  7. ECM calibration revision history check

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Loose alternator belt

Solution: S00005691

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 008-002

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 008-087

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 008-002

  • Replace the alternator belt.

Refer to Procedure 008-002

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 649 | SPN: 1378 | FMI: 31
Engine Oil Change Interval - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Oil change interval maintenance warning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Oil change interval maintenance warning

Solution: S00000671

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the lubricating oil maintenance interval has been exceeded.

Linked Solutions

  • None

Repair

  • Change the lubricating oil.

Refer to Procedure 007-037

  • Change the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 689 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankshaft tone wheel is damaged
  3. Crankshaft position sensor voltage check
  4. Crankshaft position sensor voltage check at the ECM
  5. Engine crankshaft speed/position sensor check
  6. Crankshaft position sensor open circuit check
  7. Crankshaft position sensor circuit pin to pin short
  8. ECM calibration revision history check
  9. Engine crankshaft speed/position sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 3: 238, 239

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankshaft tone wheel is damaged

Solution: S00000683

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor voltage check

Solution: S00000678

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft position sensor SUPPLY pin and the crankshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankshaft position sensor voltage check at the ECM

Refer to S00000679

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Crankshaft position sensor voltage check at the ECM

Solution: S00000679

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft positon sensor SUPPLY pin and the crankshaft positon sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft position sensor circuit pin to pin short

Solution: S00000674

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00000866

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 691 | SPN: 1172 | FMI: 3
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake temperature sensor circuit response
  3. Turbocharger compressor intake temperature sensor open circuit check
  4. Turbocharger compressor intake temperature sensor circuit pin to pin short

1 - Check for primary fault codes

Solution: S00004939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response

Solution: S00005295

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger compressor intake temperature sensor SIGNAL pin and the turbocharger compressor intake temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the following fault code became active with the jumper wire in place: 692

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger compressor intake temperature sensor open circuit check

Solution: S00004935

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the turbocharger compressor intake temperature sensor OEM wiring harness connector and the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the turbocharger compressor intake temperature sensor RETURN pin at the turbocharger compressor intake temperature sensor OEM wiring harness connector and the turbocharger compressor intake temperature sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger compressor intake temperature sensor circuit pin to pin short

Solution: S00004936

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the turbocharger compressor intake temperature sensor RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 692 | SPN: 1172 | FMI: 4
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake temperature sensor circuit response
  3. Turbocharger compressor intake temperature sensor circuit response at the ECM
  4. Turbocharger compressor intake temperature sensor circuit pin to ground short
  5. Turbocharger compressor intake temperature sensor circuit pin to pin short

1 - Check for primary fault codes

Solution: S00004939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response

Solution: S00008003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the following fault code became active with the sensor disconnected: 691

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger compressor intake temperature sensor circuit response at the ECM

Solution: S00000685

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 691
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 691

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger compressor intake temperature sensor circuit pin to ground short

Solution: S00005564

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger compressor intake temperature sensor circuit pin to pin short

Solution: S00004936

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the turbocharger compressor intake temperature sensor RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 693 | SPN: 1172 | FMI: 2
Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Compressor intake temperature sensor stuck in-range
  3. Turbocharger compressor intake temperature sensor open circuit check
  4. Turbocharger compressor intake temperature sensor circuit pin to ground short
  5. Turbocharger compressor intake temperature sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005168

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 691, 692
  • Real time clock: 3492

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Compressor intake temperature sensor stuck in-range

Solution: S00004923

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure/temperature sensor.

Specification

  • A malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected if the turbocharger compressor intake pressure/temperature sensor is not within the following specification of local ambient air temperature: 5.5C [10F]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger compressor intake temperature sensor open circuit check

Solution: S00004935

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the turbocharger compressor intake temperature sensor OEM wiring harness connector and the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the turbocharger compressor intake temperature sensor RETURN pin at the turbocharger compressor intake temperature sensor OEM wiring harness connector and the turbocharger compressor intake temperature sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger compressor intake temperature sensor circuit pin to ground short

Solution: S00005564

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger compressor intake temperature sensor circuit pin to pin short

Solution: S00004936

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the turbocharger compressor intake temperature sensor RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 731 | SPN: 723 | FMI: 7
Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intermittent ground connection
  3. Camshaft position sensor is damaged
  4. Engine crankshaft speed/position sensor check
  5. Camshaft tone wheel is damaged
  6. ECM calibration revision history check
  7. Incorrect base engine timing

1 - Check for primary fault codes

Solution: S00001081

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 115, 778, 2321

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft tone wheel is damaged

Solution: S00006265

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Visually inspect the camshaft speed indicator ring for damage.

Refer to Procedure 001-008

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft speed indicator ring.

Refer to Procedure 001-008

  • Replace the camshaft gear.

Refer to Procedure 001-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Incorrect base engine timing

Solution: S00001614

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the base engine timing.

Refer to Procedure 001-008

Specification

  • If the camshaft and crankshaft gears are not properly aligned, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Correct the base engine timing.

Refer to Procedure 001-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 741 | SPN: 1176 | FMI: 3
Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake pressure sensor voltage check
  3. Turbocharger compressor intake pressure sensor open circuit check
  4. Turbocharger compressor intake pressure sensor circuit response
  5. Turbocharger compressor intake pressure sensor circuit pin to pin short

1 - Check for primary fault codes

Solution: S00004939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake pressure sensor voltage check

Solution: S00004941

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the turbocharger compressor intake pressure/temperature sensor SUPPLY pin and the turbocharger compressor intake pressure/temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 Volts

Linked Solutions

  • Turbocharger compressor intake pressure sensor open circuit check

Refer to S00004942

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Turbocharger compressor intake pressure sensor open circuit check

Solution: S00004942

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SUPPLY pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the turbocharger compressor intake pressure sensor RETURN pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Turbocharger compressor intake pressure sensor circuit response

Solution: S00003845

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake pressure sensor has been detected if the following fault code became active with the sensor disconnected: 742

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger compressor intake pressure sensor circuit pin to pin short

Solution: S00005308

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 742 | SPN: 1176 | FMI: 4
Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake pressure sensor voltage check
  3. Turbocharger compressor intake pressure sensor open circuit check
  4. Turbocharger compressor intake pressure sensor circuit response
  5. Turbocharger compressor intake pressure sensor open circuit check
  6. Turbocharger compressor intake pressure sensor circuit pin to ground short
  7. Turbocharger compressor intake pressure sensor circuit pin to pin short

1 - Check for primary fault codes

Solution: S00004939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake pressure sensor voltage check

Solution: S00004941

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the turbocharger compressor intake pressure/temperature sensor SUPPLY pin and the turbocharger compressor intake pressure/temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 Volts

Linked Solutions

  • Turbocharger compressor intake pressure sensor open circuit check

Refer to S00004942

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Turbocharger compressor intake pressure sensor open circuit check

Solution: S00004942

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SUPPLY pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the turbocharger compressor intake pressure sensor RETURN pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Turbocharger compressor intake pressure sensor circuit response

Solution: S00003843

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger compressor intake pressure sensor SUPPLY pin and the turbocharger compressor intake pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake pressure sensor has been detected if the following fault code became active with the jumper wire in place: 741

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger compressor intake pressure sensor open circuit check

Solution: S00005310

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Troubleshoot each harness connected in series to determine which contains the open circuit.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger compressor intake pressure sensor circuit pin to ground short

Solution: S00005311

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger compressor intake pressure sensor circuit pin to pin short

Solution: S00005308

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 743 | SPN: 1176 | FMI: 2
Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Turbocharger compressor intake pressure sensor voltage check
  4. Turbocharger compressor intake pressure sensor open circuit check
  5. Turbocharger compressor intake pressure/temperature sensor is malfunctioning
  6. Turbocharger compressor intake pressure sensor open circuit check
  7. Turbocharger compressor intake pressure sensor circuit pin to ground short
  8. Turbocharger compressor intake pressure sensor circuit pin to pin short
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 741, 742

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger compressor intake pressure sensor voltage check

Solution: S00004941

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the turbocharger compressor intake pressure/temperature sensor SUPPLY pin and the turbocharger compressor intake pressure/temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 Volts

Linked Solutions

  • Turbocharger compressor intake pressure sensor open circuit check

Refer to S00004942

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Turbocharger compressor intake pressure sensor open circuit check

Solution: S00004942

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SUPPLY pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the turbocharger compressor intake pressure sensor RETURN pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Turbocharger compressor intake pressure/temperature sensor is malfunctioning

Solution: S00003201

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure.
  • Compare to the local ambient air pressure.

Specification

  • If the sensor reading is not within specification, then a malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger compressor intake pressure sensor open circuit check

Solution: S00005310

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor OEM wiring harness connector and the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Troubleshoot each harness connected in series to determine which contains the open circuit.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger compressor intake pressure sensor circuit pin to ground short

Solution: S00005311

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger compressor intake pressure sensor circuit pin to pin short

Solution: S00005308

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 778 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. Camshaft tone wheel is damaged
  8. ECM calibration revision history check
  9. Incorrect base engine timing
  10. Camshaft position sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001825

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Voltage: 441, 442

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Camshaft tone wheel is damaged

Solution: S00006265

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Visually inspect the camshaft speed indicator ring for damage.

Refer to Procedure 001-008

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft speed indicator ring.

Refer to Procedure 001-008

  • Replace the camshaft gear.

Refer to Procedure 001-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect base engine timing

Solution: S00001614

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the base engine timing.

Refer to Procedure 001-008

Specification

  • If the camshaft and crankshaft gears are not properly aligned, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Correct the base engine timing.

Refer to Procedure 001-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Camshaft position sensor is malfunctioning

Solution: S00000364

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1117 | SPN: 3597 | FMI: 2
Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Battery load test
  3. Unswitched battery open circuit check
  4. Keyswitch open circuit check
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery load test

Solution: S00000669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the batteries.

Refer to Procedure 013-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1139 | SPN: 651 | FMI: 7
Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1141 | SPN: 652 | FMI: 7
Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1142 | SPN: 653 | FMI: 7
Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1143 | SPN: 654 | FMI: 7
Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1144 | SPN: 655 | FMI: 7
Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1145 | SPN: 656 | FMI: 7
Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00005157

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1239 | SPN: 2623 | FMI: 3
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000134

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1241 | SPN: 2623 | FMI: 4
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to ground short
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000135

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1242 | SPN: 91 | FMI: 2
Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000136

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1668 | SPN: 1761 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  3. Aftertreatment power relay open circuit check
  4. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check
  5. ECM calibration revision history check
  6. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00008857

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4277, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00008388

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Refer to S00005422

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Solution: S00005422

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY at the sensor connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00006448

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1669 | SPN: 1761 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  3. Aftertreatment power relay open circuit check
  4. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check
  5. ECM calibration revision history check
  6. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00008857

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4277, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00008388

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Refer to S00005422

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Solution: S00005422

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY at the sensor connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00006448

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1671 | SPN: 1761 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00008041

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1673 | SPN: 1761 | FMI: 1
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00008041

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1677 | SPN: 3031 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00008857

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4277, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00006448

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00005378

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1678 | SPN: 3031 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00008857

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4277, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00006448

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00005378

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1679 | SPN: 3031 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. OEM ambient air temperature sensor stuck in-range
  3. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001589

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00006603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1682 | SPN: 3362 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid tank level sensor tampering
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  6. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  7. Aftertreatment diesel exhaust fluid dosing unit suction test
  8. Aftertreatment diesel exhaust fluid dosing unit return circuit check
  9. Aftertreatment diesel exhaust fluid dosing system cleaning
  10. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  11. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short
  12. Aftertreatment diesel exhaust fluid pressure line restricted
  13. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  14. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  15. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  16. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006449

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1671, 3547, 3571, 3572, 3596, 5278, 5864, 5865, 5935
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor tampering

Solution: S00006695

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank level sensor is properly mounted.
  • Verify that no external device is connected in place of the aftertreatment diesel exhaust fluid tank level sensor.
  • Visually inspect the aftertreatment diesel exhaust fluid tank level sensor for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

  • Repair or remove the tampering device or any external device.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00006324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not operate during the test, then proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing unit return circuit check.
  • Proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing system cleaning if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Proceed to the next solution if the vacuum in diagnostic line is greater than the following: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit return circuit check

Refer to S00000858

  • Aftertreatment diesel exhaust fluid dosing system cleaning

Refer to S00002910

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing unit return circuit check

Solution: S00000858

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid dosing unit motor runs.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Aftertreatment diesel exhaust fluid dosing system cleaning

Solution: S00002910

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Refer to Procedure 011-056

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short

Solution: S00004359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor SUPPLY pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

9 - Aftertreatment diesel exhaust fluid pressure line restricted

Solution: S00003284

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the outlet of the aftertreatment diesel exhaust fluid dosing unit and the pressure line.

Refer to Procedure 011-144

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then a restricted aftertreatment diesel exhaust fluid pressure line has been detected.
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure is less than specification.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00003230

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid pressure line.

Refer to OEM Service Manual

Validation

  • None
Next Solution

9.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003230

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit outlet fitting for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit filter for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing valve inlet fitting screen for signs of blockage or buildup.

Specification

  • If there are no signs of blockage or buildup, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.
  • If there are signs of blockage or buildup, then a restricted aftertreatment diesel exhaust fluid dosing unit outlet fitting or aftertreatment diesel exhaust fluid dosing valve inlet fitting has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing unit filter regardless of condition.

Refer to Procedure 011-060

  • Clean the aftertreatment diesel exhaust fluid dosing unit outlet fitting.
  • Clean the aftertreatment diesel exhaust fluid dosing valve inlet fitting.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1685 | SPN: 3364 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000144

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00008226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1686 | SPN: 3364 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000145

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1691 | SPN: 5298 | FMI: 18
Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005115

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DOC: 3313, 3314, 3315, 3251,
  • Aftertreatment DPF: 3311 3312, 3316, 3317, 3318, 3319, 3321, 3322, 3253, 3254, 3255, 3256, 4151, 4158, 4161, 4162, 4163, 4259
  • Fuel: 271, 272, 451, 452, 483, 484, 559, 755,1139 1141, 1142, 1143, 1144, 1145, 3727, 3741,

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1695 | SPN: 3513 | FMI: 3
Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 5 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 5 voltage above normal

Solution: S00005114

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector to the ECM battery (+) pins at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning ECM has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1696 | SPN: 3513 | FMI: 4
Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 5 voltage below normal
  2. OEM wiring harness has a short to ground
  3. Sensor supply 5 OEM wiring harness SUPPLY pin shorted to another pin
  4. ECM calibration revision history check

1 - ECM sensor supply 5 voltage below normal

Solution: S00006598

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Perform the following actions one at a time:
  • Disconnect the engine turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

  • Replace accelerator pedal or lever position sensor.

Refer to OEM Service Manual

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM wiring harness has a short to ground

Solution: S00006627

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Sensor supply 5 OEM wiring harness SUPPLY pin shorted to another pin

Solution: S00006599

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1714 | SPN: 3364 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00008226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1715 | SPN: 3364 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000149

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1843 | SPN: 101 | FMI: 3
Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000409

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1844

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1844
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1844

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1844 | SPN: 101 | FMI: 4
Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000410

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001176

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1843
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1848 | SPN: 105 | FMI: 10
Intake Manifold 1 Temperature - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005178

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154, 436
  • Turbocharger: 691, 692, 693

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1852 | SPN: 97 | FMI: 16
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Water accumulation in the fuel filter
  2. Water in fuel sensor circuit pin to ground short
  3. ECM calibration revision history check
  4. Water in fuel sensor is malfunctioning

1 - Water accumulation in the fuel filter

Solution: S00005320

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor circuit pin to ground short

Solution: S00004487

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the water in fuel sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1879 | SPN: 3251 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF differential pressure sensor circuit response
  5. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

1 - Check for primary fault codes

Solution: S00008858

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF differential pressure sensor circuit response

Solution: S00000582

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF differential pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1881

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00005431

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1881 | SPN: 3251 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF differential pressure sensor circuit response
  5. Aftertreatment DPF differential pressure sensor open circuit check
  6. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  7. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

1 - Check for primary fault codes

Solution: S00000157

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF differential pressure sensor circuit response

Solution: S00000580

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF differential pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1879

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00005433

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00005434

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00005431

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1883 | SPN: 3251 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment DPF differential pressure sensor open circuit check
  7. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  8. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  9. ECM calibration revision history check
  10. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000158

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00005433

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00005434

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00005431

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1885 | SPN: 3216 | FMI: 4
Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000017

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 3232, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1887 | SPN: 3226 | FMI: 4
Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000160

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 2771, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00005603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1921 | SPN: 3251 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. Aftertreatment temperature sensor stuck in-range
  6. Aftertreatment DPF partially obstructed or plugged
  7. Snap acceleration check for excessive black smoke
  8. ECM calibration revision history check
  9. Stationary aftertreatment regeneration is needed

1 - Check for primary fault codes

Solution: S00007369

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 122, 123, 124, 125, 2973
  • Aftertreatment DPF: 3133, 3134, 3135, 3312, 3319, 3321, 3322, 3255, 3256, 3753, 5275, 5276, 5383, 5715
  • Aftertreatment regeneration: 2777, 3375, 3376, 4213
  • Aftertreatment DOC: 1691, 3254, 3311, 3251, 3253, 3313, 3314, 3315, 3316, 3317, 3318
  • Wheel based vehicle speed: 241
  • Exhaust gas temperature: 4151, 4152
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF partially obstructed or plugged

Solution: S00006391

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1922 | SPN: 3251 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Fault Code 1922 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Aftertreatment DPF differential pressure sensor tubes plugged
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Snap acceleration check for excessive black smoke
  7. Overhead component damaged or out of adjustment
  8. ECM calibration revision history check
  9. Aftertreatment DPF is malfunctioning

1 - Fault Code 1922 requires that ALL solutions be performed

Solution: S00000603

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00005265

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 122, 123, 124, 125, 2973
  • Aftertreatment DPF: 3133, 3134, 3135, 3312, 3319, 3321, 3322, 3255, 3256, 3753, 5275, 5276, 5383
  • Aftertreatment regeneration: 2777, 3375, 3376, 4213
  • Aftertreatment DOC: 1691, 3254, 3311, 3251, 3253, 3313, 3314, 3315, 3316, 3317, 3318
  • Wheel based vehicle speed: 241
  • Exhaust gas temperature: 4151, 4152
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment DPF is malfunctioning

Solution: S00006393

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then disregard this solution.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1942 | SPN: 101 | FMI: 2
Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Visual inspection of crankcase breather components
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase breather restriction check
  5. Crankcase pressure sensor or breather element check
  6. ECM calibration revision history check
  7. Crankcase pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000171

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Visual inspection of crankcase breather components

Solution: S00001004

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil fill cap for proper installation.
  • Inspect the crankcase breather hose between the engine and the crankcase breather assembly for proper installation.
  • Visually inspect the crankcase breather hose for damage.

Specification

  • If the crankcase breather hose is incorrectly installed or damaged, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • For an incorrectly installed crankcase breather hose, reinstall the crankcase breather hose correctly.
  • For a damaged crankcase breather hose, replace the crankcase breather hose.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase breather restriction check

Solution: S00000635

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure with keyswitch ON and engine OFF.
  • Run engine at high idle.
  • Monitor the crankcase pressure at high idle.
  • Subtract the (key ON engine OFF) measured value from the (Engine running at high idle) measured value.

Specification

  • If the measured value for engine running at high idle minus the measured value for key ON engine OFF is less than <0.7 in H₂O, then proceed to the next solution.
  • If the measured value for engine running at high idle minus the measured value for key ON engine OFF is greater than >0.7 in H₂O, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor or breather element check

Refer to S00000636

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Crankcase pressure sensor or breather element check

Solution: S00000636

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check that the crankcase breather element is correctly installed.
  • Check that the crankcase breather inlet hose for restriction or other damage.

Specification

  • If the crankcase breather element is correctly installed and the crankcase breather inlet hose (if equipped) is free of restriction or damage, then proceed to the next solution.
  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • For an incorrectly installed crankcase breather element, reinstall the crankcase breather element correctly.

Refer to Procedure 003-019

Refer to Procedure 003-001

  • For a damaged crankcase breather hose, replace the crankcase breather hose.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankcase pressure sensor is malfunctioning

Solution: S00006414

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 1974 | SPN: 101 | FMI: 15
Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Lubricating oil level is incorrect
  2. Plugged external crankcase breather tube
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase Blowby Check
  5. Plugged external crankcase breather tube
  6. Turbocharger leaking air into crankcase
  7. Air compressor leaking air into crankcase
  8. Worn or damaged power cylinder components
  9. ECM calibration revision history check

1 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase Blowby Check

Solution: S00005142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00006462

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Worn or damaged power cylinder components

Solution: S00006462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the cylinder block bore.

Refer to Procedure 001-026

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2182 | SPN: 1072 | FMI: 3
Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00004768

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2183 | SPN: 1072 | FMI: 4
Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00004768

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2185 | SPN: 3512 | FMI: 3
Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Sensor supply 4 circuit pin to pin short
  2. Sensor supply 4 voltage error due to ECM

1 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2186 | SPN: 3512 | FMI: 4
Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Accelerator pedal or lever position sensor circuit pin to ground short
  2. Sensor supply 4 circuit pin to pin short
  3. Sensor supply 4 voltage error due to ECM

1 - Accelerator pedal or lever position sensor circuit pin to ground short

Solution: S00000731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal or lever position sensor +5 volt SUPPLY pin in the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2321 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine crankshaft speed/position sensor check
  3. Crankshaft position sensor open circuit check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000185

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2322 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2373 | SPN: 1209 | FMI: 3
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. Exhaust gas pressure sensor circuit response at the ECM
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000399

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2374

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001228

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2374
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2374

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2374 | SPN: 1209 | FMI: 4
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Exhaust gas pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000400

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001126

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2373
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2377 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid circuit pin to pin short

1 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2398 | SPN: 171 | FMI: 2
Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. OEM ambient air temperature sensor stuck in-range
  4. Ambient air temperature sensor open circuit check
  5. Ambient air temperature sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000195

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2412 | SPN: 1639 | FMI: 2
Fan Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Fan speed sensor open circuit check
  2. Fan speed sensor circuit pin to ground short
  3. Fan speed sensor resistance check
  4. Fan speed sensor circuit pin to pin short
  5. Malfunctioning cooling fan drive or cooling fan controls

1 - Fan speed sensor open circuit check

Solution: S00003668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the fan speed sensor OEM wiring harness connector and the fan speed sensor SIGNAL pin OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan speed sensor circuit pin to ground short

Solution: S00003665

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan speed sensor resistance check

Solution: S00003667

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan speed sensor.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan speed sensor circuit pin to pin short

Solution: S00003666

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan speed sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00001907

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run engine at high idle.
  • Wait for 30 seconds.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning fan speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the fan speed sensor.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2482 | SPN: 1675 | FMI: 31
Engine Starter Mode Before Ready Status - Condition Exists

Troubleshooting Summary

  1. Engine will not start

1 - Engine will not start

Solution: S00002969

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine will not start, then reset the search to crank no start.
  • If the engine is difficult to start, then reset the search to hard start / long crank time.

Linked Solutions

  • None

Repair

Only search the appropriate symptom.

  • Reset the search to crank no start.
  • Reset the search to hard start / long crank time.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2554 | SPN: 1209 | FMI: 2
Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Exhaust gas pressure sensor voltage check
  6. Exhaust gas pressure sensor voltage check at the ECM
  7. Plugged or damaged exhaust gas pressure sensor tube
  8. Exhaust gas pressure sensor open circuit check
  9. Engine exhaust back pressure regulator soot deposit check
  10. ECM calibration revision history check
  11. Exhaust gas pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000199

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine exhaust back pressure regulator soot deposit check

Solution: S00002612

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine exhaust back pressure regulator for excessive soot deposits.

Specification

  • If excessive soot deposits are found in the engine exhaust back pressure regulator, then a sticking engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Clean the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Exhaust gas pressure sensor is malfunctioning

Solution: S00003039

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning exhaust gas pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2639 | SPN: 3251 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. Aftertreatment DPF partially obstructed or plugged
  6. Snap acceleration check for excessive black smoke
  7. ECM calibration revision history check
  8. Stationary aftertreatment regeneration is needed

1 - Check for primary fault codes

Solution: S00007369

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 122, 123, 124, 125, 2973
  • Aftertreatment DPF: 3133, 3134, 3135, 3312, 3319, 3321, 3322, 3255, 3256, 3753, 5275, 5276, 5383, 5715
  • Aftertreatment regeneration: 2777, 3375, 3376, 4213
  • Aftertreatment DOC: 1691, 3254, 3311, 3251, 3253, 3313, 3314, 3315, 3316, 3317, 3318
  • Wheel based vehicle speed: 241
  • Exhaust gas temperature: 4151, 4152
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF partially obstructed or plugged

Solution: S00006391

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2764 | SPN: 1209 | FMI: 16
Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. High exhaust restriction
  7. Exhaust gas pressure sensor open circuit check
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006453

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374, 2554
  • Turbocharger: 691, 692, 693, 741, 742, 743
  • Intake manifold: 122, 123, 124, 125, 2973

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - High exhaust restriction

Solution: S00002897

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 011-009

  • Turn keyswitch ON.
  • Start the engine.
  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Refer to Procedure 018-020

Linked Solutions

  • None

Repair

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2771 | SPN: 3226 | FMI: 9
Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fault Code triggered by a malfunction in the J1939 data link
  3. Power distribution center and fuse check
  4. Low battery voltage
  5. Battery load test
  6. Ground inspection
  7. Aftertreatment power relay is malfunctioning
  8. Aftertreatment outlet NOx sensor voltage check
  9. Aftertreatment power relay voltage check
  10. Aftertreatment power relay resistance check
  11. Aftertreatment outlet NOx sensor circuit check
  12. Aftertreatment power relay circuit check
  13. Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  14. J1939 data link engine wiring harness voltage check 3 pin service connector
  15. J1939 data link component isolation
  16. J1939 data link harness pin to ground short circuit
  17. J1939 data link terminating resistance is incorrect
  18. Incorrect terminating resistor in the J1939 data link
  19. Engine wiring harness has incorrect J1939 terminating resistance
  20. OEM wiring harness has incorrect J1939 terminating resistance
  21. J1939 data link harness open circuit check
  22. OEM terminating resistor Ω check for the J1939 data link
  23. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  24. J1939 wire resistance check at the crossover connector for each component
  25. ECM calibration revision history check
  26. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006456

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4572, 4677
  • Aftertreatment DPF: 4151
  • Aftertreatment SCR: 4152

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fault Code triggered by a malfunction in the J1939 data link

Solution: S00006339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 3232, 3868, 4151, 4152, 4572, 4677

Linked Solutions

Click on the link below:

  • Power distribution center and fuse check

Refer to S00002836

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Power distribution center and fuse check

Solution: S00002836

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuse.

Refer to Procedure 019-198

  • Visually inspect the power distribution center for damage, corrosion or loose connections.

Specification

  • If the fuse is found to be blown or damaged, then proceed to Repair section.
  • If the power distribution center is damaged, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Replace the power distribution junction box.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00006226

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 3232, 3868, 4151, 4152, 4572, 4677
  • A malfunctioning aftertreatment outlet NOx sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 3232, 3868, 4151, 4152, 4572, 4677

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

9 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

11.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

13 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2777 | SPN: 3703 | FMI: 31
Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Troubleshooting Summary

  1. Aftertreatment DPF Permit Switch Status is in the OFF position
  2. ECM calibration revision history check

1 - Aftertreatment DPF Permit Switch Status is in the OFF position

Solution: S00001026

Verification

Conditions

  • None

Action

  • Visually verify the Aftertreatment DPF Permit Switch is in the ON position.

Specification

  • If the Aftertreatment DPF Permit Switch is in the ON position, then proceed to the next solution.
  • If the Aftertreatment DPF Permit Switch is not in the ON position, then proceed to the Repair section.
  • If there is not an Aftertreatment DPF Permit Switch on the dash, then an incorrect parameter setting has been determined. Proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Turn the Aftertreatment DPF Permit Switch Status to the ON position.
  • Adjust the features and parameters to the correct settings.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Perform the aftertreatment stationary regeneration.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2963 | SPN: 110 | FMI: 15
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Water pump is malfunctioning
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00010538

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-020

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Water pump is malfunctioning

Solution: S00004446

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the water pump.

Refer to Procedure 008-062

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the water pump.

Refer to Procedure 008-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Combustion gases entering the cooling system

Solution: S00001960

Verification

Conditions

  • None

Action

  • Check for air or combustion gases in the cooling system.
  • Perform the combustion gas leak test.

Refer to Procedure 008-020

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2964 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Fan clutch operates incorrectly
  3. Intake manifold temperature sensor stuck in-range
  4. Malfunctioning cooling fan drive or cooling fan controls
  5. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 2973 | SPN: 102 | FMI: 2
Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Exhaust gas pressure sensor stuck in-range
  4. Plugged or damaged exhaust gas pressure sensor tube
  5. Exhaust gas pressure sensor stuck in-range
  6. Intake manifold pressure sensor has carbon buildup
  7. Intake manifold pressure sensor stuck in-range
  8. Intake manifold pressure sensor has carbon buildup
  9. Turbocharger compressor intake pressure/temperature sensor is malfunctioning
  10. Leaks in the intake air system
  11. Turbocharger is malfunctioning
  12. ECM calibration revision history check
  13. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 295
  • Turbocharger: 691, 692, 693

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold pressure sensor has carbon buildup

Solution: S00001046

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.

Refer to Procedure 019-159

Specification

  • If the intake manifold pressure/temperature sensor tip is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

7 - Turbocharger compressor intake pressure/temperature sensor is malfunctioning

Solution: S00003201

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure.
  • Compare to the local ambient air pressure.

Specification

  • If the sensor reading is not within specification, then a malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Leaks in the intake air system

Solution: S00005731

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the air intake component causing the air leak.

Refer to OEM Service Manual

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Turbocharger is malfunctioning

Solution: S00000780

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination.

Refer to Procedure 010-033

  • Inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3133 | SPN: 3610 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF outlet pressure sensor voltage check
  5. Aftertreatment DPF outlet pressure sensor circuit check
  6. Aftertreatment DPF outlet pressure sensor circuit response
  7. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF outlet pressure sensor circuit response

Solution: S00000349

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF outlet pressure sensor has been detected if the following fault code became active with the sensor disconnected: 3134

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00005446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3134 | SPN: 3610 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF outlet pressure sensor voltage check
  5. Aftertreatment DPF outlet pressure sensor circuit check
  6. Aftertreatment DPF outlet pressure sensor circuit response
  7. Aftertreatment DPF outlet pressure sensor open circuit check
  8. Aftertreatment DPF outlet pressure circuit pin to ground short
  9. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

1 - Check for primary fault codes

Solution: S00000231

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF outlet pressure sensor circuit response

Solution: S00000347

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment DPF outlet pressure sensor SUPPLY pin and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF outlet pressure sensor has been detected if the following fault code became active with the jumper wire in place: 3133

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00005441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00005446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3135 | SPN: 3610 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment DPF differential pressure sensor vent plugged or damaged
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF outlet pressure sensor voltage check
  6. Aftertreatment DPF outlet pressure sensor circuit check
  7. Aftertreatment DPF differential pressure sensor tubes plugged
  8. Aftertreatment DPF differential pressure sensor stuck in-range
  9. Aftertreatment DPF outlet pressure sensor open circuit check
  10. Deposits in the SCR decomposition tube
  11. Leaks in the aftertreatment diesel exhaust fluid dosing system
  12. Aftertreatment DPF outlet pressure circuit pin to ground short
  13. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin
  14. High exhaust restriction
  15. ECM calibration revision history check
  16. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Aftertreatment DPF differential pressure sensor vent plugged or damaged

Solution: S00005439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment DPF differential pressure sensor from the sensor mounting bracket.
  • Inspect the aftertreatment DPF differential pressure sensor vent for signs of plugging or damage.

Refer to Procedure 019-443

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00005441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00005446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - High exhaust restriction

Solution: S00002649

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Refer to Procedure 018-020

Linked Solutions

  • None

Repair

  • Repair the source of the exhaust restriction.

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

13 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3142 | SPN: 4360 | FMI: 3
Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000236

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3143 | SPN: 4360 | FMI: 4
Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00002286

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3144 | SPN: 4360 | FMI: 2
Aftertreatment 1 SCR Intake Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR intake temperature sensor stuck in-range
  3. Aftertreatment exhaust gas temperature sensor tampering
  4. Aftertreatment exhaust system leaks
  5. ECM calibration revision history check
  6. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00001478

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3142, 3143, 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR intake temperature sensor stuck in-range

Solution: S00003260

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run the engine at idle.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment SCR outlet temperature sensor.
  • Monitor the aftertreatment SCR intake temperature sensor.

Specification

  • A malfunctioning aftertreatment SCR intake temperature sensor has been detected if the aftertreatment SCR intake temperature sensor reading is not within the following specification of the aftertreatment SCR outlet temperature sensor: 23 C [45 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intake temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00005527

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00005484

Verification

Conditions

  • Engine running.

Action

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.
  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3146 | SPN: 4363 | FMI: 3
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000237

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3147 | SPN: 4363 | FMI: 4
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000238

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3148 | SPN: 4363 | FMI: 2
Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor tampering
  3. ECM calibration revision history check
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000239

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00005527

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3151 | SPN: 4794 | FMI: 31
Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Troubleshooting Summary

  1. Fault Code 3151 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment exhaust system leaks
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Diesel fuel used is incorrect
  9. Aftertreatment SCR System Test
  10. Aftertreatment diesel exhaust fluid dosing system test failed
  11. Aftertreatment intake NOx sensor failed
  12. Aftertreatment outlet NOx sensor - Inspection
  13. Inspect both aftertreatment NOx sensors
  14. Aftertreatment SCR Catalyst Test Failed
  15. ECM calibration revision history check

1 - Fault Code 3151 requires that ALL solutions be performed

Solution: S00001372

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00005193

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 3749, 4747, 4748, 4749, 4751, 5689
  • Aftertreatment SCR: 3142, 3143, 3144, 3146, 3147, 3148, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4165, 4166, 4261, 5655
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 1685, 1686, 1715, 3497, 3498, 3567, 3568, 3571, 3572, 3574, 3575, 3596, 4677, 4739, 5864, 5865, 5935, 5936
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Fuel: 8363, 8523

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000562

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.
  • Reconnect the aftertreatment diesel exhaust fluid dosing valve to the decomposition tube if it has been previously disconnected during troubleshooting.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair the source of the external diesel exhaust fluid leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Diesel fuel used is incorrect

Solution: S00005465

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • If this vehicle has been repaired within the last 30 days for the same fault code, then the use of the incorrect fuel is suspected.
  • Verify the correct diesel fuel is being used.

Refer to Procedure 375-001

Specification

  • If the diesel fuel being used is not correct for the engine configuration, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Drain and fill with the correct diesel fuel for the engine configuration.
  • Replace the suction side fuel filter.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3165 | SPN: 4363 | FMI: 0
Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000240

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3168 | SPN: 3936 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. ECM calibration revision history check
  6. Aftertreatment DPF damaged or missing

1 - Check for primary fault codes

Solution: S00006572

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883, 5715
  • Intake manifold: 124, 125, 2973
  • Turbocharger: 743
  • Aftertreatment DPF: 3135

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF damaged or missing

Solution: S00006392

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

Refer to Procedure 011-041

  • Inspect the aftertreatment DPF for cracks or other damage.

Refer to Service Bulletin 4021600

Specification

  • If the aftertreatment DPF does not meet inspection criteria, then a plugged or damaged aftertreatment DPF has been detected.

Refer to Procedure 011-041

Refer to Service Bulletin 4021600

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

  • Perform the Aftertreatment maintenance filter installation procedure.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3229 | SPN: 4360 | FMI: 0
Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001536

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3231 | SPN: 4360 | FMI: 16
Aftertreatment 1 SCR Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. Turbocharger exhaust is leaking oil into the aftertreatment system
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3232 | SPN: 3216 | FMI: 9
Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Low battery voltage
  2. Battery load test
  3. Ground inspection
  4. Aftertreatment power relay is malfunctioning
  5. Aftertreatment intake NOx sensor voltage check
  6. Aftertreatment power relay open circuit check
  7. Aftertreatment intake NOx sensor open circuit check
  8. Fault Code 3232 triggered by a malfunction in the J1939 data link with multiple OEM fault codes
  9. J1939 data link engine wiring harness voltage check 3 pin service connector
  10. J1939 data link component isolation
  11. J1939 data link harness pin to ground short circuit
  12. J1939 data link terminating resistance is incorrect
  13. Incorrect terminating resistor in the J1939 data link
  14. Engine wiring harness has incorrect J1939 terminating resistance
  15. OEM wiring harness has incorrect J1939 terminating resistance
  16. J1939 data link harness open circuit check
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check
  21. Aftertreatment intake NOx sensor is malfunctioning

1 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor voltage check

Solution: S00005389

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin and the aftertreatment intake NOx sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment intake NOx sensor open circuit check

Refer to S00005390

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Aftertreatment intake NOx sensor open circuit check

Solution: S00005390

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the aftertreatment interface wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 3232 triggered by a malfunction in the J1939 data link with multiple OEM fault codes

Solution: S00005387

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771,3868, 4151, 4152, 4572, 4677, 7663
  • A malfunctioning aftertreatment intake NOx sensor has been detected, if any fault code is not active or does not have more than one inactive count within the last 25 engine hours from the following list: 2771,3868, 4151, 4152, 4572, 4677, 7663

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3235 | SPN: 4363 | FMI: 16
Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3243 | SPN: 3060 | FMI: 18
Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant temperature sensor resistance check
  3. Fan clutch operates incorrectly
  4. Thermostat is malfunctioning
  5. Out-of-chassis opening temperature test
  6. ECM calibration revision history check
  7. Coolant temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000261

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145, 334

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor is malfunctioning

Solution: S00001238

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3251 | SPN: 4765 | FMI: 16
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Leaks in the intake air system
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00005731

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the air intake component causing the air leak.

Refer to OEM Service Manual

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3253 | SPN: 3242 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Overhead component damaged or out of adjustment
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3254 | SPN: 3242 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Overhead component damaged or out of adjustment
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3255 | SPN: 3246 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3256 | SPN: 3246 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000267

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid dosing unit: 1932
  • Aftertreatment DPF: 4151, 4158, 4162, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3311 | SPN: 3242 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3312 | SPN: 3246 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3313 | SPN: 4765 | FMI: 4
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3314 | SPN: 4765 | FMI: 3
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3315 | SPN: 4765 | FMI: 2
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor tampering
  3. Aftertreatment temperature sensor stuck in-range
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00005527

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3316 | SPN: 3242 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3317 | SPN: 3242 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3318 | SPN: 3242 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor tampering
  3. Aftertreatment temperature sensor stuck in-range
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00005527

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3319 | SPN: 3246 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3321 | SPN: 3246 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3322 | SPN: 3246 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor tampering
  3. Aftertreatment temperature sensor stuck in-range
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00005527

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3332 | SPN: 1347 | FMI: 2
Engine Fuel Pump Pressurizing Assembly 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel pump actuator resistance check
  3. Fuel pump actuator open circuit check
  4. Fuel pump actuator circuit pin to ground short
  5. Fuel pump actuator circuit pin to pin short
  6. ECM calibration revision history check
  7. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000791

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator open circuit check

Solution: S00000771

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump actuator RETURN pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator circuit pin to pin short

Solution: S00005784

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel actuator SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the fuel actuator RETURN pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel pump actuator is malfunctioning

Solution: S00002783

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3343 | SPN: 5285 | FMI: 18
Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. High intake manifold temperature basic checks
  3. Fan clutch operates incorrectly
  4. Intake manifold temperature sensor stuck in-range
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154, 436

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3375 | SPN: 5397 | FMI: 31
Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

Troubleshooting Summary

  1. Fault Code 3375 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Charge air cooler or exhaust system leak
  7. Aftertreatment temperature sensor stuck in-range
  8. Aftertreatment DPF partially obstructed or plugged
  9. Snap acceleration check for excessive black smoke
  10. Overhead component damaged or out of adjustment
  11. Aftertreatment DOC is malfunctioning
  12. ECM calibration revision history check

1 - Fault Code 3375 requires that ALL solutions be performed

Solution: S00000792

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00006501

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135, 3316, 3317, 3319, 3321, 3322, 5383, 5715, 5716
  • Aftertreatment DOC: 1691, 3313, 3314
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 125, 2973
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277
  • Exhaust gas pressure: 2373, 2374, 2554, 7864

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler or exhaust system leak

Solution: S00005087

Verification

Conditions

  • Engine running.

Action

  • Run engine at high idle.
  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-027

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment DPF partially obstructed or plugged

Solution: S00006391

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3376 | SPN: 5319 | FMI: 31
Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Troubleshooting Summary

  1. Fault Code 3376 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment temperature sensor stuck in-range
  7. Aftertreatment DPF partially obstructed or plugged
  8. Snap acceleration check for excessive black smoke
  9. Overhead component damaged or out of adjustment
  10. Aftertreatment DOC is malfunctioning
  11. ECM calibration revision history check

1 - Fault Code 3376 requires that ALL solutions be performed

Solution: S00003165

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00006501

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135, 3316, 3317, 3319, 3321, 3322, 5383, 5715, 5716
  • Aftertreatment DOC: 1691, 3313, 3314
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 125, 2973
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277
  • Exhaust gas pressure: 2373, 2374, 2554, 7864

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF partially obstructed or plugged

Solution: S00006391

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment DOC is malfunctioning

Solution: S00000761

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.
  • If the face of the aftertreatment diesel oxidation catalyst is cracked or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3492 | SPN: 251 | FMI: 10
Real Time Clock - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM Malfunction
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000300

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM Malfunction

Solution: S00002899

Verification

Conditions

  • Engine not running.

Action

  • Keyswitch OFF 1 minute.
  • Keyswitch ON 15 minutes.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3498 | SPN: 1761 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00008041

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3539 | SPN: 51 | FMI: 3
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00000394

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine intake throttle actuator connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00000395

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM connector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 3541
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3541 | SPN: 51 | FMI: 4
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00001369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the actuator disconnected: 3539

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00001368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 3539
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 3539

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3542 | SPN: 51 | FMI: 2
Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted engine intake throttle
  3. Engine intake throttle actuator voltage check
  4. Engine intake throttle actuator voltage check at the ECM
  5. Engine intake throttle actuator open circuit check
  6. Engine intake throttle actuator motor resistance check
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000303

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Intake throttle: 3539, 3541

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Engine intake throttle actuator open circuit check

Solution: S00004944

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine intake throttle actuator motor resistance check

Solution: S00005297

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator motor connector.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is greater than the following specification: 15 Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3545 | SPN: 3226 | FMI: 10
Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000305

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00005603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3547 | SPN: 4096 | FMI: 31
Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00008041

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3558 | SPN: 3361 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit short circuit to battery
  3. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  4. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00006440

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 5865, 5867

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit short circuit to battery

Solution: S00000831

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector and battery positive (+).
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and battery positive (+).
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00005585

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00005583

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3559 | SPN: 3361 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short
  3. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00006440

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 5865, 5867

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short

Solution: S00004359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor SUPPLY pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00005585

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00005583

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3567 | SPN: 5394 | FMI: 5
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing valve resistance check
  2. Aftertreatment diesel exhaust fluid dosing valve open circuit check
  3. Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short
  4. Aftertreatment diesel exhaust fluid dosing valve circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing valve resistance check

Solution: S00005518

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing valve open circuit check

Solution: S00005519

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid dosing valve RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short

Solution: S00005520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to pin short

Solution: S00005521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3568 | SPN: 5394 | FMI: 7
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  4. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  5. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3565, 3566, 3567, 3575
  • Aftertreatment differential pressure: 3571, 3572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00005933

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00000967

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00005938

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3571 | SPN: 4334 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing valve voltage check
  3. Aftertreatment diesel exhaust fluid dosing valve open circuit check
  4. Aftertreatment diesel exhaust fluid dosing valve pressure sensor circuit response
  5. Aftertreatment diesel exhaust fluid pressure sensor OEM wiring harness pin to pin short

1 - Check for primary fault codes

Solution: S00000854

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing valve voltage check

Solution: S00005511

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin to the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve open circuit check

Refer to S00005513

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing valve open circuit check

Solution: S00005513

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor circuit response

Solution: S00005512

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the following fault code became active with the aftertreatment diesel exhaust fluid dosing valve disconnected: 3572

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid pressure sensor OEM wiring harness pin to pin short

Solution: S00005514

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3572 | SPN: 4334 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing valve voltage check
  3. Aftertreatment diesel exhaust fluid dosing valve open circuit check
  4. Aftertreatment diesel exhaust fluid dosing valve pressure sensor circuit response
  5. Aftertreatment diesel exhaust fluid dosing valve open circuit check
  6. Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short
  7. Aftertreatment diesel exhaust fluid pressure sensor OEM wiring harness pin to pin short

1 - Check for primary fault codes

Solution: S00000855

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing valve voltage check

Solution: S00005511

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin to the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve open circuit check

Refer to S00005513

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing valve open circuit check

Solution: S00005513

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor circuit response

Solution: S00005515

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin and aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the following fault code became active with the jumper wire in place: 3571

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve open circuit check

Solution: S00005516

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short

Solution: S00005517

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid pressure sensor OEM wiring harness pin to pin short

Solution: S00005514

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3574 | SPN: 4334 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  4. Aftertreatment diesel exhaust fluid tank level sensor tampering
  5. Aftertreatment diesel exhaust fluid is contaminated
  6. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  7. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  8. Aftertreatment diesel exhaust fluid dosing unit suction test
  9. Aftertreatment diesel exhaust fluid dosing unit return circuit check
  10. Aftertreatment diesel exhaust fluid dosing system cleaning
  11. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  12. Aftertreatment diesel exhaust fluid pressure line restricted
  13. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  14. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  15. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  16. ECM calibration revision history check
  17. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00005203

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • The aftertreatment diesel exhaust fluid tank is low if one of the following fault codes are active: 1673, 3497, 3498

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00006111

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1671, 1673, 3498, 3547, 3571, 3572, 5278, 5935
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor tampering

Solution: S00006695

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank level sensor is properly mounted.
  • Verify that no external device is connected in place of the aftertreatment diesel exhaust fluid tank level sensor.
  • Visually inspect the aftertreatment diesel exhaust fluid tank level sensor for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

  • Repair or remove the tampering device or any external device.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00006324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not operate during the test, then proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing unit return circuit check.
  • Proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing system cleaning if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Proceed to the next solution if the vacuum in diagnostic line is greater than the following: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit return circuit check

Refer to S00000858

  • Aftertreatment diesel exhaust fluid dosing system cleaning

Refer to S00002910

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing unit return circuit check

Solution: S00000858

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid dosing unit motor runs.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment diesel exhaust fluid dosing system cleaning

Solution: S00002910

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Refer to Procedure 011-056

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid pressure line restricted

Solution: S00003284

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the outlet of the aftertreatment diesel exhaust fluid dosing unit and the pressure line.

Refer to Procedure 011-144

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then a restricted aftertreatment diesel exhaust fluid pressure line has been detected.
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure is less than specification.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00003230

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid pressure line.

Refer to OEM Service Manual

Validation

  • None
Next Solution

9.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003230

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit outlet fitting for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit filter for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing valve inlet fitting screen for signs of blockage or buildup.

Specification

  • If there are no signs of blockage or buildup, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.
  • If there are signs of blockage or buildup, then a restricted aftertreatment diesel exhaust fluid dosing unit outlet fitting or aftertreatment diesel exhaust fluid dosing valve inlet fitting has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing unit filter regardless of condition.

Refer to Procedure 011-060

  • Clean the aftertreatment diesel exhaust fluid dosing unit outlet fitting.
  • Clean the aftertreatment diesel exhaust fluid dosing valve inlet fitting.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00008063

Verification

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit to the OEM wiring harness.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Specification

  • If the fault code is still active after the Aftertreatment Diesel Exhaust Fluid System Leak Test is completed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3575 | SPN: 4334 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  4. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  5. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  6. Aftertreatment diesel exhaust fluid dosing valve pressure check
  7. Aftertreatment diesel exhaust fluid dosing valve return restriction check
  8. ECM calibration revision history check
  9. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00000861

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 3596, 5278, 5864, 5865

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00000967

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00006324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid dosing valve pressure check

Solution: S00000862

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the inlet of the aftertreatment diesel exhaust fluid dosing valve and the pressure line.

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then proceed to the Linked Solutions section.
  • If the aftertreatment diesel exhaust fluid pressure is less than or within specification, then proceed to the next solution.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve return restriction check

Refer to S00000873

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing valve return restriction check

Solution: S00000873

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Install the diesel exhaust fluid pressure gauge at the diesel exhaust fluid dosing valve outlet.

Refer to Procedure 011-144

This is the return line between the dosing valve and the tank.

  • Reconnect the diesel exhaust fluid pressure line to the inlet of the dosing valve.

Refer to Procedure 011-144

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

  • Read the diesel exhaust fluid pressure from the service tool gauge.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the aftertreatment diesel exhaust fluid pressure is less than the following: 70 kPa [10 psi]
  • A blocked or restricted return line or tank head has been detected if the aftertreatment diesel exhaust fluid pressure is greater than the following: 70 kPa [10 psi]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the return line as necessary.

Refer to OEM Service Manual

  • Clean or replace the tank head as necessary.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00008063

Verification

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit to the OEM wiring harness.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Specification

  • If the fault code is still active after the Aftertreatment Diesel Exhaust Fluid System Leak Test is completed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3583 | SPN: 5031 | FMI: 10
Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment power relay is malfunctioning
  6. Aftertreatment outlet NOx sensor voltage check
  7. Aftertreatment power relay voltage check
  8. Aftertreatment power relay resistance check
  9. Aftertreatment outlet NOx sensor circuit check
  10. Aftertreatment power relay circuit check
  11. Aftertreatment outlet NOx sensor open circuit
  12. ECM calibration revision history check
  13. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000309

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3681
  • Aftertreatment SCR: 3144, 3146, 3147, 3148

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000872

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00005603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3596 | SPN: 4334 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  5. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  6. Aftertreatment diesel exhaust fluid dosing valve pressure check
  7. Aftertreatment diesel exhaust fluid dosing valve return restriction check
  8. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  9. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  10. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000310

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 5278, 5864, 5865, 5935, 5936

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00006324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid dosing valve pressure check

Solution: S00000862

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the inlet of the aftertreatment diesel exhaust fluid dosing valve and the pressure line.

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then proceed to the Linked Solutions section.
  • If the aftertreatment diesel exhaust fluid pressure is less than or within specification, then proceed to the next solution.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve return restriction check

Refer to S00000873

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing valve return restriction check

Solution: S00000873

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Install the diesel exhaust fluid pressure gauge at the diesel exhaust fluid dosing valve outlet.

Refer to Procedure 011-144

This is the return line between the dosing valve and the tank.

  • Reconnect the diesel exhaust fluid pressure line to the inlet of the dosing valve.

Refer to Procedure 011-144

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

  • Read the diesel exhaust fluid pressure from the service tool gauge.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the aftertreatment diesel exhaust fluid pressure is less than the following: 70 kPa [10 psi]
  • A blocked or restricted return line or tank head has been detected if the aftertreatment diesel exhaust fluid pressure is greater than the following: 70 kPa [10 psi]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the return line as necessary.

Refer to OEM Service Manual

  • Clean or replace the tank head as necessary.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3649 | SPN: 5024 | FMI: 10
Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment power relay is malfunctioning
  6. Aftertreatment intake NOx sensor voltage check
  7. Aftertreatment power relay open circuit check
  8. Aftertreatment intake NOx sensor open circuit check
  9. ECM calibration revision history check
  10. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000293

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3682
  • Aftertreatment DOC: 3313, 3314, 3315

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment intake NOx sensor voltage check

Solution: S00005389

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin and the aftertreatment intake NOx sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment intake NOx sensor open circuit check

Refer to S00005390

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment intake NOx sensor open circuit check

Solution: S00005390

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the aftertreatment interface wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3681 | SPN: 3228 | FMI: 2
Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment power relay is malfunctioning
  6. Incorrect adjustable parameter setting
  7. Aftertreatment outlet NOx sensor voltage check
  8. Aftertreatment power relay voltage check
  9. Aftertreatment power relay resistance check
  10. Aftertreatment outlet NOx sensor circuit check
  11. Aftertreatment power relay circuit check
  12. Aftertreatment outlet NOx sensor has carbon buildup
  13. ECM calibration revision history check
  14. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000292

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00005603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3682 | SPN: 3218 | FMI: 2
Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment power relay is malfunctioning
  6. Incorrect aftertreatment intake NOx sensor installed
  7. Incorrect adjustable parameter setting
  8. Aftertreatment intake NOx sensor voltage check
  9. Aftertreatment power relay open circuit check
  10. Aftertreatment intake NOx sensor open circuit check
  11. ECM calibration revision history check
  12. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000290

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Incorrect aftertreatment intake NOx sensor installed

Solution: S00000885

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Verify the aftertreatment intake NOx sensor is correct for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Specification

  • If the aftertreatment intake NOx sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment intake NOx sensor voltage check

Solution: S00005389

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin and the aftertreatment intake NOx sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment intake NOx sensor open circuit check

Refer to S00005390

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Aftertreatment intake NOx sensor open circuit check

Solution: S00005390

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the aftertreatment interface wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment intake NOx sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3697 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000289

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Internal ECM Error

Solution: S00008078

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 90 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if a fault code from the following list is active or has greater than 3 inactive counts: 111, 335, 342, 343, 1597, 3697, 3724, 5874, 6155, 7155

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3712 | SPN: 5246 | FMI: 0
Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00006104

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Intake manifold temperature: 153, 154, 436
  • Barometric pressure: 295
  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Sensor supply 5: 1695, 1696
  • Turbocharger: 691, 6892, 693, 741, 742, 743
  • Aftertreatment diesel exhaust fluid system: 1682, 1714, 3574, 3575, 3596, 3878, 4234, 4243, 4732, 4745, 5278, 5935, 5936, 6486, 6765, 6766, 6767
  • Exhaust gas pressure: 2373, 22374, 2554
  • Aftertreatment NOx: 5689
  • Aftertreatment SCR: 6266

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 30-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3714 | SPN: 1569 | FMI: 31
Engine Protection Torque Derate - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006104

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Intake manifold temperature: 153, 154, 436
  • Barometric pressure: 295
  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Sensor supply 5: 1695, 1696
  • Turbocharger: 691, 6892, 693, 741, 742, 743
  • Aftertreatment diesel exhaust fluid system: 1682, 1714, 3574, 3575, 3596, 3878, 4234, 4243, 4732, 4745, 5278, 5935, 5936, 6486, 6765, 6766, 6767
  • Exhaust gas pressure: 2373, 22374, 2554
  • Aftertreatment NOx: 5689
  • Aftertreatment SCR: 6266

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3717 | SPN: 3226 | FMI: 13
Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Aftertreatment outlet NOx sensor - Inspection
  3. ECM calibration revision history check
  4. Aftertreatment outlet NOx sensor is malfunctioning

1 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00002877

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the aftertreatment outlet NOx sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.
  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00005603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3718 | SPN: 3216 | FMI: 13
Aftertreatment 1 Intake NOx - Out of Calibration

Troubleshooting Summary

  1. Incorrect aftertreatment intake NOx sensor installed
  2. Incorrect adjustable parameter setting
  3. ECM calibration revision history check
  4. Aftertreatment intake NOx sensor is malfunctioning

1 - Incorrect aftertreatment intake NOx sensor installed

Solution: S00000885

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Verify the aftertreatment intake NOx sensor is correct for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Specification

  • If the aftertreatment intake NOx sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3725 | SPN: 3216 | FMI: 10
Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005427

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3649, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3727 | SPN: 5571 | FMI: 7
High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Fuel pressure relief valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000889

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 451, 452

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pressure relief valve is malfunctioning

Solution: S00008682

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all preceding solution verifications have been preformed, then a malfunctioning fuel pressure relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3737 | SPN: 1675 | FMI: 31
Engine Starter Mode Overcrank Protection - Condition Exists

Troubleshooting Summary

  1. Engine will not start
  2. ECM calibration revision history check

1 - Engine will not start

Solution: S00002969

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine will not start, then reset the search to crank no start.
  • If the engine is difficult to start, then reset the search to hard start / long crank time.

Linked Solutions

  • None

Repair

Only search the appropriate symptom.

  • Reset the search to crank no start.
  • Reset the search to hard start / long crank time.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3741 | SPN: 5571 | FMI: 0
High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator o-ring is malfunctioning
  6. Fuel filter restriction
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000254

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Fuel: 271, 272, 449, 451, 452, 483, 484, 553, 2311, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator o-ring is malfunctioning

Solution: S00000620

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

  • Visually inspect fuel pump actuator for a cut or damaged o-ring.
  • Visually inspect the wiring or body of the actuator for damage.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the o-ring.

Refer to Procedure 019-117

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel filter restriction

Solution: S00006720

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the outlet pressure of the filter is within specification, then proceed to the next solution.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.
  • If the pressure is not within specification at the fuel pressure filter inlet then a malfunction of the fuel pump gear pump has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace high pressure fuel pump.

Refer to Procedure 005-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3748 | SPN: 3216 | FMI: 20
Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000253

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3649, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3753 | SPN: 3713 | FMI: 31
Diesel Particulate Filter Active Regeneration Inhibited Due to System Timeout - Condition Exists

Troubleshooting Summary

  1. Aftertreatment DPF active regeneration inhibited due to timeout
  2. ECM calibration revision history check

1 - Aftertreatment DPF active regeneration inhibited due to timeout

Solution: S00003429

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If other fault codes that inhibit the aftertreatment stationary regeneration are active or inactive with more than one count within the last 25 engine operating hours, then troubleshoot those fault codes before performing the aftertreatment stationary regeneration procedure.
  • If there are no other fault codes active or inactive with more than one count within the last 25 engine operating hours that inhibit the aftertreatment stationary regeneration, then proceed directly to performing the aftertreatment stationary regeneration.

Linked Solutions

  • None

Repair

  • No repair is necessary.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3868 | SPN: 3364 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

Troubleshooting Summary

  1. Fault Code triggered by a malfunction in the J1939 data link
  2. Power distribution center and fuse check
  3. Low battery voltage
  4. Battery load test
  5. Ground inspection
  6. Aftertreatment power relay is malfunctioning
  7. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  8. Aftertreatment power relay open circuit check
  9. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check
  10. J1939 data link engine wiring harness voltage check 3 pin service connector
  11. J1939 data link component isolation
  12. J1939 data link harness pin to ground short circuit
  13. J1939 data link terminating resistance is incorrect
  14. Incorrect terminating resistor in the J1939 data link
  15. Engine wiring harness has incorrect J1939 terminating resistance
  16. OEM wiring harness has incorrect J1939 terminating resistance
  17. J1939 data link harness open circuit check
  18. OEM terminating resistor Ω check for the J1939 data link
  19. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  20. J1939 wire resistance check at the crossover connector for each component
  21. ECM calibration revision history check
  22. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Fault Code triggered by a malfunction in the J1939 data link

Solution: S00006340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 2771, 3232, 4151, 4152, 4572, 4677

Linked Solutions

Click on the link below:

  • Power distribution center and fuse check

Refer to S00002836

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Power distribution center and fuse check

Solution: S00002836

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuse.

Refer to Procedure 019-198

  • Visually inspect the power distribution center for damage, corrosion or loose connections.

Specification

  • If the fuse is found to be blown or damaged, then proceed to Repair section.
  • If the power distribution center is damaged, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Replace the power distribution junction box.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00005421

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Refer to S00005422

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Solution: S00005422

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY at the sensor connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3878 | SPN: 3364 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002405

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • J1939 Datalink: 286, 427
  • Voltage: 477, 478
  • Aftertreatment diesel exhaust fluid system: 3557, 4248, 4291, 4282, 5673, 5674
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559, 3561

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00006694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the aftertreatment diesel exhaust fluid quality sensor.
  • Verify the sensor was properly installed.
  • Visually inspect the sensor for damage.

Specification

  • If the aftertreatment diesel exhaust fluid quality sensor does not meet specification, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 3916 | SPN: 84 | FMI: 31
Wheel-Based Vehicle Speed - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. Mechanical gear slippage causing erratic wheel speed data
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696
  • Security device: 4138, 3139

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4132 | SPN: 84 | FMI: 20
Wheel-Based Vehicle Speed - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Incorrect vehicle speed sensor configuration
  2. Mechanical gear slippage causing erratic wheel speed data
  3. ECM calibration revision history check

1 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4133 | SPN: 84 | FMI: 21
Wheel-Based Vehicle Speed - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Vehicle speed sensor tampering
  2. Incorrect vehicle speed sensor configuration
  3. Vehicle speed sensor open circuit check
  4. Vehicle speed sensor circuit pin to ground short
  5. Vehicle speed sensor circuit pin to pin short
  6. Mechanical gear slippage causing erratic wheel speed data
  7. ECM calibration revision history check

1 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4151 | SPN: 5742 | FMI: 9
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Troubleshooting Summary

  1. Low battery voltage
  2. Battery load test
  3. Ground inspection
  4. Fault Code 4151 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  5. Aftertreatment power relay is malfunctioning
  6. Aftertreatment DPF temperature sensor module voltage check
  7. Aftertreatment power relay open circuit check
  8. Aftertreatment DPF temperature sensor module open circuit check
  9. J1939 data link engine wiring harness voltage check 3 pin service connector
  10. J1939 data link component isolation
  11. J1939 data link harness pin to ground short circuit
  12. J1939 data link terminating resistance is incorrect
  13. Incorrect terminating resistor in the J1939 data link
  14. Engine wiring harness has incorrect J1939 terminating resistance
  15. OEM wiring harness has incorrect J1939 terminating resistance
  16. J1939 data link harness open circuit check
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check

1 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Fault Code 4151 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00000918

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • A malfunctioning aftertreatment DPF temperature sensor module has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00005408

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module SUPPLY pin and the aftertreatment DPF temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment DPF temperature sensor module open circuit check

Refer to S00005409

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment DPF temperature sensor module open circuit check

Solution: S00005409

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment DPF temperature sensor module SUPPLY pin of the aftertreatment interface wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If voltage is within 1 volt of battery voltage, an open circuit or high resistance has been detected in the aftertreatment DPF temperature sensor module battery voltage RETURN circuit.
  • If voltage is not within 1 volt of battery voltage, an open circuit or high resistance has been detected in the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4152 | SPN: 5743 | FMI: 9
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment power relay is malfunctioning
  6. Aftertreatment SCR temperature sensor module voltage check
  7. Aftertreatment power relay open circuit check
  8. Aftertreatment SCR temperature sensor module open circuit check
  9. Fault Code 4152 triggered by a malfunction in the J1939 data link with multiple OEM fault codes
  10. J1939 data link engine wiring harness voltage check 3 pin service connector
  11. J1939 data link component isolation
  12. J1939 data link harness pin to ground short circuit
  13. J1939 data link terminating resistance is incorrect
  14. Incorrect terminating resistor in the J1939 data link
  15. Engine wiring harness has incorrect J1939 terminating resistance
  16. OEM wiring harness has incorrect J1939 terminating resistance
  17. J1939 data link harness open circuit check
  18. OEM terminating resistor Ω check for the J1939 data link
  19. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  20. J1939 wire resistance check at the crossover connector for each component
  21. ECM calibration revision history check
  22. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00005471

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 2771, 3232
  • Aftertreatment DPF: 4151
  • Aftertreatment diesel exhaust fluid system: 3868, 4672, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00005410

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module SUPPLY pin and the aftertreatment SCR temperature sensor module RETURN pin at the module connector of the aftertreatment interface harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment SCR temperature sensor module open circuit check

Refer to S00005411

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment SCR temperature sensor module open circuit check

Solution: S00005411

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment SCR temperature sensor module SUPPLY pin of the aftertreatment interface harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot each harness connected in series to determine which contains the open circuit.
  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fault Code 4152 triggered by a malfunction in the J1939 data link with multiple OEM fault codes

Solution: S00005413

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771, 3232, 3868, 4151,4572, 4677, 7663
  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 2771, 3232, 3868,4151, 4572, 4677, 7663

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

8 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

10.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4158 | SPN: 5742 | FMI: 12
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000219

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 4151, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4159 | SPN: 5743 | FMI: 12
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000218

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4161 | SPN: 5742 | FMI: 3
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module configuration is incorrect
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000217

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00005488

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module SUPPLY pin and the aftertreatment DPF temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.
  • Measure the voltage from the aftertreatment DPF temperature sensor module SUPPLY pin of the aftertreatment interface wiring harness to ground.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 18 volts (12 volt system) or 30 volts (24 volt system), a short circuit to battery has been detected in the aftertreatment DPF temperature sensor module battery voltage supply circuit, and an overcharging condition has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF temperature sensor module configuration is incorrect

Solution: S00000924

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment DPF temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment DPF temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4162 | SPN: 5742 | FMI: 4
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module open circuit check
  4. Aftertreatment DPF temperature sensor module configuration is incorrect
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000216

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00005489

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module SUPPLY pin and the aftertreatment DPF temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system), proceed to the next solution.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment DPF temperature sensor module open circuit check

Refer to S00005490

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF temperature sensor module open circuit check

Solution: S00005490

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the SUPPLY pin at the aftertreatment DPF temperature sensor module connector of the aftertreatment interface wiring harness and the SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the RETURN pin at the aftertreatment DPF temperature sensor module connector of the aftertreatment interface wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF temperature sensor module configuration is incorrect

Solution: S00000924

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment DPF temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment DPF temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4163 | SPN: 5742 | FMI: 16
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment DPF temperature sensor module is above normal operating range
  2. ECM calibration revision history check

1 - Aftertreatment DPF temperature sensor module is above normal operating range

Solution: S00000926

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is properly mounted.
  • Verify the proper heat shield is mounted over the aftertreatment temperature sensor module.
  • Visually inspect for debris on or around the aftertreatment temperature sensor module.
  • Visually check that no aftermarket shields, flaps, or brackets are mounted too close to the aftertreatment temperature sensor module.
  • Visually inspect for any exhaust leaks which would allow the aftertreatment temperature sensor module to overheat.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Relocate and/or secure the aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Install the proper heat shield (if equipped).

Refer to Procedure 011-032

  • Remove any obstruction in or around the aftertreatment DPF temperature sensor module.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4164 | SPN: 5743 | FMI: 3
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module incorrect configuration
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000215

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00005468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module SUPPLY pin and the aftertreatment SCR temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.
  • Measure the voltage from the aftertreatment SCR temperature sensor module SUPPLY pin of the aftertreatment interface wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 18 volts (12 volt system) or 30 volts (24 volt system), a short circuit to battery has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit and an overcharging condition has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment SCR temperature sensor module incorrect configuration

Solution: S00000928

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment SCR temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment SCR temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4165 | SPN: 5743 | FMI: 4
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module open circuit check
  4. Aftertreatment SCR temperature sensor module incorrect configuration
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000214

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00005469

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module SUPPLY pin and the aftertreatment SCR temperature sensor module RETURN pin at the module connector of the aftertreatment interface harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system), proceed to the next solution.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment SCR temperature sensor module open circuit check

Refer to S00005470

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment SCR temperature sensor module open circuit check

Solution: S00005470

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface harness.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the SUPPLY pin at the aftertreatment SCR temperature sensor module connector of the aftertreatment interface harness and the SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the RETURN pin at the aftertreatment SCR temperature sensor module connector of the aftertreatment interface harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot each harness connected in series to determine which contains the open circuit.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Parent Solution

3 - Aftertreatment SCR temperature sensor module incorrect configuration

Solution: S00000928

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment SCR temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment SCR temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4166 | SPN: 5743 | FMI: 16
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4213 | SPN: 3695 | FMI: 2
Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment DPF inhibit switch is malfunctioning
  2. ECM calibration revision history check

1 - Aftertreatment DPF inhibit switch is malfunctioning

Solution: S00000931

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify that the permit switch (inhibit switch) has been set up properly for the OEM application.

Refer to Procedure 011-056

Specification

  • This fault code indicates that the aftertreatment regeneration permit switch was disabled and the soot load of the diesel particulate filter is above a calibrated threshold.

Linked Solutions

  • None

Repair

  • Perform the Aftertreatment Stationary Regeneration procedure.

Refer to Procedure 014-016

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4233 | SPN: 3515 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000209

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4234 | SPN: 3515 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00004390

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4243 | SPN: 3515 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  2. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00006603

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4259 | SPN: 5742 | FMI: 11
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module SUPPLY circuit malfunction
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000201

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598
  • Aftertreatment DPF: 4151, 4162

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00009975

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module SUPPLY pin and the aftertreatment DPF temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If voltage is greater than 10-VDC (For 12 volt systems) or voltage is greater than 20-VDC (For 24 volt systems) an intermittent connection has been detected at the aftertreatment DPF temperature sensor module.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF temperature sensor module SUPPLY circuit malfunction

Solution: S00001068

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment DPF temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If voltage is less than 10-VDC (For 12 volt systems) or voltage is less than 20-VDC (For 24 volt systems) an open circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit.
  • If voltage is greater than 10-VDC (For 12 volt systems) or voltage is greater than 20-VDC (For 24 volt systems) an open circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage RETURN circuit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4261 | SPN: 5743 | FMI: 11
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module open circuit check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000198

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 6257
  • Aftertreatment SCR: 4152, 4165

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00005466

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module SUPPLY pin and the aftertreatment SCR temperature sensor module RETURN pin at the module connector of the aftertreatment interface wiring harness.
  • Measure the battery voltage during keyswitch ON and then during cranking conditions.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If voltage is greater than 10-VDC (For 12 volt systems) or voltage is greater than 20-VDC (For 24 volt systems) an intermittent connection has been detected at the aftertreatment SCR temperature sensor module.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment SCR temperature sensor module open circuit check

Solution: S00000944

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system) a malfunction of the OEM wiring harness, engine wiring harness or interconnects has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4486 | SPN: 5839 | FMI: 31
Diesel Exhaust Fluid Consumption Malfunction - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006584

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 4658, 6486

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4487 | SPN: 5840 | FMI: 31
Diesel Exhaust Fluid Dosing Malfunction - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006585

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1712, 3565, 3567, 3568, 3571, 3572, 5864, 5865, 5936, 1682, 3575
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Aftertreatment SCR: 3142, 3143, 3144, 3146, 3147, 3148, 3151, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4165, 4166, 4261
  • Turbocharger: 692, 693, 741, 742, 743

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4488 | SPN: 5841 | FMI: 31
Diesel Exhaust Fluid Quality Malfunction - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006602

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1685, 1686, 1714, 1715, 3868, 6765, 6766, 6767

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4489 | SPN: 5842 | FMI: 31
SCR Monitoring System Malfunction - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006596

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256, 2398, 3531, 3532, 7863
  • Turbocharger: 691, 692, 693, 741, 742, 743, 7862
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1677, 1678, 1679, 1683, 1684, 1685, 1686, 1714,1715, 3242, 3565, 3567, 3571, 3572, 3868, 3878, 4277, 4233, 4234, 4243, 4572, 4677, 4737, 4739, 4745,4768, 4769, 5864, 5865
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559, 3574, 3596, 5935, 6485
  • Aftertreatment SCR: 3142, 3143, 3146, 3147, 3148, 4152, 4159, 4164, 4165, 4166, 4261, 5655
  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135, 3168, 3316, 3317, 3319, 3321, 3322, 4151, 4158, 4161, 4162, 4163, 4259, 5715, 5716, 6786, 7868
  • Aftertreatment DOC: 3313, 3314, 7867
  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 5689
  • Intake manifold temperature: 122, 123, 153, 154
  • Sensor supply 5: 1695, 1696
  • Sensor supply 2: 187, 227
  • Exhaust gas temperature: 2373, 2374, 2554
  • Barometric pressure: 222, 295
  • Sensor supply 1: 352, 386
  • Intake manifold: 436, 2973

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4572 | SPN: 3031 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Troubleshooting Summary

  1. Fault Code triggered by a malfunction in the J1939 data link
  2. Power distribution center and fuse check
  3. Low battery voltage
  4. Battery load test
  5. Ground inspection
  6. Aftertreatment power relay is malfunctioning
  7. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  8. Aftertreatment power relay open circuit check
  9. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check
  10. Fault Code 4572 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  11. J1939 data link engine wiring harness voltage check 3 pin service connector
  12. J1939 data link component isolation
  13. J1939 data link harness pin to ground short circuit
  14. J1939 data link terminating resistance is incorrect
  15. Incorrect terminating resistor in the J1939 data link
  16. Engine wiring harness has incorrect J1939 terminating resistance
  17. OEM wiring harness has incorrect J1939 terminating resistance
  18. OEM terminating resistor Ω check for the J1939 data link
  19. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  20. J1939 wire resistance check at the crossover connector for each component
  21. ECM calibration revision history check

1 - Fault Code triggered by a malfunction in the J1939 data link

Solution: S00006341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 2771, 3232, 3868, 4151, 4152, 4677

Linked Solutions

Click on the link below:

  • Power distribution center and fuse check

Refer to S00002836

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Power distribution center and fuse check

Solution: S00002836

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuse.

Refer to Procedure 019-198

  • Visually inspect the power distribution center for damage, corrosion or loose connections.

Specification

  • If the fuse is found to be blown or damaged, then proceed to Repair section.
  • If the power distribution center is damaged, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Replace the power distribution junction box.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00005421

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Refer to S00005422

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Solution: S00005422

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY at the sensor connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fault Code 4572 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005424

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

If there is a previously saved job image, then that fault code list should be used in place of retrieving the fault codes again with the recommended Cummins® electronic service tool or equivalent. This will eliminate the need to reconnect and then disconnect component(s). Retrieving fault codes without reconnecting these components will result in multiple fault codes to be logged.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771, 3232,4151, 4152, 7663
  • A malfunctioning aftertreatment diesel exhaust fluid tank level/temperature/quality sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 2771, 3232,4151, 4152,7663

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4584 | SPN: 3936 | FMI: 14
Aftertreatment Diesel Particulate Filter System - Special Instructions

Troubleshooting Summary

  1. Restricted intake air filter
  2. Aftertreatment DPF system incorrect for this engine application
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. Aftertreatment temperature sensor stuck in-range
  6. Snap acceleration check for excessive black smoke
  7. Overhead component damaged or out of adjustment
  8. ECM calibration revision history check
  9. Stationary aftertreatment regeneration is needed

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment DPF system incorrect for this engine application

Solution: S00001141

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.

Specification

  • This fault code indicates that the incorrect aftertreatment diesel particulate filter system has been installed with the engine. Verify the correct aftertreatment diesel particulate filter system has been installed with the engine.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4585 | SPN: 4792 | FMI: 14
Aftertreatment 1 SCR Catalyst System - Special Instructions

Troubleshooting Summary

  1. Aftertreatment SCR system is incorrect for this engine application

1 - Aftertreatment SCR system is incorrect for this engine application

Solution: S00001149

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Fault code 4585 active indicates the incorrect aftertreatment SCR system installed with this engine.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4658 | SPN: 4331 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment diesel exhaust fluid dosing valve pressure check
  5. Aftertreatment diesel exhaust fluid dosing valve return restriction check
  6. Aftertreatment diesel exhaust fluid dosing unit suction test
  7. Aftertreatment diesel exhaust fluid dosing unit return circuit check
  8. Aftertreatment diesel exhaust fluid dosing system cleaning
  9. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  10. Aftertreatment diesel exhaust fluid pressure line restricted
  11. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  12. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  13. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002569

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid dosing unit: 1682
  • Aftertreatment diesel exhaust fluid dosing valve: 3567, 3568
  • Aftertreatment diesel exhaust fluid pressure: 5935, 5936

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve pressure check

Solution: S00000862

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the inlet of the aftertreatment diesel exhaust fluid dosing valve and the pressure line.

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then proceed to the Linked Solutions section.
  • If the aftertreatment diesel exhaust fluid pressure is less than or within specification, then proceed to the next solution.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve return restriction check

Refer to S00000873

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid dosing valve return restriction check

Solution: S00000873

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Install the diesel exhaust fluid pressure gauge at the diesel exhaust fluid dosing valve outlet.

Refer to Procedure 011-144

This is the return line between the dosing valve and the tank.

  • Reconnect the diesel exhaust fluid pressure line to the inlet of the dosing valve.

Refer to Procedure 011-144

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

  • Read the diesel exhaust fluid pressure from the service tool gauge.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the aftertreatment diesel exhaust fluid pressure is less than the following: 70 kPa [10 psi]
  • A blocked or restricted return line or tank head has been detected if the aftertreatment diesel exhaust fluid pressure is greater than the following: 70 kPa [10 psi]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the return line as necessary.

Refer to OEM Service Manual

  • Clean or replace the tank head as necessary.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not operate during the test, then proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing unit return circuit check.
  • Proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing system cleaning if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Proceed to the next solution if the vacuum in diagnostic line is greater than the following: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit return circuit check

Refer to S00000858

  • Aftertreatment diesel exhaust fluid dosing system cleaning

Refer to S00002910

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing unit return circuit check

Solution: S00000858

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid dosing unit motor runs.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment diesel exhaust fluid dosing system cleaning

Solution: S00002910

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Refer to Procedure 011-056

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid pressure line restricted

Solution: S00003284

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the outlet of the aftertreatment diesel exhaust fluid dosing unit and the pressure line.

Refer to Procedure 011-144

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then a restricted aftertreatment diesel exhaust fluid pressure line has been detected.
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure is less than specification.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00003230

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid pressure line.

Refer to OEM Service Manual

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003230

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit outlet fitting for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit filter for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing valve inlet fitting screen for signs of blockage or buildup.

Specification

  • If there are no signs of blockage or buildup, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.
  • If there are signs of blockage or buildup, then a restricted aftertreatment diesel exhaust fluid dosing unit outlet fitting or aftertreatment diesel exhaust fluid dosing valve inlet fitting has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing unit filter regardless of condition.

Refer to Procedure 011-060

  • Clean the aftertreatment diesel exhaust fluid dosing unit outlet fitting.
  • Clean the aftertreatment diesel exhaust fluid dosing valve inlet fitting.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4677 | SPN: 1761 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Troubleshooting Summary

  1. Low battery voltage
  2. Battery load test
  3. Ground inspection
  4. Aftertreatment power relay is malfunctioning
  5. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  6. Aftertreatment power relay open circuit check
  7. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check
  8. Fault Code 4677 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  9. J1939 data link engine wiring harness voltage check 3 pin service connector
  10. J1939 data link component isolation
  11. J1939 data link harness pin to ground short circuit
  12. J1939 data link terminating resistance is incorrect
  13. Incorrect terminating resistor in the J1939 data link
  14. Engine wiring harness has incorrect J1939 terminating resistance
  15. OEM wiring harness has incorrect J1939 terminating resistance
  16. J1939 data link harness open circuit check
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check

1 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Aftertreatment power relay is malfunctioning

Solution: S00005294

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00005421

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay open circuit check

Refer to S00005386

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Refer to S00005422

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment power relay open circuit check

Solution: S00005386

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness battery connector and the battery SUPPLY pin at the OEM wiring harness aftertreatment power relay connector.
  • Measure the resistance between the aftertreatment power relay SIGNAL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor open circuit check

Solution: S00005422

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY at the sensor connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 4677 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005596

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

If there is a previously saved job image, then that fault code list should be used in place of retrieving the fault codes again with the recommended Cummins® electronic service tool or equivalent. This will eliminate the need to reconnect and then disconnect component(s). Retrieving fault codes without reconnecting these components will result in multiple fault codes to be logged.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771, 3232,4151, 4152, 7663
  • A malfunctioning aftertreatment diesel exhaust fluid tank level/temperature/quality sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 2771, 3232,4151, 4152,7663

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00005364

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • J1939 data link component isolation

Refer to S00005365

  • Engine or OEM wiring harness shorted to ground

Refer to S00005380

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - J1939 data link component isolation

Solution: S00005365

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins to battery ground for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Specification

  • Proceed to the next Linked Solution if the voltage is not within the following specification: 1 - 4.5 VDC
  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00005380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00005367

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

Click on the link below:

  • Incorrect terminating resistor in the J1939 data link

Refer to S00005353

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00005368

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Incorrect terminating resistor in the J1939 data link

Solution: S00005353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00005368

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00005372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00005369

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00005369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment intake NOx sensor.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-608

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4731 | SPN: 3031 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00005378

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4732 | SPN: 1761 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  2. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00005376

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.
  • Wait for 120 seconds.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Check the aftertreatment diesel exhaust fluid gauge on the dash.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.
  • A malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected if the fault code is active and the aftertreatment diesel exhaust fluid gauge on the dash indicates the tank is full.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4737 | SPN: 3031 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00005378

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4739 | SPN: 1761 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00006448

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4745 | SPN: 3515 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4747 | SPN: 3217 | FMI: 20
Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment intake and outlet NOx sensors malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973
  • Intake manifold temperature: 155, 2964
  • Barometric pressure: 295
  • Aftertreatment NOx: 1885, 3232, 3649, 3682, 3748
  • Aftertreatment outlet oxygen: 4749, 4751

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake and outlet NOx sensors malfunctioning

Solution: S00000991

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify proper installation of the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Specification

  • If Fault Code 4749 or 4751 is not active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.
  • If Fault Code 4749 or 4751 is active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4748 | SPN: 3217 | FMI: 21
Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment intake and outlet NOx sensors malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973
  • Intake manifold temperature: 155, 2964
  • Barometric pressure: 295
  • Aftertreatment NOx: 1885, 3232, 3649, 3682, 3748
  • Aftertreatment outlet oxygen: 4749, 4751

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake and outlet NOx sensors malfunctioning

Solution: S00000991

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify proper installation of the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Specification

  • If Fault Code 4749 or 4751 is not active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.
  • If Fault Code 4749 or 4751 is active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4749 | SPN: 3227 | FMI: 20
Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment outlet NOx sensor has carbon buildup
  4. Charge air cooler is restricted
  5. ECM calibration revision history check
  6. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006076

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973
  • Intake manifold temperature: 155, 2964
  • Barometric pressure: 295
  • Aftertreatment NOx: 1887, 2771, 3583, 3681
  • Aftertreatment intake oxygen: 4747, 4748

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler is restricted

Solution: S00001005

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the pressure differential across the charge air cooler.

Refer to Procedure 010-027

Specification

  • If the charge air cooler does not meet specification, then a malfunctioning charge air cooler has been detected.

Refer to Procedure 010-027

Linked Solutions

  • None

Repair

  • Repair or replace the charge air cooler.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4751 | SPN: 3227 | FMI: 21
Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment outlet NOx sensor has carbon buildup
  4. Charge air cooler is restricted
  5. ECM calibration revision history check
  6. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006076

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973
  • Intake manifold temperature: 155, 2964
  • Barometric pressure: 295
  • Aftertreatment NOx: 1887, 2771, 3583, 3681
  • Aftertreatment intake oxygen: 4747, 4748

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler is restricted

Solution: S00001005

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the pressure differential across the charge air cooler.

Refer to Procedure 010-027

Specification

  • If the charge air cooler does not meet specification, then a malfunctioning charge air cooler has been detected.

Refer to Procedure 010-027

Linked Solutions

  • None

Repair

  • Repair or replace the charge air cooler.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4769 | SPN: 1761 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid level is low
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005292

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 4739

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00005376

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.
  • Wait for 120 seconds.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Check the aftertreatment diesel exhaust fluid gauge on the dash.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.
  • A malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected if the fault code is active and the aftertreatment diesel exhaust fluid gauge on the dash indicates the tank is full.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4843 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Fan clutch operates incorrectly
  3. Intake manifold temperature sensor stuck in-range
  4. Malfunctioning cooling fan drive or cooling fan controls
  5. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Overhead component damaged or out of adjustment

Solution: S00000389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4948 | SPN: 6874 | FMI: 3
Performance Bias Selection Switch - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Performance bias selection switch circuit response
  2. Performance bias selection switch open circuit check
  3. Performance bias selection switch circuit pin to pin short

1 - Performance bias selection switch circuit response

Solution: S00005746

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the performance bias selection switch SIGNAL pin and the performance bias selection switch RETURN pin at the switch connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning performance bias selection switch has been detected if the following fault code became active with the switch disconnected: 4949

Linked Solutions

  • None

Repair

  • Replace the performance bias selection switch.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Performance bias selection switch open circuit check

Solution: S00005745

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the performance bias selection switch RETURN pin at the performance bias selection switch OEM wiring harness connector and the performance bias selection switch RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the performance bias selection switch SIGNAL pin at the performance bias selection switch OEM wiring harness connector and the performance bias selection switch SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Performance bias selection switch circuit pin to pin short

Solution: S00004229

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the performance bias selection switch SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the performance bias selection switch RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 30-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 4949 | SPN: 6874 | FMI: 4
Performance Bias Selection Switch - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Performance bias selection switch circuit response
  2. Performance bias selection switch circuit pin to ground short
  3. Performance bias selection switch circuit pin to pin short

1 - Performance bias selection switch circuit response

Solution: S00004317

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning performance bias selection switch has been detected if the following fault code became active with the switch disconnected: 4948

Linked Solutions

  • None

Repair

  • Replace the performance bias selection switch.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Performance bias selection switch circuit pin to ground short

Solution: S00004223

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the performance bias selection switch SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Performance bias selection switch circuit pin to pin short

Solution: S00004229

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the performance bias selection switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the performance bias selection switch SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the performance bias selection switch RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 30-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5271 | SPN: 649 | FMI: 3
Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine exhaust back pressure regulator resistance check
  2. Engine wiring harness shorted to a voltage source
  3. Engine exhaust back pressure regulator open circuit check
  4. Engine exhaust back pressure regulator circuit pin to ground short
  5. Engine exhaust back pressure regulator circuit pin to pin short

1 - Engine exhaust back pressure regulator resistance check

Solution: S00002533

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the engine exhaust back pressure regulator motor resistance.

Refer to Procedure 011-105

Specification

  • If the resistance is not within specification, then a malfunctioning engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine wiring harness shorted to a voltage source

Solution: S00002024

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine exhaust back pressure regulator SUPPLY pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the voltage between the engine exhaust back pressure regulator RETURN pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the voltage between the engine exhaust back pressure regulator motor SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the voltage between the engine exhaust back pressure regulator motor RETURN pin at the engine wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is greater than the following specification: 1.5 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine exhaust back pressure regulator open circuit check

Solution: S00000573

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine exhaust back pressure regulator circuit pin to ground short

Solution: S00000531

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine exhaust back pressure regulator circuit pin to pin short

Solution: S00001603

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 06-Mar-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5272 | SPN: 649 | FMI: 4
Engine Exhaust Back Pressure Regulator Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine exhaust back pressure regulator circuit pin to ground short
  2. Engine exhaust back pressure regulator motor short to ground
  3. Engine exhaust back pressure regulator circuit pin to pin short

1 - Engine exhaust back pressure regulator circuit pin to ground short

Solution: S00000531

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine exhaust back pressure regulator motor short to ground

Solution: S00001129

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine exhaust back pressure regulator has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine exhaust back pressure regulator circuit pin to pin short

Solution: S00001603

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 06-Mar-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5273 | SPN: 649 | FMI: 5
Engine Exhaust Back Pressure Regulator Control Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Engine exhaust back pressure regulator resistance check
  2. Engine exhaust back pressure regulator open circuit check
  3. Engine exhaust back pressure regulator circuit pin to ground short
  4. Engine exhaust back pressure regulator circuit pin to pin short

1 - Engine exhaust back pressure regulator resistance check

Solution: S00002533

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the engine exhaust back pressure regulator motor resistance.

Refer to Procedure 011-105

Specification

  • If the resistance is not within specification, then a malfunctioning engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine exhaust back pressure regulator open circuit check

Solution: S00000573

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine exhaust back pressure regulator circuit pin to ground short

Solution: S00000531

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine exhaust back pressure regulator circuit pin to pin short

Solution: S00001603

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 06-Mar-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5274 | SPN: 5625 | FMI: 2
Engine Exhaust Back Pressure Regulator Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine exhaust back pressure regulator resistance check
  3. Engine exhaust back pressure regulator voltage check
  4. Engine exhaust back pressure regulator voltage check at the ECM
  5. Engine exhaust back pressure regulator open circuit check
  6. Engine exhaust back pressure regulator circuit pin to ground short
  7. Engine exhaust back pressure regulator circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006175

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine exhaust back pressure regulator resistance check

Solution: S00002533

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the engine exhaust back pressure regulator motor resistance.

Refer to Procedure 011-105

Specification

  • If the resistance is not within specification, then a malfunctioning engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine exhaust back pressure regulator voltage check

Solution: S00000325

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine exhaust back pressure regulator voltage check at the ECM

Refer to S00000482

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Engine exhaust back pressure regulator voltage check at the ECM

Solution: S00000482

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the ECM.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Engine exhaust back pressure regulator open circuit check

Solution: S00000573

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator SUPPLY pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator SUPPLY pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor SIGNAL pin at the ECM connector of the engine wiring harness.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin at the engine exhaust back pressure regulator connector of the engine wiring harness and the engine exhaust back pressure regulator motor RETURN pin at the ECM connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine exhaust back pressure regulator circuit pin to ground short

Solution: S00005605

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator position SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator position SIGNAL pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator position RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine exhaust back pressure regulator circuit pin to pin short

Solution: S00005606

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator position SUPPLY pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the engine exhaust back pressure regulator position SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the engine exhaust back pressure regulator position RETURN pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5275 | SPN: 5625 | FMI: 3
Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine exhaust back pressure regulator voltage check
  3. Engine exhaust back pressure regulator voltage check at the ECM
  4. Engine exhaust back pressure regulator circuit response
  5. Engine exhaust back pressure regulator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006175

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine exhaust back pressure regulator voltage check

Solution: S00000325

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine exhaust back pressure regulator voltage check at the ECM

Refer to S00000482

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine exhaust back pressure regulator voltage check at the ECM

Solution: S00000482

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the ECM.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine exhaust back pressure regulator circuit response

Solution: S00004414

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine exhaust back pressure regulator has been detected if the following fault code became active with the regulator disconnected: 5276

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • None
Next Solution

4 - Engine exhaust back pressure regulator circuit response at the ECM

Solution: S00002518

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 5276
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 5276

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 06-Mar-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5276 | SPN: 5625 | FMI: 4
Engine Exhaust Back Pressure Regulator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine exhaust back pressure regulator voltage check
  3. Engine exhaust back pressure regulator voltage check at the ECM
  4. Engine exhaust back pressure regulator circuit response
  5. Engine exhaust back pressure regulator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006175

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine exhaust back pressure regulator voltage check

Solution: S00000325

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine exhaust back pressure regulator voltage check at the ECM

Refer to S00000482

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine exhaust back pressure regulator voltage check at the ECM

Solution: S00000482

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Measure the voltage between the engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor RETURN pin at the ECM.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine exhaust back pressure regulator circuit response

Solution: S00004190

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine exhaust back pressure regulator has been detected if the following fault code became active with the jumper wire in place: 5275

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • None
Next Solution

4 - Engine exhaust back pressure regulator circuit response at the ECM

Solution: S00002520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between engine exhaust back pressure regulator position sensor SUPPLY pin and the engine exhaust back pressure regulator position sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 5275
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 5275

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 06-Mar-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5277 | SPN: 5626 | FMI: 13
Engine Exhaust Back Pressure Regulator - Out of Calibration

Troubleshooting Summary

  1. Check for primary fault codes
  2. Incorrect adjustable parameter setting
  3. Engine exhaust back pressure regulator is malfunctioning
  4. Engine exhaust back pressure regulator motor short to ground
  5. Engine exhaust back pressure regulator soot deposit check
  6. Engine exhaust back pressure regulator is malfunctioning

1 - Check for primary fault codes

Solution: S00002382

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust back pressure: 5273, 5274, 5276, 5293, 5295, 5313

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00002825

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.
  • Go to Features and Parameters.
  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.
  • If the adjustable parameter setting and application do match, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Engine exhaust back pressure regulator is malfunctioning

Refer to S00002817

Repair

  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Engine exhaust back pressure regulator is malfunctioning

Solution: S00002817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Verify the engine exhaust back pressure regulator is the correct engine exhaust back pressure regulator for the engine configuration.

Specification

  • If the engine exhaust back pressure regulator is not the correct part number for the engine configuration, then the incorrect engine exhaust back pressure regulator has been installed.

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • None
Parent Solution

3 - Engine exhaust back pressure regulator motor short to ground

Solution: S00001129

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine exhaust back pressure regulator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine exhaust back pressure regulator motor SIGNAL pin and engine block ground.
  • Measure the resistance between the engine exhaust back pressure regulator motor RETURN pin and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine exhaust back pressure regulator has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine exhaust back pressure regulator soot deposit check

Solution: S00002612

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine exhaust back pressure regulator for excessive soot deposits.

Specification

  • If excessive soot deposits are found in the engine exhaust back pressure regulator, then a sticking engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Clean the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine exhaust back pressure regulator is malfunctioning

Solution: S00002541

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning engine exhaust back pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine exhaust back pressure regulator.

Refer to Procedure 011-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5278 | SPN: 6802 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002348

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1682, 1683

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5576 | SPN: 107 | FMI: 15
Engine Air Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter

1 - Check for primary fault codes

Solution: S00008873

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696
  • Turbocharger: 741, 742, 743

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5655 | SPN: 4364 | FMI: 31
Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Troubleshooting Summary

  1. Fault Code 5655 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment exhaust system leaks
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Diesel fuel used is incorrect
  9. Aftertreatment SCR System Test
  10. Aftertreatment diesel exhaust fluid dosing system test failed
  11. Aftertreatment intake NOx sensor failed
  12. Aftertreatment outlet NOx sensor - Inspection
  13. Inspect both aftertreatment NOx sensors
  14. Aftertreatment SCR Catalyst Test Failed
  15. ECM calibration revision history check

1 - Fault Code 5655 requires that ALL solutions be performed

Solution: S00007691

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00005238

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 4747, 4748, 4749, 4751, 5689
  • Aftertreatment SCR: 3142, 3143, 3144, 3146, 3147, 3148, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4166, 4261
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 1685, 1686, 1715, 3497, 3498, 3547, 3568, 3571, 3572, 3574, 3575, 3867, 3868, 4277, 4658,4677, 4739, 4768, 5278, 5864, 5865, 5935, 5936
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Aftertreatment regeneration: 2777, 3753, 4213
  • Fuel: 8363, 8523

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000562

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.
  • Reconnect the aftertreatment diesel exhaust fluid dosing valve to the decomposition tube if it has been previously disconnected during troubleshooting.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair the source of the external diesel exhaust fluid leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Diesel fuel used is incorrect

Solution: S00005465

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • If this vehicle has been repaired within the last 30 days for the same fault code, then the use of the incorrect fuel is suspected.
  • Verify the correct diesel fuel is being used.

Refer to Procedure 375-001

Specification

  • If the diesel fuel being used is not correct for the engine configuration, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Drain and fill with the correct diesel fuel for the engine configuration.
  • Replace the suction side fuel filter.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5689 | SPN: 3226 | FMI: 11
Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. ECM calibration revision history check
  4. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006082

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3583, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00005366

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect for exhaust leaks around the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

  • Inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5715 | SPN: 3251 | FMI: 10
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Charge air cooler or exhaust system leak
  7. Aftertreatment DPF differential pressure sensor open circuit check
  8. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  9. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  10. ECM calibration revision history check
  11. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00005086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler or exhaust system leak

Solution: S00005087

Verification

Conditions

  • Engine running.

Action

  • Run engine at high idle.
  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-027

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the exhaust back pressure regulator.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the exhaust back pressure regulator and the aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00005433

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00005434

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00005431

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5716 | SPN: 3610 | FMI: 10
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor vent plugged or damaged
  3. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  4. Aftertreatment DPF differential pressure sensor voltage check
  5. Aftertreatment DPF differential pressure sensor circuit check
  6. Aftertreatment DPF outlet pressure sensor voltage check
  7. Aftertreatment DPF outlet pressure sensor circuit check
  8. Aftertreatment DPF differential pressure sensor stuck in-range
  9. Aftertreatment DPF outlet pressure sensor open circuit check
  10. Aftertreatment DPF outlet pressure circuit pin to ground short
  11. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000066

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 3133, 3134

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor vent plugged or damaged

Solution: S00005439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment DPF differential pressure sensor from the sensor mounting bracket.
  • Inspect the aftertreatment DPF differential pressure sensor vent for signs of plugging or damage.

Refer to Procedure 019-443

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00005441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00005446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5864 | SPN: 4375 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit short circuit to battery
  2. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  3. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit short circuit to battery

Solution: S00005587

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and battery positive (+).
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00005630

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00005583

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5865 | SPN: 4375 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Pump Command Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit relay voltage check
  2. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  3. Aftertreatment diesel exhaust fluid dosing unit circuit pin to ground short
  4. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  5. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit relay voltage check

Solution: S00001015

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit relay battery SUPPLY pin at the relay OEM wiring harness connector and ground.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00005625

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit pump connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to ground short

Solution: S00005608

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Connect the OEM wiring harness to the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin of the dosing unit OEM wiring harness connector and engine block.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current SCM code and revision number in the SCM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00005630

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit pump motor control SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00005583

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5879 | SPN: 3464 | FMI: 3
Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine intake throttle actuator motor open circuit check
  2. Intake throttle control actuator motor circuit pin to pin short

1 - Engine intake throttle actuator motor open circuit check

Solution: S00000494

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5881 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine intake throttle actuator motor shorted to ground
  2. Engine intake throttle actuator circuit pin to ground short
  3. Intake throttle control actuator motor circuit pin to pin short

1 - Engine intake throttle actuator motor shorted to ground

Solution: S00000493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator circuit pin to ground short

Solution: S00000492

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5935 | SPN: 4334 | FMI: 7
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Plugged or restricted aftertreatment diesel exhaust dosing valve return line or fittings
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006085

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 5278

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Plugged or restricted aftertreatment diesel exhaust dosing valve return line or fittings

Solution: S00001042

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the dosing unit supply line, between the tank and the dosing unit (suction line) for signs of leaks and white deposits.
  • Visually inspect the dosing valve supply line, between the dosing unit and the dosing valve (pressure line) for signs of leaks and white deposits.
  • Visually inspect the return line, between the dosing valve and the tank (return line) for signs of leaks and white deposits.
  • Visually inspect the return line and associated fittings/connectors for damage, signs of leaks or white deposits.
  • Visually inspect the return line for any kinks or improper routing.
  • Disconnect the return line dosing valve connectors and look for signs of buildup or blockage.

Specification

  • If leaks, white deposits, damage or improper routing are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace damaged connections.

Refer to OEM Service Manual

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5936 | SPN: 4334 | FMI: 15
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Plugged or restricted aftertreatment diesel exhaust dosing valve return line or fittings
  3. Aftertreatment diesel exhaust fluid dosing unit relay voltage check
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  6. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006049

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 5278

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Plugged or restricted aftertreatment diesel exhaust dosing valve return line or fittings

Solution: S00001042

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the dosing unit supply line, between the tank and the dosing unit (suction line) for signs of leaks and white deposits.
  • Visually inspect the dosing valve supply line, between the dosing unit and the dosing valve (pressure line) for signs of leaks and white deposits.
  • Visually inspect the return line, between the dosing valve and the tank (return line) for signs of leaks and white deposits.
  • Visually inspect the return line and associated fittings/connectors for damage, signs of leaks or white deposits.
  • Visually inspect the return line for any kinks or improper routing.
  • Disconnect the return line dosing valve connectors and look for signs of buildup or blockage.

Specification

  • If leaks, white deposits, damage or improper routing are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace damaged connections.

Refer to OEM Service Manual

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit relay voltage check

Solution: S00001015

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit relay battery SUPPLY pin at the relay OEM wiring harness connector and ground.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00005933

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00005938

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 5986 | SPN: 110 | FMI: 10
Engine Coolant Temperature - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Thermostat is malfunctioning
  3. Out-of-chassis opening temperature test
  4. ECM calibration revision history check
  5. Coolant temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000074

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant temperature sensor is malfunctioning

Solution: S00001238

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6127 | SPN: 636 | FMI: 2
Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine crankshaft speed/position sensor is incorrect
  3. Engine crankshaft speed/position sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001772

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Camshaft speed/position sensor: 6712, 6713

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine crankshaft speed/position sensor is incorrect

Solution: S00004220

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct crankshaft speed/position sensor is installed.

Specification

  • If the sensor is not correct for this engine configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00004204

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If the crankshaft position sensor shows any signs of damage, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6266 | SPN: 5862 | FMI: 14
Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor tampering
  3. ECM calibration revision history check
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000058

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor tampering

Solution: S00004934

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment exhaust gas temperature sensor module is properly mounted.
  • Verify the aftertreatment exhaust gas temperature sensors are properly mounted.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensor module.
  • Verify no external device is connected in place of the aftertreatment exhaust gas temperature sensors.
  • Visually inspect the aftertreatment exhaust gas temperature sensors for signs of damage or tampering.
  • Visually inspect the aftertreatment exhaust gas temperature sensor module for signs of damage or tampering.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Repair or remove the tampering device or any external device.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6338 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6485 | SPN: 4375 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Pump Drive Percentage - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid level is low
  3. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning
  6. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  7. Aftertreatment diesel exhaust fluid dosing valve pressure check
  8. Aftertreatment diesel exhaust fluid dosing valve return restriction check
  9. Aftertreatment diesel exhaust fluid dosing unit suction test
  10. Aftertreatment diesel exhaust fluid dosing unit return circuit check
  11. Aftertreatment diesel exhaust fluid dosing system cleaning
  12. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  13. Aftertreatment diesel exhaust fluid pressure line restricted
  14. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  15. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  16. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  17. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006559

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3498, 3571, 3572, 3575, 3596, 5278, 5864, 5865, 5935
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing valve pressure sensor is malfunctioning

Solution: S00006324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve pressure line.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid pressure reading is within the following specification: 0 ± 69 kPa [0 ± 10 psi]
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure reading is not within the following specification: 0 ± 69 kPa [0 ± 10 psi]

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Refer to S00006304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00006304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing valve connector of the aftertreatment interface wiring harness and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing valve pressure check

Solution: S00000862

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the inlet of the aftertreatment diesel exhaust fluid dosing valve and the pressure line.

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then proceed to the Linked Solutions section.
  • If the aftertreatment diesel exhaust fluid pressure is less than or within specification, then proceed to the next solution.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve return restriction check

Refer to S00000873

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve return restriction check

Solution: S00000873

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Install the diesel exhaust fluid pressure gauge at the diesel exhaust fluid dosing valve outlet.

Refer to Procedure 011-144

This is the return line between the dosing valve and the tank.

  • Reconnect the diesel exhaust fluid pressure line to the inlet of the dosing valve.

Refer to Procedure 011-144

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

  • Read the diesel exhaust fluid pressure from the service tool gauge.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the aftertreatment diesel exhaust fluid pressure is less than the following: 70 kPa [10 psi]
  • A blocked or restricted return line or tank head has been detected if the aftertreatment diesel exhaust fluid pressure is greater than the following: 70 kPa [10 psi]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the return line as necessary.

Refer to OEM Service Manual

  • Clean or replace the tank head as necessary.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not operate during the test, then proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing unit return circuit check.
  • Proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing system cleaning if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Proceed to the next solution if the vacuum in diagnostic line is greater than the following: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit return circuit check

Refer to S00000858

  • Aftertreatment diesel exhaust fluid dosing system cleaning

Refer to S00002910

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing unit return circuit check

Solution: S00000858

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid dosing unit motor runs.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment diesel exhaust fluid dosing system cleaning

Solution: S00002910

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Refer to Procedure 011-056

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid pressure line restricted

Solution: S00003284

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the outlet of the aftertreatment diesel exhaust fluid dosing unit and the pressure line.

Refer to Procedure 011-144

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then a restricted aftertreatment diesel exhaust fluid pressure line has been detected.
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure is less than specification.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00003230

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid pressure line.

Refer to OEM Service Manual

Validation

  • None
Next Solution

9.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003230

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit outlet fitting for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit filter for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing valve inlet fitting screen for signs of blockage or buildup.

Specification

  • If there are no signs of blockage or buildup, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.
  • If there are signs of blockage or buildup, then a restricted aftertreatment diesel exhaust fluid dosing unit outlet fitting or aftertreatment diesel exhaust fluid dosing valve inlet fitting has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing unit filter regardless of condition.

Refer to Procedure 011-060

  • Clean the aftertreatment diesel exhaust fluid dosing unit outlet fitting.
  • Clean the aftertreatment diesel exhaust fluid dosing valve inlet fitting.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6486 | SPN: 4331 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment diesel exhaust fluid dosing valve pressure check
  5. Aftertreatment diesel exhaust fluid dosing valve return restriction check
  6. Aftertreatment diesel exhaust fluid dosing unit suction test
  7. Aftertreatment diesel exhaust fluid dosing unit return circuit check
  8. Aftertreatment diesel exhaust fluid dosing system cleaning
  9. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  10. Aftertreatment diesel exhaust fluid pressure line restricted
  11. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  12. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  13. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001033

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1682, 3567, 3568, 3575, 5935, 5936

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00007964

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to Procedure 011-058

  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.

Refer to Procedure 011-058

  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.

Refer to Procedure 011-058

  • Visually inspect the pressure line for signs of leakage or rupture.

Refer to Procedure 011-058

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing valve pressure check

Solution: S00000862

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the inlet of the aftertreatment diesel exhaust fluid dosing valve and the pressure line.

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then proceed to the Linked Solutions section.
  • If the aftertreatment diesel exhaust fluid pressure is less than or within specification, then proceed to the next solution.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing valve return restriction check

Refer to S00000873

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid dosing valve return restriction check

Solution: S00000873

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Wait for 30 seconds.
  • Install the diesel exhaust fluid pressure gauge at the diesel exhaust fluid dosing valve outlet.

Refer to Procedure 011-144

This is the return line between the dosing valve and the tank.

  • Reconnect the diesel exhaust fluid pressure line to the inlet of the dosing valve.

Refer to Procedure 011-144

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-144

  • Read the diesel exhaust fluid pressure from the service tool gauge.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the aftertreatment diesel exhaust fluid pressure is less than the following: 70 kPa [10 psi]
  • A blocked or restricted return line or tank head has been detected if the aftertreatment diesel exhaust fluid pressure is greater than the following: 70 kPa [10 psi]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the return line as necessary.

Refer to OEM Service Manual

  • Clean or replace the tank head as necessary.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000672

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit does not operate during the test, then proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing unit return circuit check.
  • Proceed to the Linked Solutions section and perform the aftertreatment diesel exhaust fluid dosing system cleaning if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Proceed to the next solution if the vacuum in diagnostic line is greater than the following: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit return circuit check

Refer to S00000858

  • Aftertreatment diesel exhaust fluid dosing system cleaning

Refer to S00002910

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing unit return circuit check

Solution: S00000858

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Proceed to the next solution if the aftertreatment diesel exhaust fluid dosing unit motor runs.
  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment diesel exhaust fluid dosing system cleaning

Solution: S00002910

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Drain the diesel exhaust fluid tank, clean thoroughly, replace filter and refill with pure clean diesel exhaust fluid.

Refer to Procedure 011-056

  • Perform the aftertreatment diesel exhaust fluid dosing unit manual purge.

Refer to Procedure 011-143

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -203 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -203 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid pressure line restricted

Solution: S00003284

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install the aftertreatment diesel exhaust fluid pressure gauge between the outlet of the aftertreatment diesel exhaust fluid dosing unit and the pressure line.

Refer to Procedure 011-144

This is the supply line between the aftertreatment diesel exhaust fluid dosing unit and the aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing System Pressure Test.

Refer to Procedure 011-144

Specification

  • If the aftertreatment diesel exhaust fluid pressure is greater than specification, then a restricted aftertreatment diesel exhaust fluid pressure line has been detected.
  • Proceed to the Linked Solutions section if the aftertreatment diesel exhaust fluid pressure is less than specification.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00003230

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid pressure line.

Refer to OEM Service Manual

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003230

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit outlet fitting for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit filter for signs of blockage or buildup.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing valve inlet fitting screen for signs of blockage or buildup.

Specification

  • If there are no signs of blockage or buildup, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.
  • If there are signs of blockage or buildup, then a restricted aftertreatment diesel exhaust fluid dosing unit outlet fitting or aftertreatment diesel exhaust fluid dosing valve inlet fitting has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing unit filter regardless of condition.

Refer to Procedure 011-060

  • Clean the aftertreatment diesel exhaust fluid dosing unit outlet fitting.
  • Clean the aftertreatment diesel exhaust fluid dosing valve inlet fitting.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6595 | SPN: 190 | FMI: 11
Engine Speed - Root Cause Not Known

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Reversed engine position sensors
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Reversed engine position sensors

Solution: S00000318

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually verify the camshaft engine position and crankshaft engine position sensor are connected properly.

Specification

  • If the sensors are not properly connected, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Connect the camshaft and crankshaft position sensors in the correct position.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6712 | SPN: 636 | FMI: 8
Engine Position Sensor - Abnormal Frequency or Pulse Width or Period

Troubleshooting Summary

  1. Engine crankshaft speed/position sensor is incorrect
  2. Engine crankshaft speed/position sensor is malfunctioning
  3. ECM calibration revision history check

1 - Engine crankshaft speed/position sensor is incorrect

Solution: S00004220

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct crankshaft speed/position sensor is installed.

Specification

  • If the sensor is not correct for this engine configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00004204

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If the crankshaft position sensor shows any signs of damage, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6713 | SPN: 636 | FMI: 31
Engine Position Sensor - Condition Exists

Troubleshooting Summary

  1. Engine crankshaft speed/position sensor is incorrect
  2. Engine crankshaft speed/position sensor is malfunctioning
  3. ECM calibration revision history check

1 - Engine crankshaft speed/position sensor is incorrect

Solution: S00004220

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the correct crankshaft speed/position sensor is installed.

Specification

  • If the sensor is not correct for this engine configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00004204

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft speed/position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If the crankshaft position sensor shows any signs of damage, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6765 | SPN: 3521 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6766 | SPN: 3521 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Property - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6767 | SPN: 3521 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Property - Condition Exists

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00005379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit.

Refer to Procedure 019-608

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6771 | SPN: 521032 | FMI: 14
Aftertreatment System Assembly - Special Instructions

Troubleshooting Summary

  1. Aftertreatment DPF system incorrect for this engine application
  2. ECM calibration revision history check

1 - Aftertreatment DPF system incorrect for this engine application

Solution: S00001141

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.

Specification

  • This fault code indicates that the incorrect aftertreatment diesel particulate filter system has been installed with the engine. Verify the correct aftertreatment diesel particulate filter system has been installed with the engine.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 6786 | SPN: 3610 | FMI: 20
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor stuck in-range
  4. High exhaust restriction
  5. Deposits in the SCR decomposition tube
  6. Leaks in the aftertreatment diesel exhaust fluid dosing system
  7. Aftertreatment DPF outlet pressure circuit pin to ground short
  8. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin
  9. ECM calibration revision history check
  10. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000422

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 3133, 3134

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00005446

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7325 | SPN: 4374 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Pump Motor Speed - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit relay voltage check
  3. Aftertreatment diesel exhaust fluid dosing unit pump motor open circuit check
  4. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00010395

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1682, 3574, 3575, 3596, 5278, 5935, 5936

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit relay voltage check

Solution: S00001015

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit relay battery SUPPLY pin at the relay OEM wiring harness connector and ground.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit pump motor open circuit check

Solution: S00008825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit OEM wiring harness connector and the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short

Solution: S00008824

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to pin short

Solution: S00008823

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7381 | SPN: 4374 | FMI: 20
Aftertreatment Diesel Exhaust Fluid Pump 1 Motor Speed - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit relay voltage check
  2. Aftertreatment diesel exhaust fluid dosing unit pump motor open circuit check
  3. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short
  4. Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing unit relay voltage check

Solution: S00001015

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid dosing unit relay battery SUPPLY pin at the relay OEM wiring harness connector and ground.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit pump motor open circuit check

Solution: S00008825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit OEM wiring harness connector and the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to ground short

Solution: S00008824

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit pump motor circuit pin to pin short

Solution: S00008823

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pump motor speed SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 30-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7861 | SPN: 1172 | FMI: 10
Turbocharger 1 Compressor Intake Temperature Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Compressor intake temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005249

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 691, 692, 693

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Compressor intake temperature sensor stuck in-range

Solution: S00004923

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure/temperature sensor.

Specification

  • A malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected if the turbocharger compressor intake pressure/temperature sensor is not within the following specification of local ambient air temperature: 5.5C [10F]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7862 | SPN: 1176 | FMI: 10
Engine Turbocharger 1 Compressor Intake Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake pressure/temperature sensor is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00005250

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 741, 742, 743

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake pressure/temperature sensor is malfunctioning

Solution: S00003201

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure.
  • Compare to the local ambient air pressure.

Specification

  • If the sensor reading is not within specification, then a malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7863 | SPN: 171 | FMI: 10
Ambient Air Temperature - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. OEM ambient air temperature sensor stuck in-range
  4. Ambient air temperature sensor open circuit check
  5. Ambient air temperature sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000195

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 7864 | SPN: 1209 | FMI: 10
Exhaust Gas Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Incorrect adjustable parameter setting
  3. Exhaust gas pressure sensor stuck in-range
  4. Plugged or damaged exhaust gas pressure sensor tube
  5. Exhaust gas pressure sensor stuck in-range
  6. Exhaust gas pressure sensor voltage check
  7. Exhaust gas pressure sensor voltage check at the ECM
  8. Plugged or damaged exhaust gas pressure sensor tube
  9. Exhaust gas pressure sensor open circuit check
  10. ECM calibration revision history check
  11. Exhaust gas pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000199

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Exhaust gas pressure sensor is malfunctioning

Solution: S00003039

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning exhaust gas pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 8522 | SPN: 3720 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Snap acceleration check for excessive black smoke
  3. ECM calibration revision history check
  4. Aftertreatment DPF is malfunctioning

1 - Check for primary fault codes

Solution: S00005236

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135, 5715, 5716

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF is malfunctioning

Solution: S00006393

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then disregard this solution.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 8523 | SPN: 521240 | FMI: 31
High Sulphur Content In Fuel - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Diesel fuel used is incorrect
  3. Aftertreatment SCR System Test
  4. Aftertreatment diesel exhaust fluid dosing system test failed
  5. Aftertreatment intake NOx sensor failed
  6. Aftertreatment outlet NOx sensor - Inspection
  7. Inspect both aftertreatment NOx sensors
  8. Aftertreatment SCR Catalyst Test Failed
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008175

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 5689
  • Aftertreatment intake oxygen: 4747, 4748
  • Aftertreatment outlet oxygen: 4749, 4751
  • Aftertreatment SCR: 3142, 3143, 3144, 3146, 3147, 3148, 3165, 3229, 3231, 3235, 4152, 4159, 4164, 4166, 4261
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 1685, 1686, 1715, 3497, 3498, 3547, 3568, 3571, 3572, 3574, 3575, 3867, 3868, 4277, 4658,4677, 4739, 4768, 5278, 5864, 5865, 5935, 5936
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Aftertreatment regeneration: 2777, 3753, 4213

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Diesel fuel used is incorrect

Solution: S00007566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the incorrect diesel fuel has been used.

Specification

  • Proceed to the Repair section if fault code 8523 is active and 5655 is not active or inactive with more than one count within the last 25 engine operating hours.
  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 8523, 5655

Linked Solutions

  • None

Repair

  • Drain and fill with the correct diesel fuel for the engine configuration.
  • Replace the suction side fuel filter.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment SCR System Test

Solution: S00007402

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain and fill with the correct diesel fuel for the engine configuration.
  • Replace the suction side fuel filter.

Refer to OEM Service Manual

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 11267 | SPN: 3610 | FMI: 31
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Condition Exists

Troubleshooting Summary

  1. Aftertreatment DPF differential pressure sensor vent plugged or damaged
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor tubes plugged
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Aftertreatment DPF outlet pressure sensor open circuit check
  8. Deposits in the SCR decomposition tube
  9. Leaks in the aftertreatment diesel exhaust fluid dosing system
  10. Aftertreatment DPF outlet pressure circuit pin to ground short

1 - Aftertreatment DPF differential pressure sensor vent plugged or damaged

Solution: S00005439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment DPF differential pressure sensor from the sensor mounting bracket.
  • Inspect the aftertreatment DPF differential pressure sensor vent for signs of plugging or damage.

Refer to Procedure 019-443

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00005441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 11268 | SPN: 3610 | FMI: 14
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Special Instructions

Troubleshooting Summary

  1. Aftertreatment DPF differential pressure sensor vent plugged or damaged
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor tubes plugged
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Aftertreatment DPF outlet pressure sensor open circuit check
  8. Deposits in the SCR decomposition tube
  9. Leaks in the aftertreatment diesel exhaust fluid dosing system
  10. Aftertreatment DPF outlet pressure circuit pin to ground short

1 - Aftertreatment DPF differential pressure sensor vent plugged or damaged

Solution: S00005439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment DPF differential pressure sensor from the sensor mounting bracket.
  • Inspect the aftertreatment DPF differential pressure sensor vent for signs of plugging or damage.

Refer to Procedure 019-443

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00005426

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the aftertreatment interface wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00005428

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00005428

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF differential pressure sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00005441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the aftertreatment interface wiring harness and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 13138 | SPN: 3251 | FMI: 10
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. Aftertreatment DPF partially obstructed or plugged
  6. Snap acceleration check for excessive black smoke
  7. Stationary aftertreatment regeneration is needed

1 - Check for primary fault codes

Solution: S00007369

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 122, 123, 124, 125, 2973
  • Aftertreatment DPF: 3133, 3134, 3135, 3312, 3319, 3321, 3322, 3255, 3256, 3753, 5275, 5276, 5383, 5715
  • Aftertreatment regeneration: 2777, 3375, 3376, 4213
  • Aftertreatment DOC: 1691, 3254, 3311, 3251, 3253, 3313, 3314, 3315, 3316, 3317, 3318
  • Wheel based vehicle speed: 241
  • Exhaust gas temperature: 4151, 4152
  • Exhaust back pressure: 5271, 5272, 5273, 5274, 5275, 5276, 5277

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF partially obstructed or plugged

Solution: S00006391

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Snap acceleration check for excessive black smoke

Solution: S00000602

Verification

Conditions

  • Engine running.

Action

Verify the hood is closed for vehicles with the air intake system integrated into the hood.

  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

White smoke during deceleration does not indicate a malfunction.

  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 14671 | SPN: 5246 | FMI: 0
Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00006104

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Intake manifold temperature: 153, 154, 436
  • Barometric pressure: 295
  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Sensor supply 5: 1695, 1696
  • Turbocharger: 691, 6892, 693, 741, 742, 743
  • Aftertreatment diesel exhaust fluid system: 1682, 1714, 3574, 3575, 3596, 3878, 4234, 4243, 4732, 4745, 5278, 5935, 5936, 6486, 6765, 6766, 6767
  • Exhaust gas pressure: 2373, 22374, 2554
  • Aftertreatment NOx: 5689
  • Aftertreatment SCR: 6266

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 30-Jan-2022


NO TITLE

B6.7 CM2670 B153B

Fault Code: 14672 | SPN: 1569 | FMI: 31
Engine Protection Torque Derate - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006104

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Intake manifold temperature: 153, 154, 436
  • Barometric pressure: 295
  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Sensor supply 5: 1695, 1696
  • Turbocharger: 691, 6892, 693, 741, 742, 743
  • Aftertreatment diesel exhaust fluid system: 1682, 1714, 3574, 3575, 3596, 3878, 4234, 4243, 4732, 4745, 5278, 5935, 5936, 6486, 6765, 6766, 6767
  • Exhaust gas pressure: 2373, 22374, 2554
  • Aftertreatment NOx: 5689
  • Aftertreatment SCR: 6266

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


INDEX
576-fc111.htm

576-t06-111.htm

576-fc122.htm

576-t06-122.htm

576-fc123.htm

576-t06-123.htm

576-fc124.htm

576-t06-124.htm

576-fc125.htm

576-t06-125.htm

576-fc131.htm

576-t06-131.htm

576-fc132.htm

576-t06-132.htm

576-fc133.htm

576-t06-133.htm

576-fc134.htm

576-t06-134.htm

576-fc144.htm

576-t06-144.htm

576-fc145.htm

576-t06-145.htm

576-fc146.htm

576-t06-146.htm

576-fc151.htm

576-t06-151.htm

576-fc153.htm

576-t06-153.htm

576-fc154.htm

576-t06-154.htm

576-fc155.htm

576-t06-155.htm

576-fc187.htm

576-t06-187.htm

576-fc222.htm

576-t06-222.htm

576-fc227.htm

576-t06-227.htm

576-fc234.htm

576-t06-234.htm

576-fc238.htm

576-t06-238.htm

576-fc239.htm

576-t06-239.htm

576-fc241.htm

576-t06-241.htm

576-fc245.htm

576-t06-245.htm

576-fc249.htm

576-t06-249.htm

576-fc256.htm

576-t06-256.htm

576-fc271.htm

576-t06-271.htm

576-fc272.htm

576-t06-272.htm

576-fc285.htm

576-t06-285.htm

576-fc286.htm

576-t06-286.htm

576-fc295.htm

576-t06-295.htm

576-fc319.htm

576-t06-319.htm

576-fc322.htm

576-t06-322.htm

576-fc323.htm

576-t06-323.htm

576-fc324.htm

576-t06-324.htm

576-fc325.htm

576-t06-325.htm

576-fc331.htm

576-t06-331.htm

576-fc332.htm

576-t06-332.htm

576-fc334.htm

576-t06-334.htm

576-fc343.htm

576-t06-343.htm

576-fc351.htm

576-t06-351.htm

576-fc352.htm

576-t06-352.htm

576-fc386.htm

576-t06-386.htm

576-fc415.htm

576-t06-415.htm

576-fc418.htm

576-t06-418.htm

576-fc427.htm

576-t06-427.htm

576-fc428.htm

576-t06-428.htm

576-fc429.htm

576-t06-429.htm

576-fc435.htm

576-t06-435.htm

576-fc436.htm

576-t06-436.htm

576-fc441.htm

576-t06-441.htm

576-fc442.htm

576-t06-442.htm

576-fc451.htm

576-t06-451.htm

576-fc452.htm

576-t06-452.htm

576-fc515.htm

576-t06-515.htm

576-fc516.htm

576-t06-516.htm

576-fc553.htm

576-t06-553.htm

576-fc555.htm

576-t06-555.htm

576-fc556.htm

576-t06-556.htm

576-fc559.htm

576-t06-559.htm

576-fc584.htm

576-t06-584.htm

576-fc585.htm

576-t06-585.htm

576-fc596.htm

576-t06-596.htm

576-fc597.htm

576-t06-597.htm

576-fc598.htm

576-t06-598.htm

576-fc649.htm

576-t06-649.htm

576-fc689.htm

576-t06-689.htm

576-fc691.htm

576-t06-691.htm

576-fc692.htm

576-t06-692.htm

576-fc693.htm

576-t06-693.htm

576-fc731.htm

576-t06-731.htm

576-fc741.htm

576-t06-741.htm

576-fc742.htm

576-t06-742.htm

576-fc743.htm

576-t06-743.htm

576-fc778.htm

576-t06-778.htm

576-fc1117.htm

576-t06-1117.htm

576-fc1139.htm

576-t06-1139.htm

576-fc1141.htm

576-t06-1141.htm

576-fc1142.htm

576-t06-1142.htm

576-fc1143.htm

576-t06-1143.htm

576-fc1144.htm

576-t06-1144.htm

576-fc1145.htm

576-t06-1145.htm

576-fc1239.htm

576-t06-1239.htm

576-fc1241.htm

576-t06-1241.htm

576-fc1242.htm

576-t06-1242.htm

576-fc1668.htm

576-t06-1668.htm

576-fc1669.htm

576-t06-1669.htm

576-fc1671.htm

576-t06-1671.htm

576-fc1673.htm

576-t06-1673.htm

576-fc1677.htm

576-t06-1677.htm

576-fc1678.htm

576-t06-1678.htm

576-fc1679.htm

576-t06-1679.htm

576-fc1682.htm

576-t06-1682.htm

576-fc1685.htm

576-t06-1685.htm

576-fc1686.htm

576-t06-1686.htm

576-fc1691.htm

576-t06-1691.htm

576-fc1695.htm

576-t06-1695.htm

576-fc1696.htm

576-t06-1696.htm

576-fc1714.htm

576-t06-1714.htm

576-fc1715.htm

576-t06-1715.htm

576-fc1843.htm

576-t06-1843.htm

576-fc1844.htm

576-t06-1844.htm

576-fc1848.htm

576-t06-1848.htm

576-fc1852.htm

576-t06-1852.htm

576-fc1879.htm

576-t06-1879.htm

576-fc1881.htm

576-t06-1881.htm

576-fc1883.htm

576-t06-1883.htm

576-fc1885.htm

576-t06-1885.htm

576-fc1887.htm

576-t06-1887.htm

576-fc1921.htm

576-t06-1921.htm

576-fc1922.htm

576-t06-1922.htm

576-fc1942.htm

576-t06-1942.htm

576-fc1974.htm

576-t06-1974.htm

576-fc2182.htm

576-t06-2182.htm

576-fc2183.htm

576-t06-2183.htm

576-fc2185.htm

576-t06-2185.htm

576-fc2186.htm

576-t06-2186.htm

576-fc2321.htm

576-t06-2321.htm

576-fc2322.htm

576-t06-2322.htm

576-fc2373.htm

576-t06-2373.htm

576-fc2374.htm

576-t06-2374.htm

576-fc2377.htm

576-t06-2377.htm

576-fc2398.htm

576-t06-2398.htm

576-fc2412.htm

576-t06-2412.htm

576-fc2482.htm

576-t06-2482.htm

576-fc2554.htm

576-t06-2554.htm

576-fc2639.htm

576-t06-2639.htm

576-fc2764.htm

576-t06-2764.htm

576-fc2771.htm

576-t06-2771.htm

576-fc2777.htm

576-t06-2777.htm

576-fc2963.htm

576-t06-2963.htm

576-fc2964.htm

576-t06-2964.htm

576-fc2973.htm

576-t06-2973.htm

576-fc3133.htm

576-t06-3133.htm

576-fc3134.htm

576-t06-3134.htm

576-fc3135.htm

576-t06-3135.htm

576-fc3142.htm

576-t06-3142.htm

576-fc3143.htm

576-t06-3143.htm

576-fc3144.htm

576-t06-3144.htm

576-fc3146.htm

576-t06-3146.htm

576-fc3147.htm

576-t06-3147.htm

576-fc3148.htm

576-t06-3148.htm

576-fc3151.htm

576-t06-3151.htm

576-fc3165.htm

576-t06-3165.htm

576-fc3168.htm

576-t06-3168.htm

576-fc3229.htm

576-t06-3229.htm

576-fc3231.htm

576-t06-3231.htm

576-fc3232.htm

576-t06-3232.htm

576-fc3235.htm

576-t06-3235.htm

576-fc3243.htm

576-t06-3243.htm

576-fc3251.htm

576-t06-3251.htm

576-fc3253.htm

576-t06-3253.htm

576-fc3254.htm

576-t06-3254.htm

576-fc3255.htm

576-t06-3255.htm

576-fc3256.htm

576-t06-3256.htm

576-fc3311.htm

576-t06-3311.htm

576-fc3312.htm

576-t06-3312.htm

576-fc3313.htm

576-t06-3313.htm

576-fc3314.htm

576-t06-3314.htm

576-fc3315.htm

576-t06-3315.htm

576-fc3316.htm

576-t06-3316.htm

576-fc3317.htm

576-t06-3317.htm

576-fc3318.htm

576-t06-3318.htm

576-fc3319.htm

576-t06-3319.htm

576-fc3321.htm

576-t06-3321.htm

576-fc3322.htm

576-t06-3322.htm

576-fc3332.htm

576-t06-3332.htm

576-fc3343.htm

576-t06-3343.htm

576-fc3375.htm

576-t06-3375.htm

576-fc3376.htm

576-t06-3376.htm

576-fc3492.htm

576-t06-3492.htm

576-fc3498.htm

576-t06-3498.htm

576-fc3539.htm

576-t06-3539.htm

576-fc3541.htm

576-t06-3541.htm

576-fc3542.htm

576-t06-3542.htm

576-fc3545.htm

576-t06-3545.htm

576-fc3547.htm

576-t06-3547.htm

576-fc3558.htm

576-t06-3558.htm

576-fc3559.htm

576-t06-3559.htm

576-fc3567.htm

576-t06-3567.htm

576-fc3568.htm

576-t06-3568.htm

576-fc3571.htm

576-t06-3571.htm

576-fc3572.htm

576-t06-3572.htm

576-fc3574.htm

576-t06-3574.htm

576-fc3575.htm

576-t06-3575.htm

576-fc3583.htm

576-t06-3583.htm

576-fc3596.htm

576-t06-3596.htm

576-fc3649.htm

576-t06-3649.htm

576-fc3681.htm

576-t06-3681.htm

576-fc3682.htm

576-t06-3682.htm

576-fc3697.htm

576-t06-3697.htm

576-fc3712.htm

576-t06-3712.htm

576-fc3714.htm

576-t06-3714.htm

576-fc3717.htm

576-t06-3717.htm

576-fc3718.htm

576-t06-3718.htm

576-fc3725.htm

576-t06-3725.htm

576-fc3727.htm

576-t06-3727.htm

576-fc3737.htm

576-t06-3737.htm

576-fc3741.htm

576-t06-3741.htm

576-fc3748.htm

576-t06-3748.htm

576-fc3753.htm

576-t06-3753.htm

576-fc3868.htm

576-t06-3868.htm

576-fc3878.htm

576-t06-3878.htm

576-fc3916.htm

576-t06-3916.htm

576-fc4132.htm

576-t06-4132.htm

576-fc4133.htm

576-t06-4133.htm

576-fc4151.htm

576-t06-4151.htm

576-fc4152.htm

576-t06-4152.htm

576-fc4158.htm

576-t06-4158.htm

576-fc4159.htm

576-t06-4159.htm

576-fc4161.htm

576-t06-4161.htm

576-fc4162.htm

576-t06-4162.htm

576-fc4163.htm

576-t06-4163.htm

576-fc4164.htm

576-t06-4164.htm

576-fc4165.htm

576-t06-4165.htm

576-fc4166.htm

576-t06-4166.htm

576-fc4213.htm

576-t06-4213.htm

576-fc4233.htm

576-t06-4233.htm

576-fc4234.htm

576-t06-4234.htm

576-fc4243.htm

576-t06-4243.htm

576-fc4259.htm

576-t06-4259.htm

576-fc4261.htm

576-t06-4261.htm

576-fc4486.htm

576-t06-4486.htm

576-fc4487.htm

576-t06-4487.htm

576-fc4488.htm

576-t06-4488.htm

576-fc4489.htm

576-t06-4489.htm

576-fc4572.htm

576-t06-4572.htm

576-fc4584.htm

576-t06-4584.htm

576-fc4585.htm

576-t06-4585.htm

576-fc4658.htm

576-t06-4658.htm

576-fc4677.htm

576-t06-4677.htm

576-fc4731.htm

576-t06-4731.htm

576-fc4732.htm

576-t06-4732.htm

576-fc4737.htm

576-t06-4737.htm

576-fc4739.htm

576-t06-4739.htm

576-fc4745.htm

576-t06-4745.htm

576-fc4747.htm

576-t06-4747.htm

576-fc4748.htm

576-t06-4748.htm

576-fc4749.htm

576-t06-4749.htm

576-fc4751.htm

576-t06-4751.htm

576-fc4769.htm

576-t06-4769.htm

576-fc4843.htm

576-t06-4843.htm

576-fc4948.htm

576-t06-4948.htm

576-fc4949.htm

576-t06-4949.htm

576-fc5271.htm

576-t06-5271.htm

576-fc5272.htm

576-t06-5272.htm

576-fc5273.htm

576-t06-5273.htm

576-fc5274.htm

576-t06-5274.htm

576-fc5275.htm

576-t06-5275.htm

576-fc5276.htm

576-t06-5276.htm

576-fc5277.htm

576-t06-5277.htm

576-fc5278.htm

576-t06-5278.htm

576-fc5576.htm

576-t06-5576.htm

576-fc5655.htm

576-t06-5655.htm

576-fc5689.htm

576-t06-5689.htm

576-fc5715.htm

576-t06-5715.htm

576-fc5716.htm

576-t06-5716.htm

576-fc5864.htm

576-t06-5864.htm

576-fc5865.htm

576-t06-5865.htm

576-fc5879.htm

576-t06-5879.htm

576-fc5881.htm

576-t06-5881.htm

576-fc5935.htm

576-t06-5935.htm

576-fc5936.htm

576-t06-5936.htm

576-fc5986.htm

576-t06-5986.htm

576-fc6127.htm

576-t06-6127.htm

576-fc6266.htm

576-t06-6266.htm

576-fc6338.htm

576-t06-6338.htm

576-fc6485.htm

576-t06-6485.htm

576-fc6486.htm

576-t06-6486.htm

576-fc6595.htm

576-t06-6595.htm

576-fc6712.htm

576-t06-6712.htm

576-fc6713.htm

576-t06-6713.htm

576-fc6765.htm

576-t06-6765.htm

576-fc6766.htm

576-t06-6766.htm

576-fc6767.htm

576-t06-6767.htm

576-fc6771.htm

576-t06-6771.htm

576-fc6786.htm

576-t06-6786.htm

576-fc7325.htm

576-t06-7325.htm

576-fc7381.htm

576-t06-7381.htm

576-fc7861.htm

576-t06-7861.htm

576-fc7862.htm

576-t06-7862.htm

576-fc7863.htm

576-t06-7863.htm

576-fc7864.htm

576-t06-7864.htm

576-fc8522.htm

576-t06-8522.htm

576-fc8523.htm

576-t06-8523.htm

576-fc11267.htm

576-t06-11267.htm

576-fc11268.htm

576-t06-11268.htm

576-fc13138.htm

576-t06-13138.htm

576-fc14671.htm

576-t06-14671.htm

576-fc14672.htm

576-t06-14672.htm