QSG12 CM2880 G112

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111.

Last Modified: 30-May-2017
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect. The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code 115.

Last Modified: 30-May-2017


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 122.

Last Modified: 30-May-2017


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 123.

Last Modified: 30-May-2017


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it will be necessary to operate the engine under load in order to get the intake manifold pressure high enough for the diagnostic to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault are:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • A damaged intake manifold pressure sensor
  • Restriction in the charge-air cooler

Restriction in the exhaust system

Restriction in the air filter

  • Malfunctioning turbocharger wastegate
Refer to Troubleshooting Fault Code 125.

Last Modified: 30-May-2017


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 30-May-2017


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 30-May-2017


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine power derate.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 30-May-2017


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 30-May-2017


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 30-May-2017


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 108°C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates the engine coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 146.

Last Modified: 30-May-2017


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 113°C [ 235°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 30-May-2017


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 30-May-2017


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 30-May-2017


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 30-May-2017


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code 187.

Last Modified: 30-May-2017


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 195.

Last Modified: 30-May-2017


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open signal circuit in the OEM harness, connectors, or sensor

Signal circuit shorted to ground in the OEM harness, connector, or sensor

  • Damaged sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 196.

Last Modified: 30-May-2017


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 197.

Last Modified: 30-May-2017


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 212.

Last Modified: 30-May-2017


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 213.

Last Modified: 30-May-2017


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Engine power derate.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code t05-214

Last Modified: 30-May-2017


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is internal to the ECM and cannot be service separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 221.

Last Modified: 30-May-2017


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is internal to the ECM and cannot be service separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 222.

Last Modified: 30-May-2017


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 30-May-2017


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 30-May-2017


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Engine power derate.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
Refer to Troubleshooting Fault Code 235.

Last Modified: 30-May-2017


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 30-May-2017


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 30-May-2017


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage is detected at the fuel pump actuator circuit. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit PWM signal is NOT detected to be system voltage when the PWM signal is turned on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fuel rail pressure will be higher than the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the short circuit condition is or was intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 30-May-2017


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272.

Last Modified: 30-May-2017


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up to receive information from an OEM device, but the OEM device is not be transmitting the message for that component. Or when a multiplexed component is enabled in the Cummins® ECM, but the source address of the OEM device transmitting the component message is incorrect in the Cummins® ECM.

  • This fault can also be caused by a damaged J1939 data link connection between the OEM ECU and Cummins® ECM, a damaged connection between the component and the OEM ECU, damaged OEM ECU or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 30-May-2017


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM ECU source addressed correctly) to receive information from an OEM ECU, but the OEM ECU is transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 286.

Last Modified: 30-May-2017


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 322.

Last Modified: 30-May-2017


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 323.

Last Modified: 30-May-2017


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

•Open circuit in the engine harness(es) or injector solenoid

•High resistance in a single injector or injector solenoid

• Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

• Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 324.

Last Modified: 31-May-2017


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 325.

Last Modified: 30-May-2017


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuits

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 331.

Last Modified: 30-May-2017


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid. When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever. An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.
Refer to Troubleshooting Fault Code 332.

Last Modified: 30-May-2017


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm, the primary engine speed sensor signal is present, and the battery charge is above a minimum threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 30-May-2017


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time of alert.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code 415.

Last Modified: 30-May-2017


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | Possible loss of power, or hard starting.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 30-May-2017


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Engine power derate.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

  • This fault code may be inactive when the equipment brought in for service. Even if inactive, follow the troubleshooting tree completely.
Refer to Troubleshooting Fault Code 421.

Last Modified: 30-May-2017


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | SAE J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the ECM and another device on the SAE J1939 data link has been lost. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits

Intermittent J1939 data link connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code 426.

Last Modified: 30-May-2017


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Open RETURN or SIGNAL circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428.

Last Modified: 30-May-2017


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 429.

Last Modified: 30-May-2017


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 30-May-2017


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 30-May-2017


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P157 SPN: 157 FMI: 0/0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • High drain line restriction (high drain line pressure)
  • A malfunctioning fuel rail pressure sensor
  • A malfunctioning fuel rail actuator.
Refer to Troubleshooting Fault Code 449.

Last Modified: 30-May-2017


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 30-May-2017


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The fuel delivery pressure sensor responds to pressure changes in the fuel rail. The fuel delivery pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The electronic control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor, using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the fuel rail. The ECM will detect a low signal voltage at high rail pressures. The ECM will detect a high signal voltage during low rail pressure conditions.

Component Location

The fuel pressure sensor is installed in the fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 30-May-2017


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Engine power derate.
Intake Manifold Temperature / Pressure Sensor

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control. The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature SIGNAL circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged charge-air cooler fins
  • Restricted air flow through the charge-air cooler

Undersized charge-air cooler

  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488.

Last Modified: 30-May-2017


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553.

Last Modified: 30-May-2017


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was less than the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Before servicing any fuel system components, (such as fuel lines, fuel pump, injectors, etc.) which would expose the fuel system or internal engine component to potential contaminants prior to disassembly, clean the fittings, mounting hardware, and the area around the component to be removed. Dirt or contaminants can be introduced into the fuel system and engine if the surrounding areas are not cleaned, resulting in damage to the fuel system and engine.

When Fault Code 559 occurs, the fuel system has lost its ability to maintain rail fuel pressure.

Causes of this fault include:

Fuel inlet restrictions

Fuel filter plugging

  • Fuel gear pump output low

Fuel gear pump pressure actuator sticking or leaking

High pressure pump capacity decay (high leakage to drain from the high-pressure pump)

Fuel rail pressure relief valve leaks to drain

Fuel rail pressure relief valve opens at too low a pressure

Injector fuel circuit leaks to drain

Refer to Troubleshooting Fault Code 559.

Last Modified: 30-May-2017


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Use the INSITE electronic service tool to reset the Maintenance Monitor feature.

  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 30-May-2017


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 30-May-2017


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • ECM malfunction.
Refer to Troubleshooting Fault Code 697.

Last Modified: 30-May-2017


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • ECM malfunction.
Refer to Troubleshooting Fault Code 698.

Last Modified: 30-May-2017


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 731.

Last Modified: 30-May-2017


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 778.

Last Modified: 30-May-2017


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Engine power derate.
Engine Control Module

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Before troubleshooting fault code 1117,make sure battery post connections, engine block and chassis grounds are properly connected, tightened, and free of corrosion.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 30-May-2017


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: S151 SPN: 4182 FMI: 3/3 LAMP: Amber SRT: | Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The frequency adjust potentiometer will go to the default value.
Frequency Adjust Circuit

Circuit Description

The frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the frequency. An external parallel/load share controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage

Refer to Troubleshooting Fault Code 1411.

Last Modified: 30-May-2017


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: S151 SPN: 4183 FMI: 3/3 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The droop adjust potentiometer will go to the default value.
Droop Adjust Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage
Refer to Troubleshooting Fault Code 1412.

Last Modified: 30-May-2017


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: S151 SPN: 4184 FMI: 3/3 LAMP: Amber SRT: | Gain adjust potentiometer signal is shorted high. | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
Gain Adjust Circuit

Circuit Description

The gain adjust potentiometer is so the operator can adjust the amplification of the difference in the value between the "desired speed" and the "actual speed" of the engine, so that the governor can respond to engine speed fluctuations. The difference between the "desired speed" and the "actual speed" is called the error signal. When the gain is increased, the error signal amplification is increased, more corrective action is taken by the governor, and its response is quicker. When the gain is reduced, the error signal amplification is reduced, less corrective action is taken by the governor, and its response is slower. If the gain is set too high, the governor can over correct the speed error signal, which will lead to engine speed surging or "hunting". The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will activate Fault Code 1418 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Gain adjust circuit is shorted high

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to sensor supply or battery voltage.
  • Open return circuit in the harness, connectors, or sensor
Refer to Troubleshooting Fault Code 1418.

Last Modified: 30-May-2017


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 30-May-2017


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 30-May-2017


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature signal indicates engine coolant temperature is above the engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine will only idle or will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • Malfunctioning coolant temperature sensor

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS

Refer to Troubleshooting Fault Code 1847.

Last Modified: 30-May-2017


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water in Fuel Indicator indicates that the water level is above warning level. | Possible reduced engine performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 30-May-2017


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3/3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. | Engine will not synchronize with the grid if connected.
Speed Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1978.

Last Modified: 30-May-2017


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4/4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize with the grid if connected.
Speed Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1979.

Last Modified: 30-May-2017


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit. | Engine will shut down.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

Gain adjust setting is not set correctly

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 1992.

Last Modified: 30-May-2017


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Possible reduced engine performance.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 4 originates in the OEM connector portion of the ECM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 30-May-2017


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Possible reduced engine performance.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 4 originates in the OEM connector portion of the ECM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 30-May-2017


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | Possible reduced engine performance.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit had an intermittent circuit concern, or the fuel pump actuator resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 2311.

Last Modified: 30-May-2017


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit.
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket.
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.
  • Look for pin wear at the speed sensor.
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code 2321.

Last Modified: 30-May-2017


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2/2 LAMP: None SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code 2322.

Last Modified: 30-May-2017


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448.

Last Modified: 30-May-2017


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 11/31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowledged severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM). Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2661.

Last Modified: 30-May-2017


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 11/31 LAMP: Amber SRT: | At Least One Unacknowledged Moderately Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowleged moderately severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM). Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2662.

Last Modified: 30-May-2017


Engine Injector Bank 1 Barcodes - Out of Calibration

FAULT CODE 2765

Engine Injector Bank 1 Barcodes - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2765 PID: S392 SPN: 2797 FMI: 13/13 LAMP: None SRT: | Engine Injector Bank 1 Barcodes - Out of Calibration. Invalid injector barcode information has been entered, or has not been entered at all. | None on performance.
Engine Control Module

Circuit Description

Each fuel injector has a specific barcode. This barcode data contains information specific to each individual injector. The ECM uses this information to adjust fueling and allow the engine to run more smoothly.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode values have not been programmed or were programmed incorrectly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2765.

Last Modified: 30-May-2017


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine protection warning limit. | Engine power derate.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 104°C [ 220°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 30-May-2017


Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3694

Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3694 PID: S151 SPN: 4184 FMI: 4/4 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
Gain Adjust Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3694.

Last Modified: 30-May-2017


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3695

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3695 PID: S151 SPN: 4182 FMI: 4/4 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The generator output frequency adjust potentiometer will go to the default value.
Frequency Adjust Circuit

Circuit Description

The frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the frequency. An external parallel/load share controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 3695 goes active, the generator output frequency adjust potentiometer will not respond.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3695.

Last Modified: 30-May-2017


Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3696

Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3696 PID: S151 SPN: 4183 FMI: 4/4 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The droop adjust potentiometer will go to the default value.
Droop Adjust Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3696.

Last Modified: 30-May-2017


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 3697.

Last Modified: 30-May-2017


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: S115 SPN: 1675 FMI: 11/31 LAMP: None SRT: | Engine Starter Mode Overcrank Protection - Condition Exists. The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Control Module

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

  • The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737.

Last Modified: 30-May-2017


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3741

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3741 PID: SPN: 5571 FMI: 0/0 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Data valid but above normal operational range - Most Severe Level. The fuel rail pressure relief valve has opened due to high fuel rail pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure had exceeded the fuel pressure relief valve opening pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel drain line restriction

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve.

  • Air in the fuel
Refer to Troubleshooting Fault Code 3741.

Last Modified: 30-May-2017


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0/0 LAMP: Red SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level. Water has been detected in the fuel. | Engine power derate.
Water In Fuel Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is located in the fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 4642.

Last Modified: 30-May-2017


Tachograph Output Shaft Speed - Out of Calibration

FAULT CODE 5248

Tachograph Output Shaft Speed - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5248 PID: SPN: 1623 FMI: 13/13 LAMP: Amber SRT: | Tachograph Output Shaft Speed - Out of Calibration - The received datalink message was not valid. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the tachograph output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor.

Refer to Troubleshooting Fault Code 5248.

Last Modified: 30-May-2017


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Mar-2017


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G113 | 5467252
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2250 B131 | 4388774
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 B137 | 5411058
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G113 | 5467252
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSB4.5 CM2250 B131 | 4388774
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 B137 | 5411058
Injector | Refer to Procedure 006-026 | QSX15 CM2250 X115 | 4388739
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G110 | 4367323
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G113 | 5467252
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB4.5 CM2250 B131 | 4388774
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 B137 | 5411058
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 X115 | 4388739
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Did the fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness,and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2017


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G113 | 5467252
rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G113 | 5467252
Injector | Refer to Procedure 006-026 | QSX15 CM2250 X115 | 4388739
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L156 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G110 | 4367323
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G113 | 5467252
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 X115 | 4388739
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank.Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure Refer to Prcedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Oct-2017


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G113 | 5467252
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2250 B131 | 4388774
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 B137 | 5411058
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G113 | 5467252
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSX15 CM2250 X115 | 4388739
Injector | Refer to Procedure 006-026 | QSB4.5 CM2250 B131 | 4388774
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 B137 | 5411058
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G110 | 4367323
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G113 | 5467252
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 X115 | 4388739
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB4.5 CM2250 B131 | 4388774
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 B137 | 5411058
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC: Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250: Refer to Procedure in 003-011 in the Associated Procedures Table.

For QSB6.7 CM2250 B128 and QSL9 CM2250 L115 engines: Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.
  • For QSB6.7 CM2250 B128 and QSL9 CM2250 L115 engines: Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank.Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 17-Oct-2017


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2350 L107 | 4367386
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G113 | 5467252
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSL9 CM2350 L107 | 4367386
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G113 | 5467252
Injector | Refer to Procedure 006-026 | QSX15 CM2250 X115 | 4388739
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2350 L107 | 4367386
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G110 | 4367323
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G113 | 5467252
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 X115 | 4388739
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank.Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 20-Oct-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2250 B131 | 4388774
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 B137 | 5411058
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 X115 | 4388739
Rocker Lever Cover | Refer to Procedure 003-011 | QSF3.8 CM2350 F125 | 5411494
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSB4.5 CM2250 B131 | 4388774
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 B137 | 5411058
Injector | Refer to Procedure 006-026 | QSX15 CM2250 X115 | 4388739
Injector | Refer to Procedure 006-026 | QSF3.8 CM2350 F125 | 5411494
Injector | Refer to Procedure 006-026 | QSF2.8 CM2880 F124 | 5411484
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB4.5 CM2250 B131 | 4388774
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 B137 | 5411058
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 X115 | 4388739
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSF3.8 CM2350 F125 | 5411494
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injctor harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank.Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 1. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 1.
  • Disconnect the injector wiring harness from injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 2. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 2.
  • Disconnect the injector wiring harness from injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 3. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 16-Oct-2017


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Rocker Lever Cover | Refer to Procedure 003-011 | Marine QSB6.7 CM2250 | 4310611
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 | 4022256
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 | 4022255
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 EC | 2883621
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 EC | 2883647
Rocker Lever Cover | Refer to Procedure 003-011 | QSX11.9 CM2250 ECF | 2883561
Rocker Lever Cover | Refer to Procedure 003-011 | QSX15 CM2250 ECF | 2883557
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 ECF | 4310661
Rocker Lever Cover | Refer to Procedure 003-011 | PowerGen QSX15 CM2250 | 4310664
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 M CM2250 L106 | 4358343
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2350 G110 | 4367323
Rocker Lever Cover | Refer to Procedure 003-011 | QSB6.7 CM2250 B128 | 4388601
Rocker Lever Cover | Refer to Procedure 003-011 | QSL9 CM2250 L115 | 4388626
Rocker Lever Cover | Refer to Procedure 003-011 | QSB4.5 CM2250 B131 | 4388774
Rocker Lever Cover | Refer to Procedure 003-011 | QSB3.3 CM2250 B137 | 5411058
Rocker Lever Cover | Refer to Procedure 003-011 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | Marine QSB6.7 CM2250 | 4310611
Injector | Refer to Procedure 006-026 | QSL9 CM2250 | 4022256
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 | 4022255
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 EC | 2883621
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 EC | 2883647
Injector | Refer to Procedure 006-026 | QSX11.9 CM2250 ECF | 2883561
Injector | Refer to Procedure 006-026 | QSX15 CM2250 ECF | 2883557
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 ECF | 4310661
Injector | Refer to Procedure 006-026 | PowerGen QSX15 CM2250 | 4310664
Injector | Refer to Procedure 006-026 | QSL9 M CM2250 L106 | 4358343
Injector | Refer to Procedure 006-026 | QSG12 CM2350 G110 | 4367323
Injector | Refer to Procedure 006-026 | QSB6.7 CM2250 B128 | 4388601
Injector | Refer to Procedure 006-026 | QSL9 CM2250 L115 | 4388626
Injector | Refer to Procedure 006-026 | QSB4.5 CM2250 B131 | 4388774
Injector | Refer to Procedure 006-026 | QSB3.3 CM2250 B137 | 5411058
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 | 4022256
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 EC | 2883647
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX11.9 CM2250 ECF | 2883561
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSX15 CM2250 ECF | 2883557
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 ECF | 4310661
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | PowerGen QSX15 CM2250 | 4310664
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 M CM2250 L106 | 4358343
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2350 G110 | 4367323
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSL9 CM2250 L115 | 4388626
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB4.5 CM2250 B131 | 4388774
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSB3.3 CM2250 B137 | 5411058
Internal Actuator Wiring Harness | Refer to Procedure 019-063 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for short circuits. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.
  • Injector harness.

For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.

For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the injector harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the injector harness.

  • For QSX, QSL, and QSB3.3 CM2250 EC. Refer to Procedure in 019-063 in the Associated Procedures Table.
  • For QSB6.7 CM2250. Refer to Procedure in 003-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the harness

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Assoicated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn the keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Turn the keyswitch ON.
  • Start and idle the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault code follow the injector?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely (so that the engine may run at idle).
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank Fault Codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Disconnect the injector wiring harness from injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 4. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 4.
  • Disconnect the injector wiring harness from injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Replace injector number 5. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Refer to Procedure 003-011 in the Associated Procedures Table.
  • Connect the injector wiring harness to injector number 5.
  • Disconnect the injector wiring harness from injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Place tape on the ends of the injector wiring harness to make sure the harness end do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • 1. Use INSITE™ electronic service tool to clear the fault codes.
  • 2. Start the engine and let it idle for 1 minute.
  • 3. Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace injector number 6. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 16-Oct-2017


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V014 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Nov-2017


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
YES NO

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal, in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to fin the present ECM code and revison number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found the the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 16-Oct-2017


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2015


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 | ISZ13 CM2150 | 4022133
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | ISB/ISD4.5 CM2150 B119 | 4358465
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2150 B120 | 4358470
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 L110 | 4358475
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F110 | 4358480
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | ISB5.9 CM2880 B110 | 4332883
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F132B | 5467327

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 2448 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Nov-2017


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive red lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code? | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive red lamp fault codes?
YES NO

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other red lamp fault codes.

Once all other red lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 25-Apr-2014


FAULT CODE 2662 - At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive amber lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive amber lamp fault codes?
YES NO

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other amber lamp fault codes.

Once all other amber lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Apr-2014


FAULT CODE 2765 - Engine Injector Bank 1 Barcodes - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2765 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2765.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2765 active?
YES NO

The injector barcode adjustable parameters are not correct in INSITE™ electronic service tool.

Remove the rocker lever cover and record the barcode information.

Use INSITE™ electronic service tool to correctly enter the injector barcode parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2015


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GX15 CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F132B | 5467327
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | R2.8 CM2220 R101B | 5467556
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B110 | 4332883

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature. |
 | STEP 1A. Monitor coolant temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature.

Guided Step 1A - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Nov-2017


FAULT CODE 4642 - Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Mar-2015


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 115. | Active or inactive counts of Fault Code 115?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 115.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 115?
YES NO

Swap the engine position sensor connectors.

 No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Feb-2014


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 VOLT SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 VOLT SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.7 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9.5 CM2150 SN | 4310608
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB3.9 CM2220 B107 | 4310792
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2150 B108 | 4326163
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2150 B109 | 4326168
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G106 | 4332695
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G107 | 4332690
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG11 CM2880 G108 | 4332901
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISG12 CM2880 G109 | 4332906
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2880 L112 | 4358493
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSNT14 CM876 N102 | 4325993
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB5.9 CM2880 B127 | 4383645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9.3 CM2880 L113 | 4383811
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSC8.3 CM2880 C102 | 4388785
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB5.9 CM2880 B139 | 4388870
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.9 CM2880 B138 | 5411050
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISD6.7 CM2880 D101 | 5411372
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VOLT SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 VOLT SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High troubleshooting symptom tree in Section TS in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Aug-2014


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal in Section TS, in the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2150 SN | 4310608
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB7 CM2880 B117 | 4358390
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSNT14 CM876 N102 | 4325993
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G108 | 4332901
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G109 | 4332906
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4358493
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F104 | 4332741
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F108 | 4332746
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2880 F112 | 4383825
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9.3 CM2880 L113 | 4383811
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSC8.3 CM2880 C102 | 4388785
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB5.9 CM2880 B139 | 4388870
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.9 CM2880 B138 | 5411050
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISD6.7 CM2880 D101 | 5411372
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

  • For the ISG11 CM2880 G106, ISG12 CM2880 G107, and QSNT14 CM876 N102 engines: Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9.5 CM2150 SN | 4310608
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB3.9 CM2220 B107 | 4310792
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2150 B108 | 4326163
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2150 B109 | 4326168
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB7 CM2880 B117 | 4358390
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G106 | 4332695
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G107 | 4332690
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSNT14 CM876 N102 | 4325993
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG11 CM2880 G108 | 4332901
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISG12 CM2880 G109 | 4332906
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2880 L112 | 4358493
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F104 | 4332741
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F108 | 4332746
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F112 | 4383825
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B127 | 4383645
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2880 B126 | 4383693
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F116 | 4383664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9.3 CM2880 L113 | 4383811
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSC8.3 CM2880 C102 | 4388785
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB5.9 CM2880 B139 | 4388870
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.9 CM2880 B138 | 5411050
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISD6.7 CM2880 D101 | 5411372
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F129 | 5411325
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF4.5 CM2220 F123 | 5411320
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manfiold air temperature reading. |
 | STEP 1A. Monitor intake manfiold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manfiold air temperature reading.

Guided Step 1A - Monitor intake manfiold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS, in the appropriate service manual.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB7 CM2880 B117 | 4358390
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G106 | 4332695
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G107 | 4332690
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G108 | 4332901
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G109 | 4332906
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F104 QSF2.8 CM2882 F108 | 4332741 4332746
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB4.5 CM2150 B108 | 4326163
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB6.7 CM2150 B109 | 4326168
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSB7 CM2880 B117 | 4358390
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G106 | 4332695
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G107 | 4332690
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG11 CM2880 G108 | 4332901
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISG12 CM2880 G109 | 4332906
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F108 | 4332741 4332746
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISF2.8 CM2220 F129 | 5411325
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISL9.5 CM2150 SN | 4310608
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G106 | 4332695
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G107 | 4332690
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G108 | 4332901
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G109 | 4332906
Cooling System | Refer to Procedure 008-018 | QSNT14 CM876 N102 | 4325993
Cooling System | Refer to Procedure 008-018 | QSB7 CM2880 B117 | 4358390
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F104 | 4332741
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F108 | 4332746
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2880 B126 | 4383693
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2880 F112 | 4383825
Cooling System | Refer to Procedure 008-018 | QSL9.3 CM2880 L113 | 4383811
Cooling System | Refer to Procedure 008-018 | QSC8.3 CM2880 C102 | 4388785
Cooling System | Refer to Procedure 008-018 | QSB5.9 CM2880 B139 | 4388870
Cooling System | Refer to Procedure 008-018 | QSB3.9 CM2880 B138 | 5411050
Cooling System | Refer to Procedure 008-018 | ISD6.7 CM2880 D101 | 5411372
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F129 | 5411325
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

Reference the Coolant Loss troubleshooting symptom tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likley cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG11 CM2880 G106 | 4332695
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG12 CM2880 G107 | 4332690
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG11 CM2880 G108 | 4332901
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG12 CM2880 G109 | 4332906
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG11 CM2880 G106 | 4332695
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG12 CM2880 G107 | 4332690
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG11 CM2880 G108 | 4332901
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISG12 CM2880 G109 | 4332906
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 213 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure Repair or replace the engine harness. 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct revolutions per minute (rpm) reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring downhill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to the engine tachometer red area.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct revolutions per minute (rpm) reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above high idle speed.

–

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G106 | 4332695
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G107 | 4332690
Cooling System | Refer to Procedure 008-018 | ISG11 CM2880 G108 | 4332901
Cooling System | Refer to Procedure 008-018 | ISG12 CM2880 G109 | 4332906
Cooling System | Refer to Procedure 008-018 | QSB7 CM2880 B117 | 4358390
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F104 | 4332741
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F108 | 4332764
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2880 F112 | 4383825
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSL9.3 CM2880 L113 | 4383811
Cooling System | Refer to Procedure 008-018 | QSC8.3 CM2880 C102 | 4388785
Cooling System | Refer to Procedure 008-018 | QSB5.9 CM2880 B139 | 4388870
Cooling System | Refer to Procedure 008-018 | QSB3.9 CM2880 B138 | 5411050
Cooling System | Refer to Procedure 008-018 | ISD6.7 CM2880 D101 | 5411372
Cooling System | Refer to Procedure 008-018 | ISF2.8 CM2220 F129 | 5411325
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 l113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 l113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2150 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 l113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 271 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2280 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2280 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2280 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2280 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB3.9 CM2220 B107 | 4310792
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2150 B108 | 4326163
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2150 B109 | 4326168
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB7 CM2880 B117 | 4358390
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G106 | 4332695
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G107 | 4332690
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G108 | 4332901
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G109 | 4332906
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2280 F104 | 4332741
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2280 F108 | 4332746
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2880 F112 | 4383825
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9.3 CM2880 L113 | 4383811
Fuel Pump Actuator | Refer to Procedure 019-117 | ISD6.7 CM2880 D101 | 5411372
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F129 | 5411325
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 is active and Fault Code 271 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 3C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 is inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 is active and Fault Code 271 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 271 is inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been be detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL9.5 CM2150 SN | 4310608
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB4.5 CM2150 B108 | 4326163
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB6.7 CM2150 B109 | 4326168
Fuel Pump Actuator | Refer to Procedure 019-117 | QSB7 CM2880 B117 | 4358390
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G106 | 4332695
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G107 | 4332690
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG11 CM2880 G108 | 4332901
Fuel Pump Actuator | Refer to Procedure 019-117 | ISG12 CM2880 G109 | 4332906
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F104 | 4332741
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF2.8 CM2880 F108 | 4332746
Fuel Pump Actuator | Refer to Procedure 019-117 | ISL8.9 CM2880 L112 | 4358493
Fuel Pump Actuator | Refer to Procedure 019-117 | QSF3.8 CM2880 F112 | 4383825
Fuel Pump Actuator | Refer to Procedure 019-117 | QSL9.3 CM2880 L113 | 4383811
Fuel Pump Actuator | Refer to Procedure 019-117 | ISB/ISD6.7 CM2880 B126 | 4383693
Fuel Pump Actuator | Refer to Procedure 019-117 | ISD6.7 CM2880 D101 | 5411372
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF2.8 CM2220 F129 | 5411325
Fuel Pump Actuator | Refer to Procedure 019-117 | ISF4.5 CM2220 F123 | 5411320
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 2C. Check the fault codes and verify fuel pump actuator condition. | Fault Code 272 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the engine harness and actuator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the fuel pump actuator connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify fuel pump actuator condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN at the ECM engine connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.
  • Measure the resistance between the fuel pump actuator RETURN pin at the ECM connector of the engine harness and the fuel pump actuator RETURN pin at the fuel pump actuator connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short circuit on one connector.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4363825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 0 ohms and 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 is active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine electronic control module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the multiplexing configuration.

Check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Note: Use the following for OEM specific multiplexing configuration information. Refer to Multiplexing Troubleshooting, Bulletin 4021378.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2013


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2200 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSB2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2200 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Operate the engine. | Will the engine start?
 | STEP 1C. Read the fault codes. | Fault Code 351 active?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Troubleshoot Fault Code 441 first.

 No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Operate the engine.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Operate the engine.

Will the engine start?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 active?
YES NO

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

 No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Inspect the ECM power supply and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the battery terminals.
  • Disconnect the ECM power supply harness from the ECM connector.

Action

Check for an open circuit in the ECM ground circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Clean the battery terminal connections. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A marginal battery voltage condition is possible. Make sure the batteries are fully charged or replace, if needed.

It is likely that a marginal battery condition will result in Fault Code 351 becoming active at engine cranking.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Refer to Lubricating Oil Pressure Low symptom tree in the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Feb-2013


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active?
 | STEP 1B. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-May-2016


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Dec-2013


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water-in-Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325
Water-in-Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms (MΩ)?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms (MΩ)?
YES NO

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the ECM engine connector.

Refer to the circuit or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSNT14 CM876 N102 | 4325993
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2150 B108 | 4326163
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2150 B109 | 4326168
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB7 CM2880 B117 | 4358390
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB3.9 CM2220 B107 | 4310792
Water in Fuel Sensor | Refer to Procedure 019-127 | QSNT14 CM876 N102 | 4325993
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G106 | 4332695
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G107 | 4332690
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG11 CM2880 G108 | 4332901
Water in Fuel Sensor | Refer to Procedure 019-127 | ISG12 CM2880 G109 | 4332906
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F104 | 4332741
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F108 | 4332746
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2880 L112 | 4358493
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2880 B126 | 4383693
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB5.9 CM2880 B127 | 4383645
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F116 | 4383664
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F129 | 5411325
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the Water in Fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Water in Fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Water in Fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the Water in Fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the Water in Fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Water in Fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the Water in Fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly.

Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse.

Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery voltage. | Less than +20 VDC for 12 volt system and less than +32 VDC for 24 volt system?
 | STEP 2B. Check the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than +20 VDC for 12 volt system

Less than +32 VDC for 24 volt system?
YES NO
No Repair

Install the battery system correctly. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Jun-2014


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB3.9 CM2220 B107 | 4310792
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G106 | 4332695
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G107 | 4332690
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G108 | 4332901
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G109 | 4332906
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2880 L112 | 4358493
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F129 | 5411325
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9.5 CM2150 SN | 4310608
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G106 | 4332695
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G107 | 4332690
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG11 CM2880 G108 | 4332901
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISG12 CM2880 G109 | 4332906
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2880 L112 | 4358493
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2880 F112 | 4383825
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9.3 CM2880 L113 | 4383811
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISD6.7 CM2880 D101 | 5411372
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F129 | 5411325
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jun-2014


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2150 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSNT14 CM876 N102 | 4325993
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2150 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2150 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 to 5.25-VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-365 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | ISL9.5 CM2150 SN | 4310608
Camshaft | Refer to Procedure 001-008 | ISB3.9 CM2220 B107 | 4310792
Camshaft | Refer to Procedure 001-008 | QSB4.5 CM2120 B108 | 4326163
Camshaft | Refer to Procedure 001-008 | QSB6.7 CM2150 B109 | 4326168
Camshaft | Refer to Procedure 001-008 | ISL8.9 CM2880 L112 | 4358493
Camshaft | Refer to Procedure 001-008 | ISB5.9 CM2880 B127 | 4383645
Camshaft | Refer to Procedure 001-008 | QSF3.8 CM2880 F112 | 4383825
Camshaft | Refer to Procedure 001-008 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft | Refer to Procedure 001-008 | QSL9.3 CM2880 L113 | 4383811
Camshaft | Refer to Procedure 001-008 | QSC8.3 CM2880 C102 | 4388785
Camshaft | Refer to Procedure 001-008 | QSB3.9 CM2880 B138 | 5411050
Camshaft | Refer to Procedure 001-008 | QSB5.9 CM2880 B139 | 4388870
Camshaft | Refer to Procedure 001-008 | ISD6.7 CM2880 D101 | 5411372
Camshaft | Refer to Procedure 001-008 | ISF4.5 CM2220 F123 | 5411320
Crankshaft | Refer to Procedure 001-016 | ISL9.5 CM2150 SN | 4310608
Crankshaft | Refer to Procedure 001-016 | ISB3.9 CM2220 B107 | 4310792
Crankshaft | Refer to Procedure 001-016 | QSB4.5 CM2120 B108 | 4326163
Crankshaft | Refer to Procedure 001-016 | QSB6.7 CM2150 B109 | 4326168
Crankshaft | Refer to Procedure 001-016 | ISG11 CM2880 G106 | 4332695
Crankshaft | Refer to Procedure 001-016 | ISG12 CM2880 G107 | 4332690
Crankshaft | Refer to Procedure 001-016 | ISG11 CM2880 G108 | 4332901
Crankshaft | Refer to Procedure 001-016 | ISG12 CM2880 G109 | 4332906
Crankshaft | Refer to Procedure 001-016 | ISL8.9 CM2880 L112 | 4358493
Crankshaft | Refer to Procedure 001-016 | ISB5.9 CM2880 B127 | 4383645
Crankshaft | Refer to Procedure 001-016 | QSF3.8 CM2880 F112 | 4383825
Crankshaft | Refer to Procedure 001-016 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft | Refer to Procedure 001-016 | QSL9.3 CM2880 L113 | 4383811
Crankshaft | Refer to Procedure 001-016 | QSC8.3 CM2880 C102 | 4388785
Crankshaft | Refer to Procedure 001-016 | QSB3.9 CM2880 B138 | 5411050
Crankshaft | Refer to Procedure 001-016 | QSB5.9 CM2880 B139 | 4388870
Crankshaft | Refer to Procedure 001-016 | ISD6.7 CM2880 D101 | 5411372
Crankshaft | Refer to Procedure 001-016 | ISF4.5 CM2220 F123 | 5411320
Crankshaft | Refer to Procedure 001-016 | QSG12 CM2880 G112 | 4388731
Gear Cover, Front | Refer to Procedure 001-031 | ISL9.5 CM2150 SN | 4310608
Gear Cover, Front | Refer to Procedure 001-031 | ISB3.9 CM2220 B107 | 4310792
Gear Cover, Front | Refer to Procedure 001-031 | QSB4.5 CM2120 B108 | 4326163
Gear Cover, Front | Refer to Procedure 001-031 | QSB6.7 CM2150 B109 | 4326168
Gear Cover, Front | Refer to Procedure 001-031 | ISG11 CM2880 G106 | 4332695
Gear Cover, Front | Refer to Procedure 001-031 | ISG12 CM2880 G107 | 4332690
Gear Cover, Front | Refer to Procedure 001-031 | ISG11 CM2880 G108 | 4332901
Gear Cover, Front | Refer to Procedure 001-031 | ISG12 CM2880 G109 | 4332906
Gear Cover, Front | Refer to Procedure 001-031 | ISL8.9 CM2880 L112 | 4358493
Gear Cover, Front | Refer to Procedure 001-031 | ISB5.9 CM2880 B127 | 4383645
Gear Cover, Front | Refer to Procedure 001-031 | QSF3.8 CM2880 F112 | 4383825
Gear Cover, Front | Refer to Procedure 001-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Gear Cover, Front | Refer to Procedure 001-031 | QSL9.3 CM2880 L113 | 4383811
Gear Cover, Front | Refer to Procedure 001-031 | QSC8.3 CM2880 C102 | 4388785
Gear Cover, Front | Refer to Procedure 001-031 | QSB3.9 CM2880 B138 | 5411050
Gear Cover, Front | Refer to Procedure 001-031 | QSB5.9 CM2880 B139 | 4388870
Gear Cover, Front | Refer to Procedure 001-031 | ISD6.7 CM2880 D101 | 5411372
Gear Cover, Front | Refer to Procedure 001-031 | ISF4.5 CM2220 F123 | 5411320
Gear Cover, Front | Refer to Procedure 001-031 | QSG12 CM2880 G112 | 4388731
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG11 CM2880 G106 | 4332695
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG12 CM2880 G107 | 4332690
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG11 CM2880 G108 | 4332901
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | ISG12 CM2880 G109 | 4332906
Overhead Camshaft Timing Speed Ring | Refer to Procedure 002-034 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2120 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and speed/position sensors. |
 | STEP 1A. Inspect the engine speed and position sensors for damage. | Damage found?
 | STEP 1B. Inspect the tone wheels for any damage. | Damage found?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 2B. Inspect the gear train. | Damage found?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheels and speed/position sensors.

Guided Step 1A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed and position sensors for damage.

Damage found?
YES NO

Replace the speed or position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft removal and installation. Refer to Procedure 001-016 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation on ISG11 and ISG12 engines. Refer to Procedure 002-034 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation on all other engines. Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to top dead center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedure for ISG11 and ISG12 engines. Refer to Procedure 002-034 in the Associated Procedures Table.
  • Use the following procedure for all other engines. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Damage found?
YES NO

  • Repair the damaged components.
  • Use the appropriate service manual for repair procedure.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Oct-2017


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2120 B108 | 4326163
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2150 B109 | 4326168
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 | 4332741
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F108 | 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB7 CM2880 B117 | 4358390
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F104 | 4332741
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 F108 | 4332746
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F116 | 4383664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F129 | 5411325
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for fault code. | Fault Code 778 active or inactive?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the gear housing and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Reference the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check battery ground(s), engine block, and chassis ground. | Connections tight and corrosion-free?
 | STEP 3D. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3E. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3F. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle.

If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See the equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system];

During cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See the equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM power harness/OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM harness from the OEM power connector to the batteries.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3C - Check battery ground(s), engine block, and chassis ground.

Conditions

  • Turn keyswitch OFF.

Action

Check battery ground(s), engine block, and chassis ground.

  • Check all battery ground(s), engine block, and chassis ground for properly grounded, tightened, and free of corrosion.

See equipment manufacturer service information and wiring diagram for grounds information.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness/OEM harness connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM power harness/OEM harness connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM power harness/OEM harness connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the OEM power harness/OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 4A

Go to 3F

Guided Step 3F - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Apr-2017


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F104 QSF2.8 CM2880 F108 | 4332741 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB3.9 CM2220 B107 | 4310792
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G106 | 4332695
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G107 | 4332690
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9.5 CM2150 SN | 4310608
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2120 B108 | 4326163
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2150 B109 | 4326168
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB7 CM2880 B117 | 4358390
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG11 CM2880 G108 | 4332901
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISG12 CM2880 G109 | 4332906
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 K104 | 4332741
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 K108 | 4332746
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2880 L112 | 4358493
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B127 | 4383645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2880 F112 | 4383825
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2880 B126 | 4383693
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9.3 CM2880 L113 | 4383811
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F116 | 4383664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSC8.3 CM2880 C102 | 4388785
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.9 CM2880 B138 | 5411050
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB5.9 CM2880 B139 | 4388870
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISD6.7 CM2880 D101 | 5411372
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F129 | 5411325
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has a high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness engine control module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or has a high number of inactive counts?

If Fault Code 689 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Reference Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Check for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the primary engine speed sensor (crankshaft) from the engine block and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Oct-2017


FAULT CODE 2322 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2120 B108 | 4326163
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2150 B109 | 4326168
Engine Wiring Harness | Refer to Procedure 019-043 | QSB7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G108 | 4332901
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G109 | 4332906
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 K104 QSF2.8 CM2880 K108 | 4332741 4332746
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4358493
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.9 CM2880 B138 | 5411050
Engine Wiring Harness | Refer to Procedure 019-043 | QSB5.9 CM2880 B139 | 4388870
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB3.9 CM2220 B107 | 4310792
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL9.5 CM2150 SN | 4310608
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB4.5 CM2120 B108 | 4326163
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB6.7 CM2150 B109 | 4326168
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB7 CM2880 B117 | 4358390
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G106 | 4332695
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G107 | 4332690
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG11 CM2880 G108 | 4332901
Camshaft Position Sensor | Refer to Procedure 019-363 | ISG12 CM2880 G109 | 4332906
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 K104 | 4332741
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF2.8 CM2880 K108 | 4332746
Camshaft Position Sensor | Refer to Procedure 019-363 | ISL8.9 CM2880 L112 | 4358493
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB5.9 CM2880 B127 | 4383645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSF3.8 CM2880 F112 | 4383825
Camshaft Position Sensor | Refer to Procedure 019-363 | ISB/ISD6.7 CM2880 B126 | 4383693
Camshaft Position Sensor | Refer to Procedure 019-363 | QSL9.3 CM2880 L113 | 4383811
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF3.8 CM2220 F116 | 4383664
Camshaft Position Sensor | Refer to Procedure 019-363 | QSC8.3 CM2880 C102 | 4388785
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB3.9 CM2880 B138 | 5411050
Camshaft Position Sensor | Refer to Procedure 019-363 | QSB5.9 CM2880 B139 | 4388870
Camshaft Position Sensor | Refer to Procedure 019-363 | ISD6.7 CM2880 D101 | 5411372
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF2.8 CM2220 F129 | 5411325
Camshaft Position Sensor | Refer to Procedure 019-363 | ISF4.5 CM2220 F123 | 5411320
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 active or has a high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect the air gap and target wheel. | Air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active or has a high number of inactive counts?

If Fault Code 778 has a high number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

YES | NO
No Repair | No Repair

Reference Fault Code 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specifications?

  • Minimum Air Gap: 0.25 mm [0.009 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test for an intermittent fault condition.

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backward from the ECM connector toward the engine speed sensor connector.

Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM2880 G108 | 4332901
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM2880 G109 | 4332906
Engine Control Module | Refer to Procedure 019-031 | QSB7 CM2880 B117 | 4358390
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4358493
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F104 | 4332741
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F108 | 4332746
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2880 B126 | 4383693
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2880 F112 | 4383825
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | QSL9.3 CM2880 L113 | 4383811
Engine Control Module | Refer to Procedure 019-031 | QSC8.3 CM2880 C102 | 4388785
Engine Control Module | Refer to Procedure 019-031 | QSB3.9 CM2880 B138 | 5411050
Engine Control Module | Refer to Procedure 019-031 | QSB5.9 CM2880 B139 | 4388870
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 in the troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Oct-2017


FAULT CODE 3737 - Engine Starter Mode Overcrank Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there 10 or more inactive counts of Fault Code 3737 stored in the engine control module (ECM)?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Are there 10 or more inactive counts of Fault Code 3737 stored in the engine ECM?
YES NO

Use the appropriate troubleshooting symptom tree in the appropriate Service Manual.

  • Refer to Engine Will Not Crank or Cranks Slowly (Electric Starter) troubleshooting symptom tree in Section TS.
  • Refer to the Engine Performance troubleshooting symptom tree in Section TT.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Jun-2013


FAULT CODE 125 - Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | QSG12 CM2880 G112 | 4388731
Exhaust Restriction | Refer to Procedure 011-009 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 545?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge air cooler and charge air plumbing for leaks. | Air leaks present in the charge air system?
 | STEP 2B. Check for a restricted charge air cooler. | Charge air cooler restriction within specifications?
STEP 3. | Check the intake manifold pressure sensor. |
 | STEP 3A. Check the intake manifold pressure sensor. | INSITE™ electronic service tool reading within 127 mm-hg [ 5 in-hg ] of mechanical gauge reading?
STEP 4. | Check the turbocharger wastegate. |
 | STEP 4A. Check the turbocharger wastegate operation. | Turbocharger wastegate operating properly?
STEP 5. | Check the exhaust system restriction. |
 | STEP 5A. Check the exhaust system restriction. | Exhaust restriction within specifications?
STEP 6. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 122, 123, 221, 222, 295, or 545?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge air cooler and charge air plumbing for leaks.

Conditions

  • Operate engine.

Action

Check the charge air cooler and charge air plumbing for leaks.

  • Check the charge air cooler connections for leaks between the turbocharger compressor outlet and the charge air cooler.
  • Check the charge air cooler connections between the charge air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge air cooler hoses for leaks or loose connections.
  • Inspect the charge air cooler clamps to make sure they are tight.
  • Inspect the charge air plumbing for cracks.

Air leaks present in the charge air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for a restricted charge air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge air cooler.

  • Refer to Procedure 010-027 in Section 10.

Charge air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge air cooler as necessary.

Go to 3A

Go to 6A

Guided Step 3 - Check the intake manifold pressure sensor.

Guided Step 3A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical intake manifold pressure gauge to the engine, as close to the intake manifold pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 127 mm-hg [ 5 in-hg ] of mechanical gauge reading?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the turbocharger wastegate.

Guided Step 4A - Check the turbocharger wastegate operation.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Turbocharger wastegate operating properly?
YES NO
No Repair

Replace the turbocharger wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the exhaust system restriction.

Guided Step 5A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check the exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO

See the Intake Manifold Pressure (Boost) is Below Normal troubleshooting symptom tree in Section TS.

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2880 G112 | 4388731
Camshaft Position Sensor | Refer to Procedure 019-363 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold pressure sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the oil pressure sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the fuel rail pressure sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold pressure sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the oil pressure sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the fuel rail pressure sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the fault code. | Fault Code 221 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A malfunctioning barometric pressure sensor has been detected.

The barometric pressure sensor is internal to the ECM.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the fault code. | Fault Code 222 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A malfunctioning barometric pressure sensor has been detected.

The barometric pressure sensor is internal to the ECM.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the Engine Control Module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Engine Control Module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - Engine Control Module (ECM) bench top calibration harness and Part Number 4919009 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Society of Automotive Engineers (SAE) J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check for an open or short circuit in the J1939. | 50 to 70 ohms?
 | STEP 1D. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 1E. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the Society of Automotive Engineers (SAE) J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ 5 or later version data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic tool and connect to the ECM using INLINE™ 5 or later version (J1939) ECM connection.
  • Use INSITE™ electronic service tool to communicate with the ECM.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

See equipment manufacturer service information for information on troubleshooting and vehicle SAE J1939 data link network.

Go to 1B

Guided Step 1B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM Original Equipment Manufacturer (OEM) connector.

Action

Inspect the OEM harness and ECM OEM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for an open or short circuit in the J1939.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® engine ECM OEM connection to all other pins in the OEM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ 5 or later version data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using INLINE™ 5 or later version (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

See equipment manufacturer service information for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

See equipment manufacturer service information.

See the ECM - No Communication Troubleshooting Tree in TT section.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate fault code troubleshooting tree.

Last Modified: 18-Jun-2017


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSG12 CM2880 G112 | 4388731
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSG12 CM2880 G112 | 4388731
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 449 active or high inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Codes 1117, 271, 272, 553, or 2311 active or high inactive counts?
STEP 2. | Check the high-pressure fuel rail drain line restriction. |
 | STEP 2A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
STEP 3. | Inspect the fuel pressure relief valve. |
 | STEP 3A. Inspect the fuel pressure relief valve for tampering or wrong part number. | Is the correct fuel pressure relief valve part number installed and no tampering found?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 449 inactive?
 | STEP 5. Check if an Engine Control Module (ECM) calibration update is available. |
 | STEP 5A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1117, 271, 272, 553, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the high-pressure fuel rail drain line restriction.

Guided Step 2A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Inspect the drain line from the high-pressure relief valve to the Original Equipment Manufacturer (OEM) connection point for damage (obstructions, kinks, or crimps).

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012 in the Associated Procedures Table?
YES NO
No Repair

Replace the drain line or repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel pressure relief valve.

Guided Step 3A - Inspect the fuel pressure relief valve for tampering or wrong part number.

Conditions

  • Engine is not running.

Action

Make sure the correct fuel pressure relief valve part number is installed.

  • Look for tampering of the fuel pressure relief valve.

Is the correct fuel pressure relief valve part number installed and no tampering found?
YES NO
No Repair

Replace the fuel pressure relief valve.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault Code 449 inactive?
YES NO
No Repair

Replace the fuel pressure relief valve and fuel pump actuator.

Refer to Procedure 006-061 in the Associated Procedures Table. Refer to Procedure 019-117 in the Associated Procedures Table.

If replacing the fuel pressure relief valve does not resolve the issue, replace the fuel pump.

Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 5 - Check if an Engine Control Module (ECM) calibration update is available.

Guided Step 5A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 488. | Active or inactive counts of Fault Code 488?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 488.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 488?
YES | NO
No Repair | No Repair

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Repair complete.

Last Modified: 18-Jun-2017


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air in Fuel | Refer to Procedure 006-003 | QSG12 CM2880 G112 | 4388731
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSG12 CM2880 G112 | 4388731
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSG12 CM2880 G112 | 4388731
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 451, 452, 271, 272, or 2311 active or inactive with more than one count in the last 25 Engine Control Module (ECM) hours?
 | STEP 1B. Check for high counts inactive fault codes. | Fault Code 559 or 553 active or inactive with more than oen count in the last 25 ECM hours?
 | STEP 1C. Perform the fuel rail pressure sensor intermittent connection test. | Intermittent connection found?
 | STEP 1D. Inspect the fuel rail pressure sensor or connector pins. | Dirty or damaged pins?
STEP 2. | Check the fuel rail pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check drain line restriction. | Is fuel drain line restriction within the specifications outlined in Procedure 006-012?
 | STEP 3B. Check for air in the fuel. | Is there air in the fuel?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 4C. Monitor the fuel rail pressure at idle. | Does measured fuel rail pressure deviate from commanded fuel rail pressure by more than 100 bar [ 1450 psi ] and surge at idle?
 | STEP 4D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 451, 452, 271, 272, or 2311 active or inactive with more than one count in the last 25 Engine Control Module (ECM) hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for high counts inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 or 553 active or inactive with more than one count in the last 25 ECM hours?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Perform the fuel rail pressure sensor intermittent connection test.

Conditions

  • Turn keyswitch ON.
  • Engine not operating.

Action

Check for intermittent connection.

  • Use INSITE™ electronic service tool to perform fuel rail pressure sensor signal voltage intermittent connection test.

Intermittent connection found?
YES NO

An intermittent connection has been detected in the engine harness connector.

 No Repair

Go to 1D

Go to 2A

Guided Step 1D - Inspect the fuel rail pressure sensor or connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor.

Action

Inspect the fuel rail pressure sensor connector and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel rail pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool monitor.
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Refer to Procedure 006-071 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Is fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Note: Bubbles are an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

Is there air in the fuel?
YES NO

Check the source of air entry can be isolated to one of the following locations:

  • Suction fuel lines
  • Original Equipment Manufacturer (OEM) fuel lines
  • Electronic lift pump (if equipped)
  • Suction-side fuel filter assemblies including hand priming pump and thermal recirculating valve (if equipped)
  • Stand-pipes in the fuel tank(s). Refer to Procedure 006-020 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor commanded fuel rail pressure and measured fuel rail pressure.

Does measured fuel rail pressure deviate from commanded fuel rail pressure by more than 100 bar [ 1450 psi ] and surge at idle?

YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2017


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSG12 CM2880 G112 | 4388731
Fuel Pump Gear Pump | Refer to Procedure 005-025 | QSG12 CM2880 G112 | 4388731
Fuel System Priming | Refer to Procedure 005-234 | QSG12 CM2880 G112 | 4388731
Fuel System Diagnostics | Refer to Procedure 005-236 | QSG12 CM2880 G112 | 4388731
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | QSG12 CM2880 G112 | 4388731
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | QSG12 CM2880 G112 | 4388731
Pressure Fuel Filter | Refer to Procedure 006-065 | QSG12 CM2880 G112 | 4388731
Fuel Filter Suction | Refer to Procedure 006-066 | QSG12 CM2880 G112 | 4388731
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | QSG12 CM2880 G112 | 4388731
Lubricating Oil Dipstick | Refer to Procedure 007-009 | QSG12 CM2880 G112 | 4388731
Lubricating Oil Contamination | Refer to Procedure 007-044 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351, 451, 452, 2311, 3727, 3741, or 4691 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B. Check for inactive fault codes. | Fault Code 559 or 553 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B-1. Perform the fuel rail pressure sensor intermittent connection test. |
 | STEP 1C. Check lubricating oil level and lubricating oil contaminated. | Increased lubricating oil indicating fuel in oil?
 | STEP 1D. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
STEP 2. | Check engine operation. |
 | STEP 2A. Check for adequate fuel supply. | The equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Inspect for external fuel leaks. | Fuel leaks present?
STEP 3. | Check the low-pressure fuel system. |
 | STEP 3A. Measure the gear pump pressure. | Is the fuel gear pump pressure less than the specifications outlined in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3A-1. Measure the pressure drop at the pressure-side fuel filter. |
 | STEP 3B. Check the fuel inlet restriction at the gear pump inlet. | Is the fuel restriction within the specifications?
STEP 4. | Check the high-pressure fuel system. |
 | STEP 4A. Check the injector return flow. | Injector return flow is within specifications outlined in Procedure 005-236 in the Associated Procedures Table?
 | STEP 4B. Measure the high-pressure fuel rail return flow. | Fuel return flow is within specifications outlined in Procedure 005-236 in the Associated Procedures Table?
 | STEP 4C. Perform high-pressure fuel pump performance test. | High-pressure fuel pump output flow is within the specifications outlined in Procedure 005-236 in the Associated Procedures Table?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 351, 451, 452, 2311, 3727, 3741, or 4691 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 or 553 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B-1

Go to 1C

Guided Step 1B-1 - Perform the fuel rail pressure sensor intermittent connection test.

Conditions

  • Turn keyswitch ON.
  • Engine not operating.

Action

  • Use INSITE™ electronic service tool to perform fuel rail pressure sensor signal voltage intermittent connection test.

Intermittent connection found?
YES NO

An intermittent connection has been detected in the engine harness connector.

Check the damaged harness, connector, or pins. Refer to Procedure 019-361 in Section 19.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 1C

Guided Step 1C - Check lubricating oil level and lubricating oil contaminated.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil level for fuel in oil.

  • Refer to Procedure 007-009 in the Associated Procedures Table. Refer to Procedure 007-044 in the Associated Procedures Table.

Increased lubricating oil indicating fuel in oil?
YES NO

Check the injector high-pressure supply lines for leaks. Check for cracked injector(s). Replace the damage component. Refer to Procedure 006-026 in the Associated Procedures Table. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 1D

Guided Step 1D - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool monitor.
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Refer to Procedure 006-071 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2A

Go to 5A

Guided Step 2 - Check engine operation.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle fuel gauge. Verify there is fuel in the tank.

The equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank.

Go to 2B

Go to 5A

Guided Step 2B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle, or crank engine for up to 15 seconds if the engine will not start.
  • Check for fuel leaking from loose fittings, damaged fuel lines, and/or damaged components.

Fuel leaks present?
YES NO

  • Repair the fuel leak. See QSG12 CM2880 G112 Service Manual, Bulletin 4388731.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system.

Guided Step 3A - Measure the gear pump pressure.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

NOTE: This test can be performed if the engine will not start. See below.

Action

Measure the fuel gear pump pressure at rated conditions.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel gear pump pressure less than the specifications outlined in Procedure 005-236 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Measure the pressure drop at the pressure-side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Measure the pressure drop across the pressure-side fuel filter.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications?
YES NO
No Repair

Replace the fuel filter.

  • Refer to Procedure 006-065 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 3B - Check the fuel inlet restriction at the gear pump inlet.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

This test can not be performed if the engine will not start. If the engine will not start, check and make certain there are no kinks or bends in the suction-side fuel lines, and then replace the suction-side filters. If replacing the suction-side filters does not resolve the issue, replace the gear pump and proceed to Step 5A.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel restriction within the specifications?
YES NO

Replace the gear pump. Refer to Procedure 005-025 in the Associated Procedures Table.

If the inlet restriction is excessive, look for the root cause:

  • Suction-side fuel filters plugged
  • Fuel heater valves restricted
  • Electronic lift pump (if equipped)
  • Suction-side fuel filter assemblies including hand priming pump and thermal recirculating valve (if equipped)
  • Original Equipment Manufacturer (OEM) fuel lines pinched or restricted
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic wrapper, paper, and so forth) that can intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that can intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction-side fuel filter(s) and prime the fuel system.

  • Refer to procedures 006-066 in the Associated Procedure Table.
  • Refer to procedures 005-234 in the Associated Procedure Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the high-pressure fuel system.

Guided Step 4A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool fuel system leakage test ACTIVE (if available).

NOTE: This test can be performed if the engine will not start. See below.

Action

Check for excessive injector return flow.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow is within specifications outlined in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Refer to Procedure 005-236 in the Associated Procedures Table to isolate the leaking injector.

Repair or replace the damaged component.

Go to 4B

Go to 5A

Guided Step 4B - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Perform INSITE™ electronic service tool fuel system leakage test.

Note: This test can be performed if the engine will not start. See below.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

If the engine will not start, perform this test while cranking the engine.

Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel return flow is within specifications outlined in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

  • Replace the rail fuel pressure relief valve.
  • Refer to Procedure 006-061 in the Associated Procedures Table.

Determine the reason the fuel rail pressure relief valve has been tripping.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 4C

Go to 5A

Guided Step 4C - Perform high-pressure fuel pump performance test.

Conditions

  • Turn keyswitch ON.

Action

Perform high-pressure fuel pump performance test.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel pump output flow is within the specifications outlined in Procedure 005-236 in the Associated Procedures Table?

YES NO
No Repair

Remove fuel pump actuator, and check for stuck or blocked fuel pump actuator. If necessary, replace fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Perform Step 4C test again. If the high-pressure fuel pump output flow still can not meet the specification, replace the high-pressure fuel pump.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2017


FAULT CODE 1411 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 1695 active?
STEP 2. | Check the generator output frequency adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3695 active and Fault Code 1411 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1411 is active?
STEP 3. | Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1411 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695.

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the generator output frequency adjust potentiometer or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the generator output frequency adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active and Fault Code 1411 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the generator output frequency adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 VDC SUPPLY pin and the generator output frequency adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector to the generator output frequency adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 is active?
YES NO

A malfunction on generator output frequency adjust potentiometer or the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector and OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the generator output frequency adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator output frequency adjust potentiometer RETURN pin and the OEM harness sensor connector generator output frequency adjust potentiometer RETURN pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the generator output frequency adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 1695 active?
STEP 2. | Check the droop adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3696 active and Fault Code 1412 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1412 is active?
STEP 3. | Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695.

Go to 2A

Guided Step 2 - Check the droop adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the droop adjust potentiometer or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the droop adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 active and Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the droop adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer 5 VDC SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector to the droop adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 is active?
YES NO

A malfunction on droop adjust potentiometer or the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector and OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the droop adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector droop adjust potentiometer RETURN pin and the OEM harness sensor connector droop adjust potentiometer RETURN pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open droop adjust potentiometer RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the droop adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 1695 active?
STEP 2. | Check the gain adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3694 active and Fault Code 1418 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1418 is active?
STEP 3. | Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1418 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695.

Go to 2A

Guided Step 2 - Check the gain adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the gain adjust potentiometer or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the gain adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 active and Fault Code 1418 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the gain adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gain adjust potentiometer 5 VDC SUPPLY pin and the gain adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector to the gain adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 is active?
YES NO

A malfunction on gain adjust potentiometer or the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector and OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the gain adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector gain adjust potentiometer RETURN pin and the OEM harness sensor connector gain adjust potentiometer RETURN pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open gain adjust potentiometer RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the gain adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 1695 - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and Original Equipment Manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and Original Equipment Manufacturer (OEM) harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the droop adjust potentiometer from the OEM harness.
  • Disconnect the generator frequency adjust potentiometer from the OEM harness.
  • Disconnect the gain adjust potentiometer from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the sensor supply 5 circuit.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 1696 - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the droop adjust potentiometer and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the generator output frequency adjust potentiometer circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the gain adjust potentiometer circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and Original Equipment Manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1696 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the droop adjust potentiometer and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the droop adjust potentiometer from the OEM harness.

Action

Inspect the droop adjust potentiometer, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the droop adjust potentiometer from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the droop adjust potentiometer. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the generator output frequency adjust potentiometer circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator output frequency adjust potentiometer circuit from the OEM harness.

Action

Inspect the generator output frequency adjust potentiometer circuit, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the generator output frequency adjust potentiometer circuit from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair or replace the generator output frequency adjust potentiometer circuit. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the gain adjust potentiometer circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gain adjust potentiometer circuit from the OEM harness.

Action

Inspect the gain adjust potentiometer circuit, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gain adjust potentiometer circuit from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair or replace the gain adjust potentiometer circuit. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and Original Equipment Manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the droop adjust potentiometer from the OEM harness.
  • Disconnect the generator output frequency adjust potentiometer circuit from the OEM harness.
  • Disconnect the gain adjust potentiometer circuit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 5 pin and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the droop adjust potentiometer from the OEM harness.
  • Disconnect the generator output frequency adjust potentiometer circuit from the OEM harness.
  • Disconnect the gain adjust potentiometer circuit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 5 pin and the engine block ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 2185 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 is active?
STEP 3. | Check the Engine Control Module (ECM) OEM harness connector pins and OEM harness. |
 | STEP 3A. Inspect ECM OEM harness connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 2185 active?
YES | NO
No Repair | No Repair

See Fault Code 2185.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias sensor.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the generator speed/load governing bias sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the generator speed/load governing bias sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the generator speed/load governing bias sensor.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 VDC SUPPLY (sensor supply 4) pin and the generator speed/load governing bias RETURN (sensor return 4) pin at the OEM harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector to the generator speed/load governing bias sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 is active?
YES NO

A malfunction on generator speed/load governing bias sensor or the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) OEM harness connector pins and OEM harness.

Guided Step 3A - Inspect ECM OEM harness connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the generator speed/load governing bias sensor.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector and OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the generator speed/load governing bias sensor.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator speed/load governing bias RETURN pin and the OEM harness sensor connector generator speed/load governing bias RETURN pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias RETURN circuit has been detected in the OEM harnesses.

Repair or replace the OEM harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM OEM connector.
  • Disconnect the OEM harness connector from the generator speed/load governing bias sensor.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the OEM harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jun-2017


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 2186 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2185 active and Fault Code 2186 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 active?
STEP 3. | Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

See Fault Code 2186.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the generator speed/load governing bias potentiometer or OEM harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias potentiometer 5 VDC SUPPLY pin and the generator speed/load governing bias potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator speed/load governing bias potentiometer 5 VDC SUPPLY pin and the generator speed/load governing bias potentiometer SIGNAL pin at the OEM connector of the generator speed/load governing bias potentiometer.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active and Fault Code 2186 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES NO

A malfunction on the OEM generator speed/load governing bias potentiometer has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness Engine Control Module (ECM) connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness ECM connector or OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator speed/load governing bias potentiometer 5 VDC SUPPLY pin and the OEM harness generator speed/load governing bias potentiometer connector 5 VDC SUPPLY pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias potentiometer 5 VDC supply circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator speed/load governing bias potentiometer SIGNAL pin and the OEM harness generator speed/load governing bias potentiometer connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias potentiometer SIGNAL circuit has been detected in the OEM harnesses.

Repair or replace the OEM harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator speed/load governing bias potentiometer.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the generator speed/load governing bias potentiometer SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator speed/load governing bias potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jun-2017


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Consult a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, and so forth.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the Original Equipment Manufacturer (OEM) harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

See the appropriate circuit or wiring diagram for all engine harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 18-Jun-2017


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2185 inactive?
STEP 2. | Check the ECM and Original Equipment Manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2185 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and Original Equipment Manufacturer (OEM) harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the speed bias circuit from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 4 pin at the OEM harness ECM connector to all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the sensor supply 4 circuit.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the speed bias circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and Original Equipment Manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2186 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the coolant level sensor, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the coolant level sensor. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the speed bias circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Inspect the speed bias circuit, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the speed bias circuit from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Repair or replace the speed bias circuit. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and Original Equipment Manufacturer (OEM) engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 4 pin and all other pins in the connector.

See the circuit diagram or wiring harness for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 4 pin and the engine block ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel pump actuator. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and Engine Control Module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and Engine Control Module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine operating at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedure Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault codes inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 3694 - Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 1696 inactive?
STEP 2. | Check the gain adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1418 active and Fault Code 3694 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3694 active?
STEP 3. | Check the OEM harness ECM connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3694 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1696 inactive?
YES | NO
No Repair | No Repair

See Fault Code 1696.

Go to 2A

Guided Step 2 - Check the gain adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the gain adjust potentiometer or OEM harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gain adjust potentiometer 5 VDC SUPPLY pin and the gain adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gain adjust potentiometer 5 VDC SUPPLY pin and the gain adjust potentiometer SIGNAL pin at the OEM connector of the gain adjust potentiometer.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 active and Fault Code 3694 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector from the OEM gain adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 active?
YES NO

A malfunction on the OEM gain adjust potentiometer has been detected. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness ECM connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness ECM connector or OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector gain adjust potentiometer 5 VDC SUPPLY pin and the OEM harness gain adjust potentiometer connector 5 VDC SUPPLY pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open gain adjust potentiometer 5 VDC supply circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector gain adjust potentiometer SIGNAL pin and the OEM harness gain adjust potentiometer connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Secion 19.

Less than 10 ohms?
YES NO
No Repair

An open gain adjust potentiometer SIGNAL circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM gain adjust potentiometer.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 3695 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 1696 inactive?
STEP 2. | Check the generator output frequency adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1411 active and Fault Code 3695 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3695 active?
STEP 3. | Check the OEM harness ECM connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3695 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1696 inactive?
YES | NO
No Repair | No Repair

See Fault Code 1696.

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the generator output frequency adjust potentiometer or OEM harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 VDC SUPPLY pin and the generator output frequency adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator output frequency adjust potentiometer 5 VDC SUPPLY and the generator output frequency adjust potentiometer SIGNAL pin at the OEM connector of the generator output frequency adjust potentiometer.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 active and Fault Code 3695 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector from the OEM generator output frequency adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active?
YES NO

A malfunction on the OEM generator output frequency adjust potentiometer has been detected. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness ECM connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness ECM connector or OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator output frequency adjust potentiometer 5 VDC SUPPLY pin and the OEM harness generator output frequency adjust potentiometer connector 5 VDC SUPPLY pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer 5 VDC supply circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector generator output frequency adjust potentiometer SIGNAL pin and the OEM harness generator output frequency adjust potentiometer connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer SIGNAL circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM generator output frequency adjust potentiometer.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 3696 - Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2880 G112 | 4388731

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 1696 inactive?
STEP 2. | Check the droop adjust potentiometer circuit. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1412 active and Fault Code 3696 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3696 active?
STEP 3. | Check the OEM harness ECM connector pins and OEM harness. |
 | STEP 3A. Inspect OEM harness ECM connector pins and OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3696 inactive?
STEP 4. | Check if an ECM calibration update is available. |
 | STEP 4A. Compare the ECM code and revision to the calibration revision list. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1696 inactive?
YES | NO
No Repair | No Repair

See Fault Code 1696.

Go to 2A

Guided Step 2 - Check the droop adjust potentiometer circuit.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the droop adjust potentiometer or OEM harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer 5 VDC SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the droop adjust potentiometer 5 VDC SUPPLY pin and the droop adjust potentiometer SIGNAL pin at the OEM connector of the droop adjust potentiometer.
  • Check for appropriate response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 active and Fault Code 3696 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness connector from the OEM droop adjust potentiometer.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 active?
YES NO

A malfunction on the OEM droop adjust potentiometer has been detected. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness ECM connector pins and OEM harness.

Guided Step 3A - Inspect OEM harness ECM connector pins and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM OEM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness ECM connector or OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector droop adjust potentiometer 5 VDC SUPPLY pin and the OEM harness droop adjust potentiometer connector 5 VDC SUPPLY pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open droop adjust potentiometer 5 VDC supply circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector droop adjust potentiometer SIGNAL pin and the OEM harness droop adjust potentiometer connector SIGNAL pin.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open droop adjust potentiometer SIGNAL circuit has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness connector from the OEM droop adjust potentiometer.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the OEM harness ECM connector and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the OEM harnesses.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Compare the ECM code and revision to the calibration revision list.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


FAULT CODE 3741 - High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSG12 CM2880 G112 | 4388731
Fuel System Priming | Refer to Procedure 005-234 | QSG12 CM2880 G112 | 4388731
Fuel System Diagnostics | Refer to Procedure 005-236 | QSG12 CM2880 G112 | 4388731
Air in Fuel | Refer to Procedure 006-003 | QSG12 CM2880 G112 | 4388731
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSG12 CM2880 G112 | 4388731
Fuel Inlet Restriction | Refer to Procedure 006-020 | QSG12 CM2880 G112 | 4388731
Injector | Refer to Procedure 006-026 | QSG12 CM2880 G112 | 4388731
Pressure Fuel Filter | Refer to Procedure 006-065 | QSG12 CM2880 G112 | 4388731
Fuel Filter Suction | Refer to Procedure 006-066 | QSG12 CM2880 G112 | 4388731
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2880 G112 | 4388731
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2880 G112 | 4388731
Fuel Pump Actuator | Refer to Procedure 019-117 | QSG12 CM2880 G112 | 4388731

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 1117, 3727, or 2311 active or any inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check for air in the fuel. | Is there air in the fuel?
 | STEP 3B. Check the fuel inlet restriction at the Original Equipment Manufacturer (OEM) connection and gear pump. | Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
 | STEP 3C. Measure the pressure drop at the pressure-side fuel filter. | Is the fuel pressure drop within the specifications outlined in Procedure 005-236?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check drain line restriction. | Is the fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
 | STEP 5C. Monitor the fuel rail pressure at idle. | Does measured fuel rail pressure deviate more than 200 bar [ 2901 psi ] and surge at idle?
 | STEP 5D. Inspect the fuel pump actuator for damage. | Is the fuel pump actuator damaged?
STEP 6. | Check the Engine Control Module (ECM) to ground strap. |
 | STEP 6A. Inspect the ECM to ground strap. | Is the ECM to ground strap missing or are the connections degraded?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 271, 272, 1117, 3727, or 2311 active or any inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run INSITE™ electronic service tool monitor.
  • Fuel pressure relieved from the high-pressure fuel rail.
  • Engine not operating.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.
  • When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is running. Once the engine is keyed off, there can be a significant amount of time waiting on the rail to depressurize to zero. It is necessary to manually relieve the pressure from the high-pressure fuel rail.

Relieve the fuel pressure from the high-pressure fuel rail.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure 0 ± 43 bar [ 0 ± 624 psi ]?
YES NO
No Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Is there air in the fuel?
YES NO

The source of air entry should be isolated to one for the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipe(s) in the fuel tank(s).

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel inlet restriction at the Original Equipment Manufacturer (OEM) connection and gear pump.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Is the fuel inlet restriction within the specifications outlined in Procedure 006-020?
YES NO
No Repair

If fuel inlet restriction is excessive, search for the root cause:

  • Suction-side fuel filters plugged.
  • Fuel heater valves are restricted.
  • OEM fuel lines pinched or restricted.
  • Fuel tank stand pipes restricted.

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic, paper, and so forth) that can intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that can intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction-side fuel filter and prime the fuel system.

  • Refer to Procedure 006-066 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Measure the pressure drop at the pressure-side fuel filter.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Measure the pressure drop.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Is the fuel pressure drop within the specifications outlined in Procedure 005-236?
YES NO
No Repair

If the pressure from the gear pump is within specifications, replace the fuel filter and prime the fuel system.

  • Refer to Procedure 005-234 in the Associated Procedures Table. Refer to Procedure 006-065 in the Associated Procedures Table.

If the pressure from the gear pump is not within specifications, replace the gear pump.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Engine operating.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Is the fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair the source of the high fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Measure the fuel pump actuator resistance.

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator resistance within the specifications outlined in Procedure 019-117?
YES NO
No Repair

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 5C

Go to 7A

Guided Step 5C - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least 1 minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool to monitor commanded fuel rail pressure and measured fuel rail pressure.

Does measured fuel rail pressure deviate more than 200 bar [ 2901 psi ] and surge at idle?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5D

Guided Step 5D - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Remove the fuel pump actuator and inspect for damage (cut o-rings).

Refer to Procedure 019-117 in the Associated Procedures Table.

Is the fuel pump actuator damaged?
YES NO

Replace the fuel pump actuator. Follow the correct torque sequence in the following procedure.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the Engine Control Module (ECM) to ground strap.

Guided Step 6A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM to ground strap.

  • Check the ground connections from the cylinder block to battery (-) negative.
  • Check the ground from the ECM to the cylinder block. Refer to Procedure 019-008 in Section 19.

Is the ECM to ground strap missing or are the connections degraded?
YES NO

Repair missing or degraded ground connections. See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2017


FAULT CODE 5248- Tachograph Output Shaft Speed - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5248 active?
STEP 2. | Check the Original Equipment Manufacturer (OEM) generator set controller and Engine Control Module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which generator set controller multiplexed components are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM generator set controller multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5248 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault code.

Guided Step 2 - Check the Original Equipment Manufacturer (OEM) generator set controller and Engine Control Module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine which generator set controller multiplexed components are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM generator set controller multiplexing configuration component enables and OEM generator set controller source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the ECM multiplexed component enables and source addresses match the OEM generator set controllert multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM generator set controller multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a generator set controller, generator set controller setup, or generator set controller to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM generator set controller source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jun-2017


INDEX
418-fc111.htm

178-t05-111.htm

418-fc115.htm

178-t05-115.htm

418-fc122.htm

178-t05-122.htm

418-fc123.htm

178-t05-123.htm

418-fc125.htm

418-t05-125.htm

418-fc135.htm

178-t05-135.htm

418-fc141.htm

178-t05-141.htm

418-fc143.htm

178-t05-143.htm

418-fc144.htm

178-t05-144.htm

418-fc145.htm

178-t05-145.htm

418-fc146.htm

178-t05-146.htm

418-fc151.htm

178-t05-151.htm

418-fc153.htm

178-t05-153.htm

418-fc154.htm

178-t05-154.htm

418-fc155.htm

178-t05-155.htm

418-fc187.htm

418-t05-187.htm

418-fc195.htm

178-t05-195.htm

418-fc196.htm

178-t05-196.htm

418-fc197.htm

178-t05-197.htm

418-fc212.htm

178-t05-212.htm

418-fc213.htm

178-t05-213.htm

418-fc214.htm

00-t05-214.htm

418-fc221.htm

418-t05-221.htm

418-fc222.htm

418-t05-222.htm

418-fc227.htm

418-t05-227.htm

418-fc234.htm

178-t05-234.htm

418-fc235.htm

178-t05-235.htm

418-fc238.htm

178-t05-238.htm

418-fc239.htm

178-t05-239.htm

418-fc271.htm

178-t05-271.htm

418-fc272.htm

178-t05-272.htm

418-fc285.htm

178-t05-285.htm

418-fc286.htm

178-t05-286.htm

418-fc322.htm

00-t05-322.htm

418-fc323.htm

00-t05-323.htm

418-fc324.htm

00-t05-324.htm

418-fc325.htm

00-t05-325.htm

418-fc331.htm

00-t05-331.htm

418-fc332.htm

00-t05-332.htm

418-fc351.htm

178-t05-351.htm

418-fc415.htm

178-t05-415.htm

418-fc418.htm

178-t05-418.htm

418-fc421.htm

178-t05-421.htm

418-fc426.htm

418-t05-426.htm

418-fc428.htm

178-t05-428.htm

418-fc429.htm

178-t05-429.htm

418-fc441.htm

178-t05-441.htm

418-fc442.htm

178-t05-442.htm

418-fc449.htm

418-t05-449.htm

418-fc451.htm

178-t05-451.htm

418-fc452.htm

178-t05-452.htm

418-fc488.htm

418-t05-488.htm

418-fc553.htm

418-t05-553.htm

418-fc559.htm

418-t05-559.htm

418-fc649.htm

178-t05-649.htm

418-fc689.htm

178-t05-689.htm

418-fc697.htm

00-t05-697.htm

418-fc698.htm

00-t05-698.htm

418-fc731.htm

178-t05-731.htm

418-fc778.htm

178-t05-778.htm

418-fc1117.htm

178-t05-1117.htm

418-fc1411.htm

418-t05-1411.htm

418-fc1412.htm

418-t05-1412.htm

418-fc1418.htm

418-t05-1418.htm

418-fc1695.htm

418-t05-1695.htm

418-fc1696.htm

418-t05-1696.htm

418-fc1847.htm

00-t05-1847.htm

418-fc1852.htm

00-t05-1852.htm

418-fc1978.htm

418-t05-1978.htm

418-fc1979.htm

418-t05-1979.htm

418-fc1992.htm

418-t05-1992.htm

418-fc2185.htm

418-t05-2185.htm

418-fc2186.htm

418-t05-2186.htm

418-fc2311.htm

418-t05-2311.htm

418-fc2321.htm

178-t05-2321.htm

418-fc2322.htm

178-t05-2322.htm

418-fc2448.htm

00-t05-2448.htm

418-fc2661.htm

00-t05-2661.htm

418-fc2662.htm

00-t05-2662.htm

418-fc2765.htm

00-t05-2765.htm

418-fc2963.htm

00-t05-2963.htm

418-fc3694.htm

418-t05-3694.htm

418-fc3695.htm

418-t05-3695.htm

418-fc3696.htm

418-t05-3696.htm

418-fc3697.htm

178-t05-3697.htm

418-fc3737.htm

178-t05-3737.htm

418-fc3741.htm

418-t05-3741.htm

418-fc4642.htm

00-t05-4642.htm

418-fc5248.htm

418-t05-5248.htm